Last Comment Bug 592897 - perplexing experience when closing windows in Panorama [tabcandy-central]
: perplexing experience when closing windows in Panorama [tabcandy-central]
Status: RESOLVED WONTFIX
tabcandy-central
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
P4 normal
: Future
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-01 16:54 PDT by juan becerra [:juanb]
Modified: 2016-04-12 14:00 PDT (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image juan becerra [:juanb] 2010-09-01 16:54:24 PDT
http://hg.mozilla.org/try/rev/08d6e565ab29 Sept 1 tryserver build

Closing tabs can be a little confusing in Panorama. I was trying out Panorama's awareness of all tabs in all windows, when I got into a situation where I was prompted whether I wanted to close several tabs, when I was only trying to kill one window. Simply, I felt confused.

Steps:
1. Open two windows. Open several tabs in one of them.
2. Go into Panorama mode in both windows.
3. Create a group and drag the single tab in the first window onto it
4. Select the tab from step 3
5. Click on the close window icon

Expected: I should be able to close the window with no prompt to close several other tabs.

Actual: I get a message saying whether I want to close several tabs.

What's more, if I do select to close them, and I end up with no windows (the case at the moment), if I open another window and go into Panorama mode, I will see several blank tabs in a group corresponding at least in number to the group of tabs I closed.

At worse, it might not be handling my session data correctly.

This one is sort of special, so I will not refrain from asking to block despite it not being in mozilla-central.
Comment 1 User image Dietrich Ayala (:dietrich) 2010-09-03 10:22:44 PDT
Blocking+, since it's part of the all-windows in tabview work in bug 578512, which is blocking.
Comment 2 User image Aza Raskin [:aza] 2010-09-03 11:13:16 PDT
Hey Juan,

I'm confused as to your description. I think we should separate out the "Are you sure" message into a separate bug. The rest I think are just interim bugs that mitcho is working on (apparently we aren't as solid as we should be for the multi-window case).

Also see: https://bugzilla.mozilla.org/show_bug.cgi?id=576427#c27
Comment 3 User image Dietrich Ayala (:dietrich) 2010-09-07 11:02:35 PDT
swapping beta blocker flag because all-windows is canceled for this release.
Comment 4 User image Michael Yoshitaka Erlewine [:mitcho] 2010-09-16 18:47:53 PDT
Dietrich, did you intend to remove the blocking+? It still says blocking+ here for me.

Also, is this a dupe of bug 587245?
Comment 5 User image Ian Gilman [:iangilman] 2010-09-17 10:15:25 PDT
I think the point here is that in "all windows", we need to make sure to move the hidden tabs to another window when the user closes the window they're hosted in. In that way it's not a dupe of bug 587245, but it's also not relevant until we have bug 578512 back in the picture; punting to the future.
Comment 6 User image Ian Gilman [:iangilman] 2010-09-17 10:16:28 PDT
(also removed the blocking flag, which was dietrich's stated intention... not sure if that's the proper process)
Comment 7 User image Justin Dolske [:Dolske] 2016-02-03 16:10:25 PST
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.

Note You need to log in before you can comment on or make changes to this bug.