Closed Bug 59337 Opened 19 years ago Closed 19 years ago

Ability to set triggers for filters such as time or date

Categories

(MailNews Core :: Filters, enhancement, P3)

enhancement

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: netdragon, Assigned: alecf)

Details

There should be more actions and more ways to select when the filters occur

First, a user should set when the filter occurs - such as at a specified time, 
or when a specified action has occured (such as deleting), or when new messages 
arrive, or a specific time, etc - not just when new messages arrive.


Also, more options should be given of actions.

I am going to also add enhancement bugs on how to integrate macros and filters 
(I don't mean finding the area under the macros and filters functions silly :)

Perhaps filters could be renamed to rules so that people are not confused by the 
ability to do more than just searching - or maybe that isn't necessary.
Changed the Summary
Summary: Filter functionality → More filter functionality - more actions and triggers
Blocks: 59339
Blocks: 59341
please file specific bugs on the features you are expecting... if you're looking
for ideas, that's what newsgroups are for.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
This is a specific bug. This mostly has to do with the ability to set triggers 
for a filter since currently filters can be only triggered by new email. 
Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: More filter functionality - more actions and triggers → Ability to set triggers for filters such as time or date
No longer blocks: 59339
No longer blocks: 59341
Marking invalid - I will write a new bug that is more specific.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → INVALID
QA Contact: esther → laurel
Status: RESOLVED → VERIFIED
Marking verified (invalid)
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.