Javascript Filter actions (not criteria)

VERIFIED DUPLICATE of bug 11037

Status

MailNews Core
Filters
P3
enhancement
VERIFIED DUPLICATE of bug 11037
17 years ago
9 years ago

People

(Reporter: Brian 'netdragon' Bober, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

(Depends on: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Filters should have an action that can call a specified macro(s). That is it. 
check the dependancies for a definition of macros.
(Reporter)

Comment 1

17 years ago
Added dependancies - sorry alecf for the bug overload. I turned one stinky long 
bug into four good (in my opinion) bugs (enhancements).
Depends on: 59335, 59337

Comment 2

17 years ago
clarifying summary. there's no difference between a "Macro" and any other JavaScript

To clarify the difference between this bug and bug 59339, this is for having
normal filter criteria, but a special javascript-based ACTION when the filter is
hit.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Filter actions should have option of calling a macro → Javascript Filter actions
(Reporter)

Updated

17 years ago
No longer depends on: 59337
(Reporter)

Comment 3

17 years ago
I added the dependancy for actions. I will also explain the difference in 
definition between javascript and macros in bug 59335.
Depends on: 59369
(Reporter)

Updated

17 years ago
Summary: Javascript Filter actions → Javascript Filter actions (not criteria)

Comment 4

17 years ago
reassigning my filter bugs to gayatrib..
Assignee: alecf → gayatrib
(Reporter)

Comment 5

17 years ago
Adding depends.
Depends on: 13145
(Reporter)

Comment 6

17 years ago
This would appear as: "Run <Macro>" when someone clicks the drop down arrow on 
the left Action line.

Updated

16 years ago
QA Contact: esther → laurel
(Reporter)

Updated

16 years ago
Blocks: 66425

Comment 7

16 years ago
reassigning to naving
Assignee: gayatrib → naving

Comment 8

15 years ago
Dup of bug #11037?

Comment 9

15 years ago
I think that bug 59821(this), and bug 59341, and bug 59339 should be marked as
dupes of bug 11037.
mass re-assign.
Assignee: naving → sspitzer
Product: MailNews → Core

Comment 11

12 years ago

*** This bug has been marked as a duplicate of 11037 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

12 years ago
verified. The summary in bug 11037 stinks. I'm going to fix it.
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.