Last Comment Bug 593600 - D3D9 bugs - rendering corruption
: D3D9 bugs - rendering corruption
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://ie.microsoft.com/testdrive/per...
: 594354 (view as bug list)
Depends on: 596152
Blocks: d3d9-layers
  Show dependency treegraph
 
Reported: 2010-09-04 08:39 PDT by IU
Modified: 2010-09-16 19:52 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot #1: Corruption in IE FishTank Demo (678.52 KB, image/png)
2010-09-04 08:42 PDT, IU
no flags Details
Screenshot #2: Corruption in Group Your Tabs view (86.57 KB, image/png)
2010-09-04 08:43 PDT, IU
no flags Details
Video #1: rendering artifacts durring text transition (1.04 MB, video/x-msvideo)
2010-09-06 08:04 PDT, IU
no flags Details
Video #2: rendering artifacts durring sliding animation (305.00 KB, video/x-msvideo)
2010-09-06 08:10 PDT, IU
no flags Details

Description IU 2010-09-04 08:39:36 PDT
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre ID:20100904041009

Rendering corruption with layers.accelerate-all set to true.

As a aside: NOTICE THE TYPO in the Error Console message: "Direct3D 9 DeviceManager Initialized Succesfully." <--- s/Succesfully


Reproducible: Always

Steps to Reproduce:
Issue 1: Garbage rending or IE9 Fish Tank demo
--------
1. Create a new profile
2. Open about:config and set layers.accelerate-all to true
3. Check Error Console to make sure you see:
"Direct3D 9 DeviceManager Initialized Succesfully."
NOTE: There's also "CoCreateInstance() FAILED." in Error Console -- just above
4. Restart the browser
5. Visit: http://ie.microsoft.com/testdrive/performance/fishIE%20tank/default.html
6. Notice the corruption (see screenshot #1).

Issue 2: Garbage during tab opening animation
--------
7. Close the FishIE Tank tab
8. Click the "Open a new tab" tab bar button.
9. Notice the garbage text during tab opening animation.

Issue 3: Garbage in TabCandy/TabView/Panorama :-)
--------
10. Make sure you have two tabs open, with at least one of the tabs having a web page loaded, such as the "Minefield Start Page."
11. Click the "Group Your Tabs" tab bar button.
12. Notice the corruption (see screenshot #2).
Comment 1 IU 2010-09-04 08:42:36 PDT
Created attachment 472165 [details]
Screenshot #1: Corruption in IE FishTank Demo
Comment 2 IU 2010-09-04 08:43:42 PDT
Created attachment 472166 [details]
Screenshot #2: Corruption in Group Your Tabs view
Comment 3 IU 2010-09-04 08:50:26 PDT
My Hardware, based on Error Console:

Direct3D 9 DeviceManager Initialized Succesfully.
Driver: ati2dvag.dll
Description: ATI Radeon HD 4290
Version: 6.14.10.7111
Comment 4 IU 2010-09-04 09:27:28 PDT
Missed one:

Issue 4: Scrolling a textbox with text results in smearing (until the region is updated about 2-3 seconds later).
Comment 5 Vladimir Vukicevic [:vlad] [:vladv] 2010-09-04 10:48:56 PDT
How recent is your video driver?  ATI unfortunately uses different version numbering for their Catalyst packages and the version files (e.g. you have 6.14.10.7111, and the latest catalyst package seems to be "10.8")
Comment 6 IU 2010-09-04 11:27:47 PDT
(In reply to comment #5)
> How recent is your video driver?

Catalyst 10.8
Asus M4A89GTD Pro/USB3 (AMD 890GX integrated graphics)

If someone can get their hands on a board with the same chipset, should be pretty easy to reproduce.
Comment 7 IU 2010-09-04 11:33:30 PDT
Catalyst driver details: http://developer.amd.com/drivers/ccc/Pages/default.aspx
Comment 8 IU 2010-09-06 08:04:02 PDT
Created attachment 472401 [details]
Video #1: rendering artifacts durring text transition

I see this on the following website: http://lazarus.interclue.com/download.html
Comment 9 IU 2010-09-06 08:10:07 PDT
Created attachment 472404 [details]
Video #2: rendering artifacts durring sliding animation

Reproduced at this link: https://bug583548.bugzilla.mozilla.org/attachment.cgi?id=461865
Comment 10 IU 2010-09-06 08:14:26 PDT
Interestingly, I don't get these issue if I run these with Window XP in a VirtualBox VM.  There, everything is fine.  So there's a problem in the way Firefox is interacting with real hardware.

This leads me to wonder if some of you are writing the hardware acceleration code against virtual hardware and not testing it on real hardware.
Comment 11 IU 2010-09-07 05:25:31 PDT
It looks like Issues 1, 3, and 4 were resolved in the intervening period.

What remain are: Issue 2 and those represented in the videos (and of course, the typo).

If no one else sees otherwise, I will later dupe this to bug 593888 and attach the videos there.
Comment 12 Bas Schouten (:bas.schouten) 2010-09-07 05:29:44 PDT
That's interesting. I wonder what we did to fix them.
Comment 13 CruNcher 2010-09-07 16:31:26 PDT
It was also affecting https://bugzilla.mozilla.org/show_bug.cgi?id=589357 :) but now everything is fine
Comment 14 CruNcher 2010-09-07 16:35:59 PDT
Though there are still some rendering bugs with Image animations temporal truncations and also Grafx Bot shows many failing reftests but non of those seems as hurting as this problem was :)
Comment 15 CruNcher 2010-09-07 17:11:52 PDT
also experiencing currently the same text transition and image rendering problems (though im not sure if it's only for sliding images seems more a overall problem for changing images (javascript driven) :) also happens here http://www.arcinspirations.com/kobe/ if you move over the animated sections on top
Comment 16 Bas Schouten (:bas.schouten) 2010-09-07 17:22:41 PDT
(In reply to comment #15)
> also experiencing currently the same text transition and image rendering
> problems (though im not sure if it's only for sliding images seems more a
> overall problem for changing images (javascript driven) :) also happens here
> http://www.arcinspirations.com/kobe/ if you move over the animated sections on
> top

Hrm, those are looking pretty good for me. Could you add a screenshot of what you're seeing on this page?
Comment 17 CruNcher 2010-09-07 17:48:01 PDT
(In reply to comment #16)
> (In reply to comment #15)
> > also experiencing currently the same text transition and image rendering
> > problems (though im not sure if it's only for sliding images seems more a
> > overall problem for changing images (javascript driven) :) also happens here
> > http://www.arcinspirations.com/kobe/ if you move over the animated sections on
> > top
> 
> Hrm, those are looking pretty good for me. Could you add a screenshot of what
> you're seeing on this page?

Sure here

Moving mouse from Drinking (highlighted) over to Gallery

http://img844.imageshack.us/img844/8066/transitioncorrupt.png

Moving mouse fast between all sections

http://img8.imageshack.us/img8/9421/transitioncorruptextrem.png

The Changing text on the Lazarus page (effect looks familiar ;))

http://img715.imageshack.us/img715/7690/transitioncorruptlazaru.png

here also my latest Grafx Bot reftest 

http://brasstacks.mozilla.com/resultserv/data/results/6e95cc55-8613-41f9-bbe8-97bf1c6f6f22
Comment 18 Please Ignore This Troll (Account Disabled) 2010-09-08 11:30:46 PDT
*** Bug 594354 has been marked as a duplicate of this bug. ***
Comment 19 CruNcher 2010-09-16 10:05:41 PDT
Ehmm above Rendering Problems are gone in latest nightly on XP :)
Comment 20 IU 2010-09-16 10:23:49 PDT
(In reply to comment #19)
> Ehmm above Rendering Problems are gone in latest nightly on XP :)

I don't think the fixed the underlying bugs.  It seems they merely blacklisted the GPU, as hw acceleration doesn't appear to be enabled.  Will have to double-check when I get home.
Comment 21 Bas Schouten (:bas.schouten) 2010-09-16 13:25:11 PDT
(In reply to comment #20)
> (In reply to comment #19)
> > Ehmm above Rendering Problems are gone in latest nightly on XP :)
> 
> I don't think the fixed the underlying bugs.  It seems they merely blacklisted
> the GPU, as hw acceleration doesn't appear to be enabled.  Will have to
> double-check when I get home.

We should be blacklisting less than we used to.. or should be. Do double check.

I suspect this was fixed by fixing of bug 596152.
Comment 22 CruNcher 2010-09-16 14:52:45 PDT
@Bas Shouten 
What is blocking D3D9 on XP showing some actuall speedup in all the tests that get accellerated well under D2D and Win7. Chromes new GPU rendering http://blog.chromium.org/2010/09/unleashing-gpu-acceleration-on-web.html allready works under XP quite well even on your own http://demos.hacks.mozilla.org/openweb/HWACCEL/ test :) i get 66 fps with Chromes Hardware accelleration on XP and 11 either with layers on or of in Firefox :(
Comment 23 IU 2010-09-16 19:52:17 PDT
(In reply to comment #21)
> We should be blacklisting less than we used to.. or should be. Do double check.
> 
> I suspect this was fixed by fixing of bug 596152.

Confirming this fixed.

And yes, like CruNcher pointed out, Chrome 7's D3D9 acceleration on my XP system is almost twice the speed of Firefox, so something's wrong with the Firefox implementation.

Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre ID:20100916041016

http://hg.mozilla.org/mozilla-central/rev/f38ef1080bfe

Note You need to log in before you can comment on or make changes to this bug.