Some UI images become temporarily garbled when loaded with D3D9 and D2D on

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: hjalte, Unassigned)

Tracking

Trunk
x86_64
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100906 Firefox/4.0b6pre Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100906 Firefox/4.0b6pre Firefox/4.0b6pre

When opening a new tab, the new tab's favicon, close button, and the back button become garbled/corrupted for a moment.  Also, dragging two tabs together in Panorama causes the tab group outline to become corrupted, but only for a moment. 

D2D is enabled and layers.accelerate-all is true.

New tab example:  http://i53.tinypic.com/v5fq09.jpg
Panorama example: http://i54.tinypic.com/intohl.jpg

Reproducible: Always
Blocks: d3d9-layers
blocking2.0: --- → ?
Version: unspecified → Trunk
This also happens without D2D (i see this on WinXP), accelerated Layers turned on is sufficient.
OS: Windows 7 → Windows XP
That's the same basic thing I reported in Bug 593600.  I've attached videos, showing the problem, to that bug.
There's been a few times before where this doesn't occur, so I'm not sure about it always happening.
(In reply to comment #2)
> That's the same basic thing I reported in Bug 593600.  I've attached videos,
> showing the problem, to that bug.

I would agree, except I don't experience any of the problems that are reported
there, despite experiencing these.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Can people seeing the garbled image issue go into about:support and copy their Graphics information from the bottom into this bug?
Seeing this. Windows XP SP3. Also the issues from Bug 593600.

Here's the info from about:support :

  Graphics

        Adapter Description
        Radeon X1650 Series

        Vendor ID
        1002

        Device ID
        71c1

        Adapter RAM
        Unknown

        Adapter Drivers
        ati2dvag

        Driver Version
        8.593.100.0

        Driver Date
        2-10-2010

        Direct2D Enabled
        false

        DirectWrite Enabled
        false

      GPU Accelerated Layers Enabled
      1/1 Direct3D 9
Here you go:

---

Adapter Description: NVIDIA GeForce GT 230

Vendor ID: 10de

Device ID: 0603

Adapter RAM: 1536

Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2umDriver

Version: 8.17.12.5896

Driver Date: 7-9-2010

Direct2D Enabled: true

DirectWrite Enabled: true

GPU Accelerated Layers Enabled: 1/1 Direct3D 9
Just so you have more information, I am NOT seeing this issue on my system:

Adapter Description ATI Radeon HD 5800 Series
Vendor ID1002
Device ID 6898
Adapter RAM 1024
Adapter Drivers aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version 8.762.0.0
Driver Date 8-3-2010 
Direct2D Enabled: true
DirectWrite Enabled: true
GPU Accelerated Layers Enabled: 1/1 Direct3D 9
Adapter Description NVIDIA GeForce 9600M GT
Vendor ID 10de
Device ID 0649
Adapter RAM 512
Adapter Driver snvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version 8.17.12.5896
Driver Date 7-9-2010
Direct2D Enabled true
DirectWrite Enabled true
GPU Accelerated Layers Enabled 1/1 Direct3D 9
I'm affected by this bug:

Graphics
Adapter Description NVIDIA GeForce 8400 GS
Vendor ID 10de
Device ID 0422
Adapter RAM 256
Adapter Driver snvd3dum nvwgf2um,nvwgf2um
Driver Version 8.17.12.5721
Driver Date 6-7-2010
Direct2D Enabled true
DirectWrite Enabled true
GPU Accelerated Windows 1/1 Direct3D 9
Duplicate of this bug: 594753
Could this issue I'm seeing in this thread be related to this bug report?

See > http://forums.mozillazine.org/viewtopic.php?p=9865481#p9865481
Can people still reproduce this? We may have fixed it in another bug.
blocking2.0: ? → betaN+
I haven't seen it for a while now, since those other graphics bugs got fixed.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.