Closed Bug 593885 Opened 9 years ago Closed 9 years ago

Selecting a tab from a group to open, followed by closing window looses all panorama settings

Categories

(Firefox Graveyard :: Panorama, defect, blocker)

x86_64
macOS
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 587245

People

(Reporter: jose.fandos, Unassigned)

References

Details

(Keywords: dataloss)

Had 6 groups of tabs with a few groups containing just one tab. The latter were very small, so I opened the first to check what it was. After reviewing I didn't need that page information anymore, I closed the window. Going back to Panorama showed a single group with one tab (the one I was now apparently on) and the group with the introductory video of Panorama.

I would consider this dataloss. No warning of any kind was issued.

I believe (take with a pinch of salt) this happened before (with beta4), but magically after a restart, panorama recovered what was there before. Not so this time.
Steps to reproduce:

1. Open Firefox and add a few tabs to the current window.
2. Click on the "Group your tabs" button to bring about Panorama.
3. In the Panorama window, draw a new group and add a tab to it.
4. The tab is brought into a window, hiding Panorama.
5. Close the window.
6. Your Panorama with all its tabs is gone without a warning.

Expected Results:

After step 5 above, I would imagine that a warning should be shown, at the very least.

Even better would be to go back to Panorama. My intention when closing the window was to close the tab and remove it from Panorama. Panorama is working as a launcher of sorts. I don't expect it to go away with the window.
Blocks: 597043
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: dataloss
Resolution: --- → DUPLICATE
Duplicate of bug: 587245
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.