[OSX] black artifacts appear in window titlebar when scrolling a page with flash content

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: beltzner, Assigned: smichaud)

Tracking

unspecified
All
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [fixed by 596414])

Most likely related to bug 130078, spun off from bug 592453:

1. Go to http://tiff.net/filmsandschedules/tiff/2010/10to11
2. Scroll down on the page
3. Notice that there are artifacts in the titlebar

Screencap: http://grab.by/6iXv
Visible regression, so adding relnote.
blocking2.0: --- → betaN+
Keywords: relnote
Does it happen only if you have a persona? I don't, and I don't see this bug.
(Assignee)

Comment 3

8 years ago
I can't reproduce this either.

But I've found another (probably related) bug that I *can* reproduce.  More on that later when I open a new bug for it.
(Assignee)

Comment 4

8 years ago
> But I've found another (probably related) bug that I *can*
> reproduce.  More on that later when I open a new bug for it.

It's bug 595060.  But it turns out to be completely unrelated -- it
regressed about 9 months ago.
(In reply to comment #2)
> Does it happen only if you have a persona?

I think so.

Where were plugin NSViews in the NSView hierarchy before bug 130078, and where are they now?
(Assignee)

Comment 6

8 years ago
> Where were plugin NSViews in the NSView hierarchy before bug 130078,
> and where are they now?

They're still there, but they're now subviews of the top-level
ChildView.  So here's what I believe is the NSView hierarchy in a
browser window with a single plugin:

ToolbarWindow (an NSWindow)
  NSView (the content view)
    ChildView (same dimensions as the content view)
      ChildView (plugin view)

>> Does it happen only if you have a persona?
>
> I think so.

Any persona?
(Assignee)

Comment 7

8 years ago
(Following up comment #6)

Prior to bug 130078, there were three or four additional layers in the NSView hierarchy above the plugin view -- all ChildView objects.
Duplicate of this bug: 595670
with both personas Blue Floral Asbtract and Mozilla Test Pilot I also experienced this bug.
I can now also reproduce this, after having installed a Persona
more-or-less at random from the "What's New" startup page
(http://www.mozilla.com/en-US/firefox/3.6.9/whatsnew/) -- Red Ladybug.

It seems that any Flash	"video" will do -- not just one whose display
changes dynamically.  I used
http://www.playercore.com/bugfiles/146162/AddReturnHTML.html.

To see the problem (after a Persona has been installed), just scroll
the page until a (non-visible) part of the Flash "video" underlies the
title bar.

I tested in today's Minefield nightly on OS X 10.5.8.	

(I also tested on Windows, but didn't see the problem there.)
Assignee: nobody → smichaud
OS: All → Mac OS X
I have noticed the problem with Quicktime as well so I doubt this is Flash specific.
Duplicate of this bug: 596539
Do the patches in bug 596414 fix this?
I'll test myself as soon as I've built a 32 bit build...
Yes, they do.

This bug was caused by the subview exclusion loop in drawRect:inContext:. Bug 596414 removes this loop.
Before bug 130078, plugins weren't direct subviews of the top level ChildView, so the plugin rects weren't excluded from the drawing region.
Depends on: 596414
(In reply to comment #14)
> This bug was caused by the subview exclusion loop in drawRect:inContext:. Bug
> 596414 removes this loop.

... except for QuickDraw plugins. Maybe the subview exclusion loop should only subtract the widget's clip region, instead of the whole widget rect? I'm referring to the clip region that is set on it with StoreWindowClipRegion in nsChildView::ApplyConfiguration.
Quickdraw plugin drawing doesn't honor that region though. It does honor the SetWindow clipRect, so I think we should exclude *that*.

Let's let 596414 land first though before we do that. There are too many patches in flight.
Bug 596414 has landed, so this bug is fixed for all plugins except for those using QuickDraw.
I have a similar problem with Windows 7, the only difference is that the artifact is white, and I don't use any personas.
Here is a screenshot :
http://i.imgur.com/nvXYI.png
I think you are seeing bug 593703. If so could you add your hardware and driver info to that bug with your steps to reproduce. Thanks.

Comment 20

8 years ago
I'm unable to reproduce this on Mac OS X 10.5.8 using the Test Pilot persona and today's nightly build. I tried to repro with Silverlight and Flash, on YouTube and the example URLs given in this bug.
I haven't seen it recently, either, even with OpenGL turned off. Since I opened this up, I'm happy to RESO WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: relnote
Resolution: --- → WORKSFORME
Whiteboard: [fixed by 596414]
http://hg.mozilla.org/mozilla-central/rev/9c33280093f8 was needed for OpenGL layers, but was not OpenGL specific, so that makes sense.
Duplicate of this bug: 592068
Duplicate of this bug: 607054
You need to log in before you can comment on or make changes to this bug.