Android splash screen does not dismiss when accelerated layers is enabled

RESOLVED DUPLICATE of bug 605063

Status

()

defect
RESOLVED DUPLICATE of bug 605063
9 years ago
9 years ago

People

(Reporter: blassey, Assigned: blassey)

Tracking

unspecified
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec2.0b3+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Posted patch patch (obsolete) — Splinter Review
This patch implements nsSplashScreen for android and sends the progress events over the android java bridge.
Attachment #473955 - Flags: review?(mwu)
tracking-fennec: --- → ?
Posted patch patchSplinter Review
Assignee: nobody → blassey.bugs
Attachment #473955 - Attachment is obsolete: true
Attachment #473971 - Flags: review?(mwu)
Attachment #473955 - Flags: review?(mwu)

Comment 2

9 years ago
What patches do I need to apply this one?
Summary: Android splash screen does not dismiss what accelerated layers is enabled → Android splash screen does not dismiss when accelerated layers is enabled
I have it applied over the patch on bug 594553
OS: Linux → Android
Hardware: x86_64 → ARM
tracking-fennec: ? → 2.0b2+

Comment 4

9 years ago
Comment on attachment 473971 [details] [diff] [review]
patch

I don't see a splashscreen with this patch.
Attachment #473971 - Flags: review?(mwu)
Comment on attachment 473971 [details] [diff] [review]
patch

do you have --enable-splashscreen in your mozconfig?

Comment 6

9 years ago
(In reply to comment #5)
> Comment on attachment 473971 [details] [diff] [review]
> patch
> 
> do you have --enable-splashscreen in your mozconfig?

Turned it on and it crashed. Cleaned the embedding/android directory and then it started working. Will have to look into that at some point.
Probably need to add a dependency on autoconf.mk for our preprocessed files

Comment 8

9 years ago
Comment on attachment 473971 [details] [diff] [review]
patch

This does feel faster. It seems to feel faster regardless of whether we update the progress bar or not. Wonder what's going on.
Attachment #473971 - Flags: review?(mwu)
--enable-splashscreen/--disable-splashscreen don't seem to reliably enable/disable the progress meter.  With both, non-GL fennec starts fine, but also with both, I never see anything drawn with GL.  This is on a galaxy s.
(Note: I deleted $objdir/embedding/android in between changing --*-splashscreen.)
With --disable-splashscreen removed from my mozconfig, I don't get the splash screen; SW layers draw just fine; GL layers don't ever draw to screen.
This doesn't need to block b2 anymore since GL compositing has been pushed back to b3.
tracking-fennec: 2.0b2+ → 2.0b3+
There's a r+'d patch for this in bug 6050632; will land that soon.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 605063

Updated

9 years ago
Attachment #473971 - Flags: review?(mwu)
You need to log in before you can comment on or make changes to this bug.