[modern] Caret doesn't appear immediately on clicking in URL bar.

VERIFIED FIXED in Future

Status

()

Core
Editor
P3
minor
VERIFIED FIXED
17 years ago
12 years ago

People

(Reporter: Ilya Gulko, Assigned: kinmoz)

Tracking

({helpwanted})

Trunk
Future
x86
Windows 2000
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caret][correctness])

(Reporter)

Description

17 years ago
When the URL box is clicked, the cursor does not always appear right away. This
is non-standard behavior as far as text widgets go under Windows.

Perfect Reproducing:
Click on some HTML widget and watch the cursor blink. Wait until the cursor
disappears and then click on the URL box right away.

Actual Results:
The cursor does not appear right away after the click, but "waits" until the
next time it's supposed to blink.

Expected Results:
The cursor should appear right away after the click. Otherwise, the user may be
confused whether or not the text box actually recieved focus and may repeatedly
click on it until the cursor appears (aggravation).

Comment 1

17 years ago
Rewriting summary to indicate that the problem is the caret, not the cursor.
->xpapps, since this works in other text fields. confirming.
Assignee: trudelle → beppe
Status: UNCONFIRMED → NEW
Component: XP Toolkit/Widgets → Editor
Ever confirmed: true
QA Contact: jrgm → sujay
Summary: Cursor Misbehaving Upon URL Box Click → Caret doesn't appear immediately on clicking in URL bar.

Comment 2

17 years ago
Doh! really xpapps...
Assignee: beppe → don
Component: Editor → XP Apps
QA Contact: sujay → sairuh
Component: XP Apps → XP Apps: GUI Features
QA Contact: sairuh → claudius
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 4

17 years ago
This is a caret timing issue.
Assignee: vishy → anthonyd
Component: XP Apps: GUI Features → Editor

Comment 5

17 years ago
*** Bug 64167 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
0.9.1
Target Milestone: --- → mozilla0.9.1

Comment 7

17 years ago
move to mozilla1.0
URL: (none)
Keywords: correctness, helpwanted
Target Milestone: mozilla0.9.1 → mozilla1.0

Comment 8

17 years ago
From the dup I filed: this happens in all XUL text fields in Modern, but 
doesn't happen in Classic or in HTML forms.
Summary: Caret doesn't appear immediately on clicking in URL bar. → [modern] Caret doesn't appear immediately on clicking in URL bar.
if this is a theme issue, should this go to hewitt?

Comment 10

17 years ago
there is no way a caret problem is a themes issue

Comment 11

17 years ago
this is a caret draw issue i think.
Status: NEW → ASSIGNED
Whiteboard: [caret][correctness]

Comment 12

17 years ago
*** Bug 94101 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
*** Bug 94420 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
-->editor QA
QA Contact: claudius → sujay

Comment 15

17 years ago
--> kin
Assignee: anthonyd → kin
Status: ASSIGNED → NEW
(Assignee)

Comment 16

16 years ago
Bulk move of mozilla1.0 bugs to mozilla.1.0.1. I will try to pull some of these
back in if I can.
Target Milestone: mozilla1.0 → mozilla1.0.1
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0.1 → Future
Is this still an issue in current trunk builds?
(Reporter)

Comment 18

12 years ago
Martin, I just tested it with [1] and it is still a problem. It seems that there is a "caret on" flag that is not getting reset to "on" upon clicking.

Just to clarify -- this is the way native Windows widgets work. I just re-confirmed with Wordpad, IE6, Notepad, and Microsoft Word. This is also the way INPUT and TEXTAREA widgets appear to work within the HTML canvas.

[1] Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2 - Build ID: 2006030804
Ilya, please test with the latest nightly trunk build:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk
(Reporter)

Comment 20

12 years ago
Fixed! :)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060418 Firefox/3.0a1
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 21

12 years ago
Fixed by bug 287813?
(In reply to comment #21)
> Fixed by bug 287813?
Yes.
Depends on: 287813
Verified FIXED using build 2006-04-28-05 of SeaMonkey trunk under Windows XP.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.