Gmail.com fails to load email messages after JM merge

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: geeknik, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

(Whiteboard: [to be fixed by 596460])

(Reporter)

Description

8 years ago
Last night after I ran the hourly build with the JM merge, I noticed that Gmail was not loading email messages any more after you click on them. But if you refresh the page, the message you clicked on was marked as read.  The only error messages I can see when loading Gmail are these:

11:57:59.082: Exception: af is not defined Source File: https://mail.google.com/mail/?ui=2&view=js&name=main,tlist&ver=DVEloBQGiQ0.en.&am=!cuWC60aDNmuxhZziWvP2RiX_YjiW2M3B4Y6fsSrd8aeH2rF64Kk&fri Line: 48, Column: 0 Category: content javascript

11:57:59.094: Exception: af is not defined Source File: https://mail.google.com/mail/?ui=2&view=js&name=main,tlist&ver=DVEloBQGiQ0.en.&am=!cuWC60aDNmuxhZziWvP2RiX_YjiW2M3B4Y6fsSrd8aeH2rF64Kk&fri Line: 48, Column: 0 Category: content javascript

When I click on the email message, I see this:

12:00:35.239: Warning: Error in parsing value for 'display'.  Declaration dropped. Source File: https://mail.google.com/mail/?ui=2&view=bsp&ver=ohhl4rw8mbn4 Line: 0, Column: 8 Category: CSS Parser

12:00:35.258: Network: GET https://mail.google.com/mail/?ui=2&ik=1408d81653&view=ad&aav=2&th=12b049eb4b44a03c&search=mbox [HTTP/1.1 200 OK 491ms]

It looks like it retrieves the URL and the message just fine, however, it isn't displayed on the screen.

Changeset that I know was working:  84baf90b040c
Changeset that I noticed wasn't working:  f1bd314e64ac
I had this, cleared my cache and reloaded the page and it started working. No issues since. No idea why.

You've posted this under JavaScript - have you tested with JM and TM disabled?
(Reporter)

Comment 2

8 years ago
It is filed under JavaScript because when I set javascript.options.methodjit.content to false, it works just fine.
Have you tried a newer build? A few followup fixes went in, so it's worth a try.

/be
(Reporter)

Comment 4

8 years ago
This issue is still present in hourly build 389e836517bc.
WFM with that build.
(Reporter)

Comment 6

8 years ago
I just tried hourly build fc4dc7ff4e9a and it WFM now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

8 years ago
Something isn't working right. After I installed hourly build fc4dc7ff4e9a, it worked fine long enough for me to come here and say it was WFM, but it working and now I just installed hourly build b836c7151fc6 and the problem is still there. When I click on an unread email, it just marks it read but doesn't open it. I'm not seeing any errors in the Web Console either.

When I click on an email, this is what shows up in the Web Console:

15:22:14.137: Warning: Error in parsing value for 'display'.  Declaration dropped. Source File: https://mail.google.com/mail/?ui=2&view=bsp&ver=ohhl4rw8mbn4 Line: 0, Column: 8 Category: CSS Parser

15:22:14.158: Network: GET https://mail.google.com/mail/?ui=2&ik=1408d81653&view=ad&aav=2&th=12b0770c551994ec&search=mbox [HTTP/1.1 200 OK 297ms]

15:22:14.550: Network: GET https://pagead2.googleadservices.com/pagead/adview?ai=B8c8ZujaNTND5J4mImgf7rbi5C-uNy9MB29qgiBfAjbcBwN9yEAUYBSCGj4ACKAU4AFCeqKWe-v____8BYMmGgIDIpKwUoAH54cf8A7IBD21haWwuZ29vZ2xlLmNvbboBCGdtYWlsLWN2yAEB2gEyaHR0cDovL21haWwuZ29vZ2xlLmNvbS9NVE0wTmpRME5ESTBORGM0T0RVNE1URTFPREXIApXOrgeoAwHoA-0C6AOKA_UDBAAARA&sigh=O29BLaAUhZs [HTTP/1.1 200 OK 63ms]

As soon as I set javascript.options.methodjit.content to false, I don't have a single problem.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Okay, I take it back. I can still see this on and off. There is something really odd going on here.
blocking2.0: --- → ?
It is ok again with latest hourly build.

http://hg.mozilla.org/mozilla-central/rev/508d0a50827c
It just didnt worked in the same build. It's randomly working. Weird.

Comment 11

8 years ago
with the nighty build 20100913 i also have gmail problems, but not directly emails but i think it is the same,

first i open gmail, i see my inbox, then i open a message, reply on that (this seems to be the key) and after replying i cant go back to the inbox list. The list is always completely empty.
I have refresh/reload the browser window.
I dont see many things, no errors at all at that time, in the web console log.
Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100913 Firefox/4.0b6pre ID:20100913041656

I can confirm the problems with the STR from comment #11

Comment 13

8 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre

I just want to add that this is also happening on Mac OS X, sometimes type password and the page does not load, loading slow html verison also does not work. Sometimes just reloading the page multiple times fix the issue temporary. 
Changing javascript.options.methodjit.content to false makes no difference.

Updated

8 years ago
Duplicate of this bug: 596195

Comment 15

8 years ago
i think comment 13 describes something else then i do in comment 11

my problems are all fixed when i say:

javascript.options.methodjit.content=false
(Reporter)

Updated

8 years ago
OS: Windows 7 → All
Depends on: 596460

Comment 16

8 years ago
(In reply to comment #15)
> i think comment 13 describes something else then i do in comment 11
> 
> my problems are all fixed when i say:
> 
> javascript.options.methodjit.content=false

Doesn't seem to work for me. But Gmail seems to load and work properly for a while after a forced reload (ctrl+f5). But it's pretty random.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100914 Firefox/4.0b6pre
There may be two separate issues here.  Let's keep this bug open on the JM issue and get a new one filed on the cache issue, please?
(Reporter)

Comment 18

8 years ago
With hourly build 1cc1070b27ff, I've noticed that I can read emails in the Basic HTML view. Standard view is still unchanged.

Comment 19

8 years ago
confirmed here, using 4.0 pre-beta 6 20100913.
Can't ship without support for Gmail
blocking2.0: ? → beta7+
Confirmed that flipping the methodjit pref fixes the problem, indicting JM. Here's the interesting thing, though - I am pretty sure I was using GMail last night (from home in Toronto) without issue, and I haven't applied an update yet. Now it doesn't work (from the Mountain View office). Any chance that it's a change they're rolling out server-side that's causing the difficulty in pinning it down? (I know for SURE that I used GMail without issue after the JM merge)

Comment 22

8 years ago
I can reproduce this on Windows, but both Ben and Doug don't see it on Mac.
Yeah, I see it too, but a reload of the main page fixes it.
This bug is coming very randomly for me. Sometimes i cannot load gmail, sometimes gmail cannot load messages. A reload alwasy fixes the problem. Turning off JM for content fixes it permanently.
I haven't been able to reproduce this issue since about 2pm PT today; can anyone else?

Comment 26

8 years ago
Its still happening off and on... not predictable... currently Gmail is working in FF but don't know till when it will continue... A hard reload doesn't necessarily fix the problem in my case... Usually the problem is solved after updating to the latest nightly trunk before recurring after a couple of hours (sometimes even minutes)
@ Comment 21: I don't think its from Gmail server-side since I have been using IE8 and FF simultaneously for the last week or so... At the same instant, loading Gmail in both breaks the render in FF but not in IE so it seems to be a problem with the js rendering in FF itself.
I just got the bug with latest hourly build. http://hg.mozilla.org/mozilla-central/rev/bcca2c0c4805

Comment 28

8 years ago
for me it is very predictable if i enable methodjit for content gmail is completely unworkable

If i send myself an email, that is going fine, but if i reply to that email that i just send to my self it is a 100% failure, if i press send and then press Inbox or Priority Inbox that will always result in a empty page (at least the inbox area where the messages should be in is empty)

the thing that is disabled so methodjit for chrome is for me not a problem to have enabled.

this all with the nightly build of 20100916

Comment 29

8 years ago
@Johan: Indeed, that is bug 595828 (which may be the same bug).

So far, I haven't seen this on the 64-bit builds FWIW.
(Reporter)

Comment 30

8 years ago
I just installed hourly build 32b3aad80bb2 and Gmail loaded right up and I was able to load my email with methodjit enabled. =)
(In reply to comment #31)
> http://hg.mozilla.org/mozilla-central/rev/f1f07a0a036b merged earlier.

Oops, That was the top changeset of the tracemonkey merge on the pushlog today.
(Reporter)

Comment 33

8 years ago
After using it for a bit now, I'm still having intermittent problems, like the entire Inbox disappearing until I ctrl-F5, but at least now, I can read my email with methodjit turned on.
(Reporter)

Comment 34

8 years ago
So now with the inbox disappearing, I'm having layout issues:

http://i.imgur.com/pJQye.png

ctrl-F5 solves this. Temporarily.
The reload thing is a cache issue, not a JS one...  There's some known cache weirdness going on.

Updated

8 years ago
Duplicate of this bug: 596653

Comment 37

8 years ago
Using Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100917 Firefox/4.0b7pre.

A similar problem happens with Google calendar, and it appears the JS and caching issues are somehow interconnected.  These are the steps I take and behavior I get:

with javascript.options.methodjit.content as true:
1) log into Google calendar
2) create a calendar entry
3) click to edit entry
4) in edit entry screen, edit the entry in some way
5) click save

expected behavior:
1) entry will save with edits
2) will be able to edit any current calendar entry on the screen without having to hit control-f5

actual behavior:
1) entry edits will not save
2) unable to edit any current calendar entry until hitting control-f5.

with javascript.options.methodjit.content as false:
expected behavior:
1) entry will save with edits after clicking save once only
2) after saving entry screen will return to main calendar screen

actual behavior:
1) entry does not save and nothing actually happens until clicking save again
2) after clicking save twice, entry does save edits but returns to a blank calendar screen (i.e., notification that the entry was updated is provided but the calendar does not redraw).

In both cases, the web console shows the "too much recursion" error when clicking save the first time.  With methodjit turned off, at least the second time clicking save works fine.

Comment 38

8 years ago
I'm still having the Gmail problem using the Sep. 17 Minefield nightly build (Windows). 

Two days ago I could load Gmail, but with the problems mentioned earlier. Disabling javascript.options.methodjit.content fixed this problem. But Yesterday & Today I can't even load Gmail; the loading stops on the progress bar and never loads the inbox (tested with labs on and off, & with javascript.options.methodjit.content both enabled and disabled).
I'm hitting this quite often. It actually seems to be getting worse, not better.

Still no exact steps to reproduce, still quite random.

Comment 40

8 years ago
I still can't even load Gmail (Using 9-19 build). Always freezes at this point: http://img691.imageshack.us/img691/1473/62950001.png 

Even when cache is cleared, browser restarts, it still won't load. (This is with javascript.options.methodjit.content disabled).
> This is with javascript.options.methodjit.content disabled

That sounds like a separate issue from this bug, then.  Please file that as a separate bug?

Comment 42

8 years ago
(In reply to comment #41)
> > This is with javascript.options.methodjit.content disabled
> 
> That sounds like a separate issue from this bug, then.  Please file that as a
> separate bug?

No, disabling it has been one way of fixing the bug for some of the people commenting on this bug. (read some of the first comments)

It might deserve a second bug, but I personally don't think so. It's all related to this one.
This bug is about the issues JM causes on gmail.

Disabling JM means those issues are no longer present, no?  Bugs about issues that are only present when JM is on and issues that are also present when JM is off are definitely different bugs and need to be filed separately if they're both going to get fixed.

Comment 44

8 years ago
(In reply to comment #43)
> This bug is about the issues JM causes on gmail.
> 
> Disabling JM means those issues are no longer present, no?  Bugs about issues
> that are only present when JM is on and issues that are also present when JM is
> off are definitely different bugs and need to be filed separately if they're
> both going to get fixed.

Good point. Will do.

Comment 45

8 years ago
(In reply to comment #43)
> This bug is about the issues JM causes on gmail.
> 
> Disabling JM means those issues are no longer present, no?  Bugs about issues
> that are only present when JM is on and issues that are also present when JM is
> off are definitely different bugs and need to be filed separately if they're
> both going to get fixed.

I don't think it's clear that the bug being experienced here is only JM-related, on the assumption that the behavior noted in comment 37 is in fact the same bug that Gmail users are experiencing.  As far as I can make out, the steps in comment 37 are fully reproducible for me on separate profiles and machines. I have otherwise been unable to accurately reproduce the Gmail issue. If the behavior in comment 37 has a different cause (and the "too much recursion" with methodjit off is actually a different issue) I will gladly file a different bug or reopen bug 596653.
(In reply to comment #45)
> (In reply to comment #43)
> > This bug is about the issues JM causes on gmail.
> > 
> > Disabling JM means those issues are no longer present, no?  Bugs about issues
> > that are only present when JM is on and issues that are also present when JM is
> > off are definitely different bugs and need to be filed separately if they're
> > both going to get fixed.
> 
> I don't think it's clear that the bug being experienced here is only
> JM-related, on the assumption that the behavior noted in comment 37 is in fact
> the same bug that Gmail users are experiencing.

Please stop mixing things up. Bugs start out reporting symptoms or correlations (JM landed, gmail fails to load), and proceed toward causes. They may split up or combine during this process. It does not help to refuse to split when there are different factors, one of which (methodjit pref on) is required for symptom S but not for symptom T.

> As far as I can make out, the
> steps in comment 37 are fully reproducible for me on separate profiles and
> machines. I have otherwise been unable to accurately reproduce the Gmail issue.
> If the behavior in comment 37 has a different cause (and the "too much
> recursion" with methodjit off is actually a different issue) I will gladly file
> a different bug or reopen bug 596653.

Too much recursion is bug 596460, right? Separate symptom, independent of the methodjit pref setting, not this bug.

/be

Comment 47

8 years ago
Got it.  I'll undupe and reopen bug 596653 on the assumption that it is a separate bug unrelated to JM and this bug.
Echo'ing my own words: "Too much recursion is bug 596460, right?"

/be

Updated

8 years ago
Duplicate of this bug: 595684

Comment 50

8 years ago
Just realised that the problem occurs without fail whenever I reply to a mail. And my reply doesn't update into the mail thread as is conventional in Gmail.

Comment 51

8 years ago
Additional problem is that there is no possibilities to add an attachment to mail (always message "Attachment is too big" even if it's 1KB)

Comment 52

8 years ago
Had the same issue... drag dropping files into the FF windows works for me for the time being but i think someone needs to get this fixed promptly... not only is this a bug in the script engine but too many people work with gmail for the browser to break on loading the inbox...
Whiteboard: [to be fixed by 596460]

Comment 53

8 years ago
Interestingly, I can't reproduce this on a non-PGO build. If I make a profiledbuild then gmail breaks within minutes (if javascript.options.methodjit.content is true).

Comment 54

8 years ago
I can no longer reproduce this (javascript.options.methodjit.content is true) as of the 9/22 build. Gmail now loading and functioning properly, at least for me.
(In reply to comment #51)
> Additional problem is that there is no possibilities to add an attachment to
> mail (always message "Attachment is too big" even if it's 1KB)

Bug 596837

Comment 56

8 years ago
ok for me build of 20100923 also works, i cant reproduce it now anymore,
replying on mails and then back to the inbox works fine for me now.
(Reporter)

Comment 57

8 years ago
I'm still seeing this problem. Latest nightly (re-spin), Windows 7 Pro x64.
It's not fixed, we believe that we have a fix for the PGO-implicated issue.  Tomorrow's nightly might be to your liking, this bug will be updated when we think it's fixed.
Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100924 Firefox/4.0b7pre ID:20100924112647

FIXED (Bug 596460) on XP

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.