[modern theme] Can't switch tabs in sidebar

VERIFIED FIXED

Status

SeaMonkey
Sidebar
P1
major
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Dagfinn I. Mannsåker, Assigned: Blake Ross)

Tracking

({modern, regression})

Trunk
modern, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
On build 2000110821 Linux, i can't switch between the different tabs in the
sidebar. Nothing happens when I click a tab, not even on the console.

The only way to select a different tab is to clikc on "Tabs >", deselect the
wated tab, and then reselect it.

Comment 1

18 years ago
Confirming. This is a recent regression, 20001103 does not show this.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
adding keyw.
Keywords: regression

Comment 3

18 years ago
where did you get the build from ? This is not happening on the branch(1108) . I 
just checked on the trunk too(1108), worknig fine. What's a proper way to 
reproduce this ? Gimme details..pls.. 

Comment 4

18 years ago
I don't see any "110821" build on the ftp site.
(Reporter)

Comment 5

18 years ago
I got that build from ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-i686-pc-linux-gnu.tar.gz, which I have a cron job download and unpack every day at 10:00 CET.

I don't know whether that's a trunk or branch build, but it's the one that's linked from the front page on mozilla.org. Hope this helps

Comment 6

18 years ago
i cannot repro this. Anyone else seeing this ? 

Comment 7

18 years ago
i see it, with installed build 2000110906.
(installed with installer downloaded  from ftp.mozilla.org. Filename:
mozilla-i686-pc-linux-gnu-installer.tar.gz size 61258 bytes)
I don't see this with 2000110908 linux trunk....

Comment 9

18 years ago
In build 2000110906 it's theme related. Affects newmod, but not classic.
Keywords: newmod
OK.  I see this with 2000110908 and the modern theme.

With classic, all is happy.
Summary: Can't switch tabs in sidebar → [modern theme] Can't switch tabs in sidebar

Comment 11

18 years ago
adding Blake to CC since he's the last who touched sidebarOverlay.xul
(Assignee)

Comment 12

18 years ago
I don't understand this.  Just changing onclick="SidebarSelectPanel
(this,false,false);" to oncommand="SidebarSelectPanel(this,false,false);" makes 
this not work in Modern and Blue (oncommand never even seems to fire), but it 
works in Classic...

Anyone have any ideas?
Assignee: matt → blakeross

Comment 13

18 years ago
Yeah, I put a dump into the onclick handler for <box id="sidebar-panels" ...>
and added an oncommand handler with a dump as well.  In the modern skin 
(and blue and skypilot) the oncommand is clearly not being triggered by 
the click. But in ClassicWin, it is.

I wonder if it is related to a (possible) difference in user-focus (or other
such things). I see also that the sidebar has a special bindings file for 
Classic:
   themes/classic/communicator/sidebar/win/sidebarBindings.xml
(Assignee)

Comment 14

18 years ago
hrm, true.  But those seem to be windows-specific bindings, and others have 
reported this working in Linux classic.  this is a weird one...

well, if I can't make any progress on this by tomorrow, I can just revert back 
to onclick for now; that change wasn't critical to the patch being checked in 
(but will be important soon...)
Status: NEW → ASSIGNED
OS: Linux → All
Priority: P3 → P1
Hardware: PC → All

Comment 15

18 years ago
The linux Classic skin is, in fact, the Windows classic skin (with a few 
tweaks). So, it's not surprising that Classic will work correctly on both
windows and linux. [Although I still don't have a real answer as to why 
oncommand works in one skin and not the other for this case; Hey, I was 
hoping you'd have the answer by now :-]
(Assignee)

Comment 16

18 years ago
Ah.  I was just about to publicly wonder why unix had this line also: 
http://lxr.mozilla.org/seamonkey/source/themes/classic/communicator/sidebar/unix
/sidebar.css#65

Thanks. I'll investigate tomorrow...

Comment 17

18 years ago
Just a note: be wary of "./themes/classic/..../unix/..." files in the tree;
they may or may not be part of the classic skin on linux. You need to look
through the makefiles to be certain. (Yeah, this is confusing). Classic
on linux is pretty much the same files as Classic on windows, with a very
small number of tweaks for platform issues (e.g. background-color for 
textfields). 

Comment 18

18 years ago
 I am having the same problems with my Cool Blue theme (Win98 Mtrunk 2000111004).
Cool Blue is partially based of the old modern theme (I started working on it in
July). So, whatever is causing the problem, it has been in there for a long time
and has not caused any problems till today. Is Modern 2 based off the original
Modern or is it a complete rewrite? And, are other themes having the same
problems? I will download and isntall other themes to see if they can switch
sidebar tabs.

Comment 19

18 years ago
this is weird:
In build 2000111006 (?) i changed theme to classic, browse a little, verified
that the tab's worked, then changed back to modern. The next time i started
mozilla, the tab's worked again under *new modern* theme. Hoping it lasts..

Comment 20

18 years ago
 Ok, all Modern based themes are affected. All Classic themes aren't. Is this
related to the tooltips and chatzilla bug?

Comment 21

18 years ago
As i understand blake, there is yet no reason for changing onclick to oncommand.
Since the only effect it has for now is breaking all modern skins, it seems to
need some re-thinking before an eventually implementation?

Comment 22

18 years ago
*** Bug 59899 has been marked as a duplicate of this bug. ***

Comment 23

18 years ago
Ok, i see this too. On Windows, build 2000111120 (latest for today)

Comment 24

18 years ago
seems this bug is active in the installed builds, but not in the SEA builds (linux).

Comment 25

18 years ago
seems the tab's now also respond to drag-code - or try to:

a drag of a tab in classic shows this in console:
 Dragging DOM node: <box>

A drag of a tab in modern theme shows:
Hrm..not sure if I should be dragging this text.. but I'll try.
Dragging DOM node: <box>


None of the drag's do anything else than display these messages, however.
*** Bug 59914 has been marked as a duplicate of this bug. ***

Comment 27

18 years ago
happy happy spam spam..
There was something fishy with the SEA build from two days back. The bug is now
in those too. (2000111221)

Comment 28

18 years ago
*** Bug 59939 has been marked as a duplicate of this bug. ***

Comment 29

18 years ago
Just to confirm that I experience this bug too.  On the Nov 12, 2000 build.  
Win32 installer build

Comment 30

18 years ago
Created attachment 19155 [details] [diff] [review]
Fix from Dmitry Kubov

Comment 31

18 years ago
r=jag

Comment 32

18 years ago
Btw, here's what's going on:
The sidebar/win/sidebarBindings.xml file is always packaged (see top level
jar.mn), and referenced by both the win and the unix sidebar.css (though the
unix one is currently placed in a skins directory, instead of overriding the
windows one). The sidebar tab header binding defined in that xml file is made
from a button, which has oncommand, therefore making oncommand work in both unix
and win classic skin.

Yes, this is a mess.
*** Bug 59971 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 34

18 years ago
er...you can check that "fix" in if you want, but that just reverts back to the 
old way.  I'm trying to fix the cause.

Comment 35

18 years ago
blake: "the cause"? Then your fix would be that you'd need to make the tab
header a button in the chrome, not the skin. Do you really want that?
(Assignee)

Comment 36

18 years ago
If that's what it takes to use oncommand, then yes.  I'll try using both 
onclick and oncommand and see what happens.
(Assignee)

Comment 37

18 years ago
*** Bug 59986 has been marked as a duplicate of this bug. ***

Comment 38

18 years ago
sr=alecf
(Assignee)

Comment 39

18 years ago
temp fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
verified fixed on builds:

windows 2000-11-14-09-Mtrunk
linux 2000-11-14-06-Mtrunk
mac 2000-11-14-04-Mtrunk
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.