Closed Bug 596204 Opened 10 years ago Closed 9 years ago

"Save as" dialog on attachment, doesn't saves extension if Windows option "Hide extensions for known file types" isn't flagged

Categories

(Thunderbird :: Message Reader UI, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 414865

People

(Reporter: bhavneet_ahuja, Unassigned)

References

Details

(Keywords: platform-parity)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100824 Ant.com Toolbar 2.0.1 Firefox/3.6.9
Build Identifier: thunderbird 3.1.3

While reading mail has attachemnet if I need to save teh attachment by right click on attachment and save as, it does saves with file name but not extension, so file cant be straightaway opened. though rename with correct extension after saving is a workaround.

Reproducible: Always

Steps to Reproduce:
1.check a messag which has say word file as attachment
2 [review]. right click on attachment and save as
3.save to destination. The file will be saved but not known format. can open correctly with correct associated program with open with feature
Pasquale , can you reproduce ?
I hv already given steps to reproduce. Any attachment when saved to computer using the save as dialog will save file to destination but not the file extension I think, which is why the file is saved as all file not specific say .jpg or .doc

hope I am more clear
WFM

Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100914 Thunderbird/3.2a1pre ID:20100914032723

Bhavneet do you have an association in tools-->options-->attachments for *.doc file?
do you have enable to see also common extension part of file name in Windows XP?
I can confirm that happens when in Windows OS, you have flag folder option "Hide extensions for known file tupes" (uncheck this option via open some folder and the click on tools-->folder options... dialog).

Sound as dupe for me
It's a dupe of bug #298074 that is flagged as Expired.

Then I confirm this issue and flag it as New.

Maybe is only Windows OS related?

When the option is flagged, TB can show extension in attachments pane.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: pp
Summary: save as dialog on attachment from message reader window, doesn't saves extension of file → "Save as" dialog on attachment, doesn't saves extension if Windows option "Hide extensions for known file types" isn't flagged
Depends on: 298074
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414865
You need to log in before you can comment on or make changes to this bug.