Opening Panorama in resized window causes layout rearrangement

RESOLVED DUPLICATE of bug 601534

Status

P3
normal
RESOLVED DUPLICATE of bug 601534
8 years ago
3 years ago

People

(Reporter: shorlander, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 475755 [details]
Example of layout reflow problem

STR:

1. Carefully arrange and size groups in large/maximized window
2. Exit panorama by selecting a tab in a group
3. Shrink window
4. Enter panorama
5. Groups shift and resize in undesirable ways with no way to return to previous layout

Expected:

a) Scale groups proportionally as a unit

or

b) Remember layout and restore on resize
Scaling proportionally is the goal.
OS: Mac OS X → All
Priority: -- → P3
Hardware: x86 → All
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 601534

Comment 3

6 years ago
(In reply to Michael Yoshitaka Erlewine [:mitcho] from comment #1)
> Scaling proportionally is the goal.

Hi mitcho,

I think current behaviour still don't resolve the problem of when resize window, the group shift and resize in undesirable way, nor finish scaling proportionally. 

Could we reopen the bug? The problem always bother me alot.

Comment 4

6 years ago
Hi,

there is also another possibility of resolving this issue - allowing panorama workspace to be larger than window size. See https://bugzilla.mozilla.org/show_bug.cgi?id=671810. 
Actually it solves more issues that way.

Regards,
K.
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.