Display build architecture (32-bit or 64-bit) to the About dialog

VERIFIED FIXED in Firefox 51

Status

()

defect
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: scoobidiver, Assigned: cpeterson)

Tracking

Trunk
Firefox 51
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 affected, firefox50 wontfix, firefox51 verified)

Details

Attachments

(4 attachments)

Build : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre

In the about window of 64-bit Minefied, 4.0b7pre (released 09-18-2010) is displayed even if my UA string is the one above.
It must be noted that version updates are mixed in update history (see bug 585934 that depends on bug 572162)
Component: Menus → General
QA Contact: menus → general
Should I leave this bug opened or should I close it ?
In a different way, is it forecast to re-add the release date in the About window ?
Hardware: x86 → x86_64
Leave it open. Since we aren't releasing an official Win x64 of Firefox 4.0 chances are whether the about window should display that it is an x64 build will most likely be decided after Firefox 4.0 when people have time to spend on this.
Unable to duplicate. I have both Minefield Win32 and Minefield Win64 installed on Windows 7 Home Premium 64-bit, and my user-agent, "about:" URL, and About Minefield windows are all correct.
> Unable to duplicate. I have both Minefield Win32 and Minefield Win64 installed
> on Windows 7 Home Premium 64-bit, and my user-agent, "about:" URL, and About
> Minefield windows are all correct.
It was written about the release date which had been present a few days in About Minefield window.
Now that there is no more release date, I let it opened because there is no reference to x64 in About Minefield window as there is one for every 64-bit applications.
That's not only a problem on Windows. All platforms suffer from it. Go to "Help | Troubleshooting Information" and you will not be able to distinguish between 32bit and 64bit builds. While the removal is fine for the user agent string, it would still be great to have the architecture bits visible in the version name. Otherwise it will cause extra questions to the user from QA and Support, until we will be able to determine which version is in use.
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: When 32-bit and 64-bit minefield are installed, 64-bit about window shows 32-bit version name → 64-bit minefield builds don't show "64bit" in the version name to distinguish from 32-bit builds
(In reply to comment #5)
> That's not only a problem on Windows. All platforms suffer from it. Go to "Help
> | Troubleshooting Information" and you will not be able to distinguish between
> 32bit and 64bit builds. While the removal is fine for the user agent string, it
> would still be great to have the architecture bits visible in the version name.
> Otherwise it will cause extra questions to the user from QA and Support, until
> we will be able to determine which version is in use.

I definitely +1 this to have "64-bit" listed in the Help/About window. Although going to "about:" does give this info in the user-agent, it would be nice to have it explicitly stated elsewhere, without having to look for a *32 in Task Manager.
>I let it opened because there is no
>reference to x64 in About Minefield window

From the UX side of things, mentioning this information in the about window is fine.  However, we should not place this information in the window title, or application shortcut title (for instance IE and Photoshop have separate x64 shortcuts in the start menu).
(In reply to comment #7)
> From the UX side of things, mentioning this information in the about window is
> fine.  However, we should not place this information in the window title, or
> application shortcut title (for instance IE and Photoshop have separate x64
> shortcuts in the start menu).

We don't show this information anymore in the about window. It's only part of the Troubleshooting page. But I assume that your comment would also apply there?
Yeah, trouble shooting page is fine as well.  I'm just interested in us avoiding very top level things like shortcut and window title.
On Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121026030606 I see this in about:support

"User Agent
            

            Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:19.0) Gecko/19.0 Firefox/19.0"

Should this be consider fixed now?
Flags: needinfo?
(In reply to alex_mayorga from comment #10)
> Should this be consider fixed now?
No. The About Firefox window doesn't still mention 64 bits.
Flags: needinfo?
¡Hola Benjamin!

Shall this be a priority now that https://www.mozilla.org/en-US/firefox/43.0/releasenotes/ states "Firefox 64-bit for Windows is now available via the Firefox download page" ?

¡Gracias!
Flags: needinfo?(benjamin)
If a patch comes out, I'd find a reviewer for it, but I don't think it's a high priority.
Flags: needinfo?(benjamin)
I think it should be displayed in 
Help -> About Firefox

And then 32 Bit or 64 Bit version.
Duplicate of this bug: 1243933
Assignee: nobody → cpeterson
Blocks: support-win64
No longer blocks: tracking_win64
Summary: 64-bit minefield builds don't show "64bit" in the version name to distinguish from 32-bit builds → Display build architecture (32-bit or 64-bit) to the About dialog
This patch will append the build architecture, "(32-bit)" or "(64-bit)", to the Firefox version number in the About dialog, e.g. "48.0.2 (32-bit) <What's new>" or "51.0a1 (2016-09-05) (64-bit)". Adding a parenthetical "(64-bit)" after the Nightly or Aurora version number's parenthetical build date looks a little odd, but it's consistent.

I assume the "32-bit" and "64-bit" strings should be localized, though Chrome does not localize "(64-bit)" in the version number on its About page.

Also remove unused local variable `defaults`.
Attachment #8788320 - Flags: review?(dolske)
Here is a screenshot of what the Nightly and Aurora version numbers will look like with the parenthetical architecture after the build date.
Here is a screenshot of what the Beta and Release version numbers will look like with the parenthetical architecture between the version number and the <What's new> release notes link..
Comment on attachment 8788320 [details] [diff] [review]
about-dialog-64-bit.patch

Review of attachment 8788320 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/aboutDialog.js
@@ +45,5 @@
>    let version = Services.appinfo.version;
>    if (/a\d+$/.test(version)) {
>      let buildID = Services.appinfo.appBuildID;
>      let buildDate = buildID.slice(0, 4) + "-" + buildID.slice(4, 6) + "-" + buildID.slice(6, 8);
> +    versionField.textContent += " (" + buildDate + ")";

You use a template string below for ${arch}, so could do so here too...
Attachment #8788320 - Flags: review?(dolske) → review+
(In reply to Justin Dolske [:Dolske] from comment #19)
> > +    versionField.textContent += " (" + buildDate + ")";
> 
> You use a template string below for ${arch}, so could do so here too...

Thanks. I'll fix that before I land the patch.
Pushed by cpeterson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/838a2c3d46ef
Display build architecture (32-bit or 64-bit) to the About dialog. r=dolske
https://hg.mozilla.org/mozilla-central/rev/838a2c3d46ef
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Duplicate of this bug: 662917
I have reproduced this bug with Nightly 4.0b7pre on Windows 8.1(64 Bit!).

This bug's fix is verified on Latest Nightly 51.0a1.
Build ID : 20160908030434
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160907]
Thanks, Azmina!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.