All occurrences of question icon should be removed

NEW
Unassigned

Status

SeaMonkey
UI Design
17 years ago
6 years ago

People

(Reporter: Matthew Paul Thomas, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug], URL)

(Reporter)

Description

17 years ago
Many dialogs and alerts in Mozilla are using an icon of a question mark inside a 
speech bubble. This is bad UI -- firstly because the icon provides no useful 
information, and secondly because the user may think that the question mark means 
that the dialog or alert is providing user help. Mac OS has never had such an 
icon in its native alerts, and on Windows its use is discouraged
<http://msdn.microsoft.com/library/books/winguide/ch09f.htm>.

All occurrences of the question icon should be changed as follows.

* Where an alert is telling the user that a command the user gave could not be
  carried out because of an error, the error icon (white cross within a red
  circle on Windows, open hand within a stop sign on Mac OS) should be used.
  Example: `Mozilla could not check for new messages from imap.foo.bar because
  the mail server is not responding.'

* Where an alert is telling the user about anything other than an error, the info
  icon (`i' in a speech bubble on Windows, face with a speech bubble on Mac OS)
  should be used. Example: `The string "armadillo" was not found.'

* Where a dialog is asking the user to choose between two or more options, at
  least one of which is potentially destructive, the caution icon (`!' in a
  yellow triangle) should be used. Example: `Overwrite existing "KingFred.html"?'

* In any other situation, a dialog should either use a custom icon relating to
  the subject of the dialog (e.g. a keyring icon when asking for a password), or
  use no icon at all.
(Reporter)

Updated

17 years ago
Depends on: 43672

Comment 1

17 years ago
taking...
Assignee: ben → blakeross

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: P3 → P4
Target Milestone: --- → mozilla1.0

Comment 2

17 years ago
Matthew: should we skip the icon altogether, or do you know what icon to use?
(Reporter)

Comment 3

17 years ago
Håkan, the appropriate icons to use are described in the initial bug report 
above. If you have doubts about which one is appropriate for a particular 
dialog, just ask.
(Reporter)

Updated

17 years ago
Depends on: 81155

Comment 4

16 years ago
--> Ben
Assignee: blake → ben
Status: ASSIGNED → NEW
(Reporter)

Updated

16 years ago
Depends on: 94839
(Reporter)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → Future

Comment 5

15 years ago
Why is this dependant on bug 81155 ?
(Reporter)

Comment 6

15 years ago
Because the alert to be demolished in bug 81155 is one of the errant
question-mark-icon-using ones.

In other news: Since I filed this bug, the Gnome interface guidelines have been 
published. Like those for Windows and Mac OS, the guidelines for Gnome do not 
support the use of a question mark icon in any alert.
<http://developer.gnome.org/projects/gup/hig/1.0/windows.html#alert-windows>
Product: Core → Mozilla Application Suite
Assignee: bugs → nobody
Status: ASSIGNED → NEW
Priority: P4 → --
QA Contact: bugzilla → guifeatures
Target Milestone: Future → ---

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design

Comment 7

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 8

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 9

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 10

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 11

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 12

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 13

7 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → EXPIRED

Updated

6 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: EXPIRED → ---

Comment 14

6 years ago
Still valid, afaict.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Halloween2011Bug]
You need to log in before you can comment on or make changes to this bug.