Last Comment Bug 598920 - Remove button styling for buttons added to Addon Bar
: Remove button styling for buttons added to Addon Bar
Status: RESOLVED FIXED
[addon bar][target-betaN]
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 4.0b9
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on: 604531 620059
Blocks: 574688 598921
  Show dependency treegraph
 
Reported: 2010-09-23 06:07 PDT by Paul [pwd]
Modified: 2011-05-20 09:25 PDT (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Opera styling (15.55 KB, image/png)
2010-09-24 05:23 PDT, Paul [pwd]
no flags Details
Add-on Bar Button Styling Mockup (22.58 KB, image/png)
2010-09-29 04:47 PDT, Paul [pwd]
no flags Details
Add-on Bar Button Styling Tweaks (5.00 KB, image/png)
2010-10-17 08:32 PDT, Paul [pwd]
no flags Details
patch (5.87 KB, patch)
2010-11-22 07:35 PST, Dão Gottwald [:dao]
dietrich: review+
dietrich: approval2.0+
Details | Diff | Review

Description Paul [pwd] 2010-09-23 06:07:15 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre

Buttons added to the Addon Bar currently receive the same styling as those added to the Navigation Bar when in fact the styling should be closer to that of buttons added to the Tab Bar.

Reproducible: Always
Comment 1 [not reading bugmail] 2010-09-23 18:44:28 PDT
Well, then when I put all my widgets down there, what we really need to do this right is update the addon bar so its actually to be styled by the default theme.  

All those things on it to be the styled similarly.  Removing the buttons will just make it more statusbar like, weather its by glass or like the nav or bookmarks bar, themed or by lwtheme.
Comment 2 Paul [pwd] 2010-09-24 02:04:41 PDT
The plan is to retain some button styling, just not the default navigation bar button styling as those buttons feel cumbersome. I'm sure the UX Team has some ideas on this, if not, I'll be sure to try and come up with a mockup.
Comment 3 Paul [pwd] 2010-09-24 05:23:38 PDT
Created attachment 478239 [details]
Opera styling

Here is how Opera have styled their bottom bar. I propose we mimic the button style.
Comment 4 Dietrich Ayala (:dietrich) 2010-09-27 11:40:38 PDT
A mockup would be great, thanks Paul.
Comment 5 Paul [pwd] 2010-09-29 04:47:08 PDT
Created attachment 479351 [details]
Add-on Bar Button Styling Mockup

Apologies for the wait.

This shows the button in their three different states.
Comment 6 Paul [pwd] 2010-10-17 08:32:06 PDT
Created attachment 483842 [details]
Add-on Bar Button Styling Tweaks

I tried to play with the userChrome to get it to look proper, but had problems getting the borders and backgrounds back when hovering over the button. That said, it also raised some user experience concerns in cases of buttons with drop downs. It just didn't look intuitive. Anyway, this is a compromise I came up with.
Comment 7 Dão Gottwald [:dao] 2010-11-22 07:35:50 PST
Created attachment 492321 [details] [diff] [review]
patch
Comment 8 Paul [pwd] 2010-11-22 08:03:28 PST
Can we avoid pushing this until we get UX feedback on bug 609559. As it might negate this work.
Comment 9 Dão Gottwald [:dao] 2010-11-22 08:11:43 PST
(In reply to comment #8)
> Can we avoid pushing this until we get UX feedback on bug 609559.

No, I certainly don't want to wait for that bug. I don't think it would work for jetpack items anyway.
Comment 10 Paul [pwd] 2010-11-22 08:24:55 PST
(In reply to comment #9)
> (In reply to comment #8)
> > Can we avoid pushing this until we get UX feedback on bug 609559.
> 
> No, I certainly don't want to wait for that bug. I don't think it would work
> for jetpack items anyway.

Then post your argument against it in that bug so as that when the UX Team do review the idea, they're able to take your well grounded arguments into consideration.
Comment 11 Dietrich Ayala (:dietrich) 2010-11-23 00:08:20 PST
Comment on attachment 492321 [details] [diff] [review]
patch

thanks! patch doesn't apply however, and also do you need to make linux changes?
Comment 12 Dão Gottwald [:dao] 2010-11-23 01:52:08 PST
(In reply to comment #11)
> Comment on attachment 492321 [details] [diff] [review]
> patch
> 
> thanks! patch doesn't apply however, and also do you need to make linux
> changes?

It applies on top of bug 604531. Linux should be fine already.
Comment 13 Dietrich Ayala (:dietrich) 2010-11-30 00:40:35 PST
Comment on attachment 492321 [details] [diff] [review]
patch

After testing the patch, and loading some add-ons into the bar, I think this needs a couple of pixels on the right margin. The buttons look a bit crunched together otherwise. r=me with that change.
Comment 14 Dão Gottwald [:dao] 2010-11-30 00:59:07 PST
(In reply to comment #13)
> Comment on attachment 492321 [details] [diff] [review]
> patch
> 
> After testing the patch, and loading some add-ons into the bar, I think this
> needs a couple of pixels on the right margin. The buttons look a bit crunched
> together otherwise. r=me with that change.

On Windows, Linux, OS X or all of them?
Comment 15 Dão Gottwald [:dao] 2010-12-01 11:22:09 PST
(In reply to comment #14)
> (In reply to comment #13)
> > Comment on attachment 492321 [details] [diff] [review] [details]
> > patch
> > 
> > After testing the patch, and loading some add-ons into the bar, I think this
> > needs a couple of pixels on the right margin. The buttons look a bit crunched
> > together otherwise. r=me with that change.
> 
> On Windows, Linux, OS X or all of them?

ping?
Comment 16 Dietrich Ayala (:dietrich) 2010-12-01 11:31:42 PST
This was on Linux. I didn't test the patch on Mac or Windows.
Comment 17 Dão Gottwald [:dao] 2010-12-01 11:47:14 PST
Sounds like we should have a separate bug on that. I haven't touched Linux since it doesn't have the button styling that this bug refers to.
Comment 18 Dão Gottwald [:dao] 2010-12-15 13:33:45 PST
http://hg.mozilla.org/mozilla-central/rev/08c0399c5ff3
Comment 19 Matthew Turnbull [Bluefang] 2010-12-25 18:56:47 PST
Shouldn't the buttons have a hover effect? Not having one gives no tactile response that an icon is actually a button. IMHO this is especially important on the Windows theme, when there is little visual differentiation between a button's enabled and disabled states.
Comment 20 Dão Gottwald [:dao] 2010-12-26 01:37:41 PST
(In reply to comment #19)
> Shouldn't the buttons have a hover effect?

If you're using a classic Windows theme, bug 589236 is the bug you should watch.

Note You need to log in before you can comment on or make changes to this bug.