Add Status Bar text or progress URL notification text as core functionality (create a customize toolbar widget)

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
9 years ago
7 years ago

People

(Reporter: mozbugz, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100922 Firefox/4.0b7pre
Build Identifier: 

With Status Bar gone, and Addon bar replacing it, turn it into a widget so it can be put on any toolbar like other widgets.

Reproducible: Always

Actual Results:  
no functionality

Expected Results:  
custom functionality

Widget makes sense, it doesn't have to be primary UI but still allows users to use the functionality.
Reporter

Updated

9 years ago
Depends on: 574688
Version: unspecified → Trunk
Reporter

Comment 2

9 years ago
(In reply to comment #1)
> http://limi.net/articles/improving-download-behaviors-web-browsers/

That's actually for the download files widget.  I'm referring to the progress meter and status text like this extension Status-4-Evar: https://addons.mozilla.org/ru/firefox/addon/235283/
but have it built into firefox.
Summary: Convert Status Bar Download URL notification text into a customizable widget → Convert Status Bar progress URL notification text into a customizable widget
There's already an add-on for it (see above). Let's see how uptake goes, before considering putting it back into core.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX

Comment 5

9 years ago
Users should not have to install an add-on just to see where a link is going.

Displaying the URL in a visible and readable fashion (and the location bar doesn't do that), is in my opinion an important enough feature (primarily for security reasons) to have it in Firefox core.
Reporter

Updated

9 years ago
Summary: Convert Status Bar progress URL notification text into a customizable widget → Add Status Bar text or progress URL notification text as core functionality (create a customize toolbar widget)
Reporter

Updated

9 years ago
Duplicate of this bug: 610429

Comment 7

9 years ago
Well, the info is getting bounced all over the place, so I'll include it again here:

In Bug 610429, I outlined several usability considerations why keeping a status indicator around for some people may be of use.

I also brought up this issue on the mailing list, with even more details on why it may be a good idea to keep around: http://groups.google.com/group/mozilla.dev.usability/browse_thread/thread/61de2b33106843d7#

Again, I tried to present the case looking at it from a usability perspective (so there wouldn't be so much emotion tied into it).  I, personally, think implementing the two things I mentioned in the mailing list would practically eliminate most of the complaints that are coming in ... but anyways. :)
Reporter

Comment 8

9 years ago
(In reply to comment #5)
> Users should not have to install an add-on just to see where a link is going.

We actually have that part by hovering your mouse on links will show them in the Location Bar.  What we don't have is all the status text generated for loading/transferring web content after clicking on a link during loading... or transfering... (not counting the standard loading/connecting messages which are listed on the tabs).  Though Firebug kinda fills that gap for developers now, but not average users who grew up used to all these status updates and who care about their privacy and security because they are concerned about issues because websites add so much junk to their sites, they don't know what their browser is really doing or downloading without it.  The rest just use it as a security blanket or out of habit.
(In reply to comment #8)
> What we don't have is all the status text generated for
> loading/transferring web content after clicking on a link during loading... or
> transfering... (not counting the standard loading/connecting messages which are
> listed on the tabs).

Actually, we do — but only if enough time passes waiting for a request to complete — so it will say "waiting for ads.example.com" if it's too slow, but it won't flicker lots of messages as the page loads.

Comment 10

9 years ago
I'd like to point out that on the feeback link within the browser, when searching for "status bar", 87% of all responses have been marked as "issues" with most of them pointing out that they wanted the status bar back.

of the 10% of the "praise" when searching for "status bar", almost all of them say that they "praise" the new FF, but that they wish the status bar was back.


You may list this as a "Wontfix" but your user base has spoken.  

out of 122,253 total bits of feedback, 10,030 of them were related to "Status bar".  87% of that total is listed as an "issue" and most of your "praise" have sidenotes asking for the functionality back.

Face it, devs:  This was a BIG mistake.
Reporter

Comment 11

9 years ago
Also note: we changed the behavior to include a Status Overlay in bug 628654 and moved link hover in bug 541656 to the overlay from the URL bar.
Reporter

Updated

9 years ago
Depends on: 541656, 628654, 629304

Comment 12

9 years ago
Hopefully the new overlay thing you all are doing actually does it right, but ultimately, the OPTION to have a fully functional, traditional status bar without any need for an add-on should have remained from the get go.  I'm all for innovation, and some of the ideas you all have had are actually pretty good, but for me, the innovation you've put in to replace the status bar isn't enough (as of FF4b10 anyway) to justify it's complete removal. 

I want it back.  it's made my life harder not having it.  several of my plugins do not work with the Add-on bar for whatever reason.
Reporter

Comment 13

9 years ago
Plugins don't have anything to do with the addon bar or this bug.  If your seeing a specific problem, please file a new bug.
Reporter

Comment 14

9 years ago
(In reply to comment #12)
> I want it back.  it's made my life harder not having it.  several of my plugins
> do not work with the Add-on bar for whatever reason.

Your problem sounds like it might be caused by incompatible extensions with FF4. If so, please contact the extension authors and ask them to update them on the AMO site as that also nothing to do with this bug.

Comment 15

8 years ago
It looks like IE9 will be my browser of choice simply for this reason.
You need to log in before you can comment on or make changes to this bug.