Show connecting / waiting / loading status messages inside the add-on bar if enabled

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: WonderCsabo, Unassigned)

Tracking

({regression, ux-minimalism})

Trunk
regression, ux-minimalism
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [parity-IE])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre
Build Identifier: 

Bug 628654 will put the status messages into a popup on the top of content. If add-on bar is enabled this is a screen waste, because these messages can be put on the add-on bar itself.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 628654
Version: unspecified → Trunk

Comment 1

8 years ago
I use both the left and right sides of my Addon Bar.

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ux-minimalism
(In reply to comment #1)
> I use both the left and right sides of my Addon Bar.

We could make the status field movable / removable.

Comment 3

8 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > I use both the left and right sides of my Addon Bar.
> 
> We could make the status field movable / removable.

Removable would be my preference. But this does seem inconsistent. Not to mention what happens if a user wants to have the Addon Bar enabled but keep the popups?
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > I use both the left and right sides of my Addon Bar.
> > 
> > We could make the status field movable / removable.
> 
> Removable would be my preference. But this does seem inconsistent. Not to
> mention what happens if a user wants to have the Addon Bar enabled but keep the
> popups?

That user would remove the field.
I think I already opened a bug to make it custom widget then.
This may be a softblocker.

Comment 7

8 years ago
1) It's not completely screen space waste as the page is still loading and thus you don't care as much about what's getting covered up yet.
2) I think instead of showing this in the add-on bar it could simply be shown on top of the add-on bar. That's the simpler route and the bubble box moves out of the way on hover so it wouldn't obstruct usage of the add-on bar in the meantime.
Hardware: x86 → All
Summary: Show connecting / waiting / loading status messages in the add-on bar if enabled → Show connecting / waiting / loading status messages in/on the add-on bar if enabled
Adding the regression keyword, as the overhead of the popup with the bottom bar being displayed wasn't there in Firefox 3.6.

Also, last time I checked (months ago), IE 9 had a similar switch.
Keywords: regression
Whiteboard: [parity-IE]

Updated

8 years ago
Duplicate of this bug: 631428

Comment 10

8 years ago
this should include link urls, since those have also been moved down into the overlay (Bug 541656)

Updated

8 years ago
Blocks: 599212
I'm nominating this as a softblocker since in the process of trying to get down to zero bars, this has contributed (along with bug 627484 and bug 628179) in the user often having three bottom bars displayed on screen simultaneously.
blocking2.0: --- → ?
I don't think that we're going to restructure the Add-On Bar for this.
Status: NEW → RESOLVED
blocking2.0: ? → -
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
A patch for this would replace a removable empty spring with a removable flexing label. The overall structure would remain the same.

Comment 14

8 years ago
You could also just show the same popup over the add-on bar instead of content.
Dave, please file a separate bug on your suggestion. It's different from this one.

Comment 16

8 years ago
(In reply to comment #12)
> I don't think that we're going to restructure the Add-On Bar for this.

Why not?  Why show this popup on top of content when there is an empty bar right below it?

Comment 17

8 years ago
(In reply to comment #15)
> Dave, please file a separate bug on your suggestion. It's different from this
> one.

Sure. Filed bug 632626 as a separate bug for my comment 7 option 2.
Summary: Show connecting / waiting / loading status messages in/on the add-on bar if enabled → Show connecting / waiting / loading status messages inside the add-on bar if enabled
Can't you just add an item to the customize box which contains hovered link, just like the Status-4-ever addon.

Updated

8 years ago
Duplicate of this bug: 633166

Updated

8 years ago
Duplicate of this bug: 636998

Updated

8 years ago
Duplicate of this bug: 644242
You need to log in before you can comment on or make changes to this bug.