Last Comment Bug 599605 - Full update for nightly builds doesn't work, removes xul.dll
: Full update for nightly builds doesn't work, removes xul.dll
Status: VERIFIED FIXED
: regression
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: All All
: -- blocker (vote)
: seamonkey2.1b1
Assigned To: Frank Wein [:mcsmurf]
:
Mentors:
Depends on:
Blocks: 598644
  Show dependency treegraph
 
Reported: 2010-09-25 05:34 PDT by Bruno 'Aqualon' Escherl
Modified: 2010-09-27 13:53 PDT (History)
3 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (484 bytes, patch)
2010-09-25 07:03 PDT, Frank Wein [:mcsmurf]
kairo: review+
Details | Diff | Splinter Review
log of failed partial update from 20100925 to 20100926 (27.87 KB, text/plain)
2010-09-26 12:59 PDT, Bruno 'Aqualon' Escherl
no flags Details

Description Bruno 'Aqualon' Escherl 2010-09-25 05:34:36 PDT
Our nightly updates are broken. The partial update can't be applied and the full update removes xul.dll, so SeaMonkey won't start afterwards.
Comment 1 Frank Wein [:mcsmurf] 2010-09-25 07:03:27 PDT
Created attachment 478529 [details] [diff] [review]
Patch

Removes xul.* from removed-files.in as libxul now includes xul.dll
Comment 2 Justin Wood (:Callek) 2010-09-25 09:08:50 PDT
yea, thats whats I found in my slumber last night; but was too tired to verify stuff... land it!
Comment 3 Frank Wein [:mcsmurf] 2010-09-25 09:25:00 PDT
http://hg.mozilla.org/comm-central/rev/ea410ea7805e
Comment 4 Serge Gautherie (:sgautherie) 2010-09-25 19:09:43 PDT
Ftr,
bug 534689 added this for MOZ_STATIC_BUILD,
bug 598644 missed to remove these lines.
Comment 5 Bruno 'Aqualon' Escherl 2010-09-26 12:59:37 PDT
Created attachment 478670 [details]
log of failed partial update from 20100925 to 20100926

The full update from 24 to 26 worked, but the partial update from 25 to 26 failed (see attached log). Aftermath of the change or different issue?
Comment 6 Bruno 'Aqualon' Escherl 2010-09-27 13:53:26 PDT
(In reply to comment #5)
> Created attachment 478670 [details]
> log of failed partial update from 20100925 to 20100926
> 
> The full update from 24 to 26 worked, but the partial update from 25 to 26
> failed (see attached log). Aftermath of the change or different issue?
Frank filed bug 600000 for the partial issue.

Since full updates work:
-> V.Fixed

Note You need to log in before you can comment on or make changes to this bug.