Last Comment Bug 599731 - Move "Recently Closed" menus to Go menu
: Move "Recently Closed" menus to Go menu
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: unspecified
: All All
: -- enhancement (vote)
: seamonkey2.5
Assigned To: Edmund Wong (:ewong)
:
Mentors:
: 400503 (view as bug list)
Depends on: 670513 675672 702297
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-26 07:33 PDT by Aki Laaksovirta
Modified: 2011-12-23 09:21 PST (History)
6 users (show)
iann_bugzilla: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Moved "Recently Closed" menus to Go Menu. (5.32 KB, patch)
2011-07-07 06:49 PDT, Edmund Wong (:ewong)
iann_bugzilla: review+
Details | Diff | Review
Moved "Recently Closed" menus to Go Menu.(v2) [Checked in: Comment 9] (5.32 KB, patch)
2011-07-10 05:54 PDT, Edmund Wong (:ewong)
iann_bugzilla: review+
Details | Diff | Review

Description Aki Laaksovirta 2010-09-26 07:33:03 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.63 Safari/534.3
Build Identifier: 

I think that the "Recently Closed Tabs" and the "Recently Closed Windows" menus should be moved from the File menu to the Go menu.The reasons:

* They are not related to the current page, but they are rather a part of the "browsing history" in the broader sense.

*The File menu typically contains items that are related to opening or saving files.

Reproducible: Always
Comment 1 Misak Khachatryan 2010-09-26 09:33:06 PDT
I'm working on porting on demand restore session, deciding where to place it's menu entry. My first though is File menu, bug i decided to place it to Go menu. Also i propose rename Go menu to History, which will better reflect it's entries.
Comment 2 Aki Laaksovirta 2010-09-26 22:04:46 PDT
> Also i propose rename Go menu to History, which will better reflect it's
> entries.

I agree, but you should probably file a separate bug about that.
Comment 3 Jens Hatlak (:InvisibleSmiley) 2010-12-06 12:18:19 PST
Valid request, so confirming. Doesn't need to be decided now, though.
Comment 4 Edmund Wong (:ewong) 2011-07-07 06:49:42 PDT
Created attachment 544465 [details] [diff] [review]
Moved "Recently Closed" menus to Go Menu.
Comment 5 Ian Neal 2011-07-09 13:50:21 PDT
Comment on attachment 544465 [details] [diff] [review]
Moved "Recently Closed" menus to Go Menu.

>+++ b/suite/browser/navigatorOverlay.xul

>+        <menu label="&recentTabs.label;"
>+              accesskey="&recentTabs.accesskey;"
>+              id="menu_recentTabs">
Nit: I'd prefer the id to be first.
>+          <menupopup id="menu_recentTabsPopup"
>+                     onpopupshowing="updateRecentTabs(this);"
>+                     oncommand="gBrowser.undoCloseTab(event.target.value);"/>
>+        </menu>
>+        <menu label="&recentWindows.label;"
>+              accesskey="&recentWindows.accesskey;"
>+              id="menu_recentWindows">
Nit: id first please

>+++ b/suite/locales/en-US/chrome/browser/navigator.dtd
>@@ -14,22 +14,16 @@
>+<!ENTITY recentTabs.label "Recently Closed Tabs">
>+<!ENTITY recentTabs.accesskey "R">
You will have to change this accesskey, perhaps "C", as "Restore Previous Session" already uses "R".

>+<!ENTITY recentTabs.commandkey "t">
>+<!ENTITY recentWindows.label "Recently Closed Windows">
>+<!ENTITY recentWindows.accesskey "y">
>+<!ENTITY recentWindows.commandkey "y">
> <!ENTITY historyRestoreLastSession.label "Restore Previous Session">
> <!ENTITY historyRestoreLastSession.accesskey "R">

Does help need changing to reflect this new menu structure?
Comment 6 Edmund Wong (:ewong) 2011-07-10 05:33:16 PDT
*** Bug 400503 has been marked as a duplicate of this bug. ***
Comment 7 Edmund Wong (:ewong) 2011-07-10 05:50:54 PDT
(In reply to comment #5)
> Does help need changing to reflect this new menu structure?

Filed bug #670513.
Comment 8 Edmund Wong (:ewong) 2011-07-10 05:54:20 PDT
Created attachment 545069 [details] [diff] [review]
Moved "Recently Closed" menus to Go Menu.(v2) [Checked in: Comment 9]
Comment 9 Ian Neal 2011-07-12 08:14:52 PDT
Comment on attachment 545069 [details] [diff] [review]
Moved "Recently Closed" menus to Go Menu.(v2) [Checked in: Comment 9]

http://hg.mozilla.org/comm-central/rev/b1075fd310df
Comment 10 neil@parkwaycc.co.uk 2011-07-29 03:48:43 PDT
(In reply to comment #5)
>(From update of attachment 544465 [details] [diff] [review])
>>+<!ENTITY recentTabs.label "Recently Closed Tabs">
>>+<!ENTITY recentTabs.accesskey "R">
>You will have to change this accesskey, perhaps "C", as "Restore Previous
>Session" already uses "R".
Why not "T"?

Would it make sense to group all the session restore items together?
Comment 11 Ian Neal 2011-07-29 05:14:57 PDT
(In reply to comment #10)
> (In reply to comment #5)
> >(From update of attachment 544465 [details] [diff] [review] [diff] [details] [review])
> >>+<!ENTITY recentTabs.label "Recently Closed Tabs">
> >>+<!ENTITY recentTabs.accesskey "R">
> >You will have to change this accesskey, perhaps "C", as "Restore Previous
> >Session" already uses "R".
> Why not "T"?
I do keep forgetting that "T" has a fairly wide underscore when an accesskey.
> 
> Would it make sense to group all the session restore items together?
Indeed that is an option, could both be done in a spin off bug...
Comment 12 neil@parkwaycc.co.uk 2011-08-01 02:27:47 PDT
(In reply to comment #11)
> (In reply to comment #10)
> > (In reply to comment #5)
> > >(From update of attachment 544465 [details] [diff] [review])
> > >>+<!ENTITY recentTabs.label "Recently Closed Tabs">
> > >>+<!ENTITY recentTabs.accesskey "R">
> > >You will have to change this accesskey, perhaps "C", as "Restore Previous
> > >Session" already uses "R".
> > Why not "T"?
> I do keep forgetting that "T" has a fairly wide underscore when an accesskey.
> > Would it make sense to group all the session restore items together?
> Indeed that is an option, could both be done in a spin off bug...
Of course. I only mention it because I had to build Firefox to debug bug 671466 and I liked the order that they've put their menuitems in.
Comment 13 Edmund Wong (:ewong) 2011-08-01 02:47:59 PDT
(In reply to comment #11)

> > Would it make sense to group all the session restore items together?
> Indeed that is an option, could both be done in a spin off bug...

Spun off bug #675589.
Comment 14 neil@parkwaycc.co.uk 2011-08-01 10:02:50 PDT
The code to enable and disable the menus was unfortunately hidden away at the end of updateCloseItems. This needs to be moved into a new function so that it can be called from the go popup.
Comment 15 Ian Neal 2011-08-01 10:49:03 PDT
The relevant code to be moved starts at http://mxr.mozilla.org/comm-central/source/suite/browser/navigator.js#1500
You will need to add a onpopupshowing to the "history-menu" http://mxr.mozilla.org/comm-central/source/suite/browser/navigatorOverlay.xul#380
This could probably be done in bug 675672 as part of that work.
Comment 16 Jens Hatlak (:InvisibleSmiley) 2011-11-19 09:11:11 PST
added bug 599731 / bug 702297 to Known Issues

Checking in seamonkey2.5/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/index.en.html,v  <--  index.en.html
new revision: 1.10; previous revision: 1.9
done

Note You need to log in before you can comment on or make changes to this bug.