[SeaMonkey] Linux Mochi-1 test_2d.composite.uncovered.image.destination-atop.html failing

RESOLVED FIXED in seamonkey2.1b2

Status

SeaMonkey
Testing Infrastructure
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: Callek, Assigned: Callek)

Tracking

(Blocks: 2 bugs, {intermittent-failure})

Trunk
seamonkey2.1b2
x86
Linux
intermittent-failure
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sm-perma][cc-orange])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
SeaMonkey just encountered this: 

s: cb-seamonkey-linux-01
29984 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/test_2d.composite.uncovered.image.destination-atop.html | pixel 15,15 is 255,255,255,1; expected 0,0,0,0 +/- 5
29985 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/test_2d.composite.uncovered.image.destination-atop.html | pixel 50,25 is 255,255,255,1; expected 0,0,0,0 +/- 5

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1285807366.1285809754.10904.gz

Per vlad over IRC this could be caused by an old/outdated X11 version, after logging into the SeaMonkey slave where this failed:

------
[seabld@cb-seamonkey-linux-01 ~]$ X -version

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.9-42.0.3.ELsmp i686 Red Hat, Inc.
Current Operating System: Linux cb-seamonkey-linux-01 2.6.18-8.el5 #1 SMP Thu Mar 15 19:57:35 E
DT 2007 i686
Build Date: 15 March 2007
Build ID: xorg-x11-server 1.1.1-48.13.el5
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
[seabld@cb-seamonkey-linux-01 ~]$
-------

I could not glean from brief IRC nor the wiki what X11 version Firefox machines are running.

CC-ing Nthomas for the answer to that, and CC-ing KaiRo as I'm not sure the proper steps to update this for us. [yes I know KaiRo will likely not be able to fix until after vienna meeting late oct, but he might be able to give me guidance before then if we know what X11 ver to upgrade to]
(Assignee)

Updated

8 years ago
Depends on: 600120

Comment 1

8 years ago
We're running our tests on CentOS 5 build machines as we don't have the amount of hardware to run an independent talos pool for tests. Firefox runs tests on some newer Fedora talos machines instead.
Our setup regarding to that won't change in a while, the request for machines we filed a year ago and which isn't granted yet (due to some people being unsure if our project is worth supporting that way) is only for more build machines, and I'm pretty sure we won't get talos any time soon - unless I can make something wondrous happen next week in my talk with people in MV.

Comment 2

8 years ago
Oh, and I'm pretty sure there's no easy way to upgrade anything here, not just because X is a very large and integrated piece of the system, but also because upgrading X on those machines would mean being unable to run our builds on any older X versions, as we'd compile against the new version as well.
(Assignee)

Comment 3

8 years ago
Ok... disable the test it is then. :/

Comment 4

8 years ago
(In reply to comment #3)
> Ok... disable the test it is then. :/

I fear that's the only thing we can do right now - even though I wonder if something's really broken here for users on older Linux versions which are still supported by Firefox and SeaMonkey.
(Assignee)

Updated

8 years ago
Assignee: nobody → bugspam.Callek
(Assignee)

Updated

8 years ago
Summary: [SeaMonkey] Linux Mochi-1 test_2d.composite.uncovered.image.destination-atop.html possibly due to X11 version → [SeaMonkey] Linux Mochi-1 test_2d.composite.uncovered.image.destination-atop.html failing
(Assignee)

Comment 5

8 years ago
Created attachment 480019 [details] [diff] [review]
disable it for SeaMonkey Linux

I am assuming the order if these tests should not matter.
Attachment #480019 - Flags: review?(khuey)
Attachment #480019 - Flags: feedback?(vladimir)
(Assignee)

Comment 6

8 years ago
Created attachment 480020 [details] [diff] [review]
disable it for SeaMonkey Linux

...and qref the right patch
Attachment #480019 - Attachment is obsolete: true
Attachment #480020 - Flags: review?(khuey)
Attachment #480020 - Flags: feedback?(vladimir)
Attachment #480019 - Flags: review?(khuey)
Attachment #480019 - Flags: feedback?(vladimir)

Comment 7

8 years ago
I removed this bug from the landing queue as the patch is still waiting for feedback.  Feel free to add it back when the feedback has been granted.
Attachment #480020 - Flags: feedback?(vladimir) → feedback+
(Assignee)

Comment 8

8 years ago
http://hg.mozilla.org/mozilla-central/rev/cd22150c60ca
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Target Milestone: --- → seamonkey2.1b2
OS: Windows XP → Linux
Keywords: intermittent-failure
Whiteboard: [sm-perma][orange] → [sm-perma]

Updated

6 years ago
Whiteboard: [sm-perma] → [sm-perma][cc-orange]
You need to log in before you can comment on or make changes to this bug.