Open Bug 716404 Opened 11 years ago Updated 11 years ago

[SeaMonkey] Disable tests from their source (at run-time), not from Makefile (at build-time)

Categories

(SeaMonkey :: Testing Infrastructure, defect)

defect
Not set
minor

Tracking

(Not tracked)

REOPENED

People

(Reporter: sgautherie, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug, )

Details

1. Check that this test still fail: it's likely to.
   NB: This probably (= just) needs to revert bug 600767 fix, as a first step.
2. Disable it from (run-time) html (with a todo()), not from (build-time) Makefile.
Ah well, there are (just) a few more tests in similar situation.
OS: Linux → All
Hardware: x86 → All
Summary: [SeaMonkey, Linux] Check and fix test_2d.composite.uncovered.image.destination-atop.html being disabled → [SeaMonkey] Disable tests from their source (at run-time), not from Makefile (at build-time)
Depends on: 598252, 598360, 635825
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
(In reply to Justin Wood (:Callek) from comment #2)
> *** This bug has been marked as a duplicate of bug 640464 ***

I agree bug 640464 (when done) could be used to solve this bug too.
But, currently,
bug 640464 is long-term, to rework how a lot of (duplicated) SeaMonkey tests are handled,
whereas this bug is short term, to fix a handful of Core/Toolkit cases.
We already have "various" Core/Toolkit tests disabled/adapted at runtime.
Status: RESOLVED → REOPENED
Depends on: 640464
Resolution: DUPLICATE → ---
No longer depends on: 598360
You need to log in before you can comment on or make changes to this bug.