insert or paste tab character fails in textarea

RESOLVED DUPLICATE of bug 596001

Status

()

RESOLVED DUPLICATE of bug 596001
8 years ago
8 years ago

People

(Reporter: mozilla.blen4reg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.10) Gecko/20100915 Ubuntu/10.04 (lucid) Firefox/3.6.10
Build Identifier: firefox 3.6.9

Regression: if you try to insert a hard tab character into a html textarea element, the result is inconsistent starting with version 3.6.9. If the cursor is on an empty line, an actual hard tab character is inserted. If the line of the cursor is not an empty line, four spaces are inserted instead of the tab character.

Note: pressing the Tab key does not insert anything in general, it moves the focus. This report is not about this. Using other means (e.g. copy-paste) to insert tab characters used to work reliably until firefox 3.6.8, it changed behavior since that as described above.

Reproducible: Always

Steps to Reproduce:
1. Open a web page that contains a html textarea, e.g. http://c2.com/cgi/wiki?edit=WikiWikiSandbox
2. Prepare some text containing tab characters (or even a single tab character) in a text editor
3. Copy-paste the text into the html textarea
Actual Results:  
Upon pasting, the tab characters are replaced with four spaces.

Exception: if the cursor is on an empty line, the tab characters are inserted correctly.

Expected Results:  
The tab characters are supposed to appear as hard tab characters in the textarea.

The regression also breaks the extension Tabinta: http://tabinta.mozdev.org/

This extension is for inserting Tab characters into a textarea. It uses the cmd_insertText command for text insertion.
Looks like a duplicate of bug 577240 except for that "used to work in 3.6.8 bit.... Ehsan?

Comment 2

8 years ago
This is actually a dupe of bug 596001 (a regression from bug 336104 which was fixed by bug 592592).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596001
You need to log in before you can comment on or make changes to this bug.