Closed Bug 601562 Opened 9 years ago Closed 9 years ago

Update Modern theme from missingPlugin.css to pluginProblem.css

Categories

(SeaMonkey :: Themes, defect)

defect
Not set

Tracking

(blocking-seamonkey2.1 final+)

RESOLVED FIXED
seamonkey2.1final
Tracking Status
blocking-seamonkey2.1 --- final+

People

(Reporter: neil, Assigned: ewong)

References

Details

(Keywords: modern)

Attachments

(1 file, 6 obsolete files)

Bug 539848 replaced missingPlugin.css with pluginProblem.css and bug 547292 added support for crashed plugins.

Conveniently many of the styles were factored out into pluginProblemContent.css so they can now be removed from the theme.
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #485685 - Flags: review?(neil)
Attachment #485685 - Flags: review?(neil) → review?(neil)
Attachment #485685 - Attachment is obsolete: true
Attachment #485689 - Flags: review?(neil)
Attachment #485685 - Flags: review?(neil)
Comment on attachment 485689 [details] [diff] [review]
Renamed missingPlugin.css to pluginProblem.css

Well it's a start. I guess we need a followup patch or bug to get the rest of the changes ported.

>diff --git a/Makefile.in b/Makefile.in
>--- a/Makefile.in
>+++ b/Makefile.in
>@@ -62,10 +62,10 @@ default alldep all:: $(topsrcdir)/config
> 
> ifndef INCLUDED_BRIDGE_MK
> include $(topsrcdir)/bridge/bridge.mk
>-endif
> 
> # workaround Bug 599809 by making these makefiles be generated here
> SUBMAKEFILES += $(addsuffix /Makefile, $(APP_LIBXUL_DIRS) $(APP_LIBXUL_STATICDIRS))
>+endif
I don't think you meant to attach this bit ;-)
Attachment #485689 - Flags: review?(neil) → review+
(In reply to comment #3)

> >diff --git a/Makefile.in b/Makefile.in
> >--- a/Makefile.in
> >+++ b/Makefile.in
> >@@ -62,10 +62,10 @@ default alldep all:: $(topsrcdir)/config
> > 
> > ifndef INCLUDED_BRIDGE_MK
> > include $(topsrcdir)/bridge/bridge.mk
> >-endif
> > 
> > # workaround Bug 599809 by making these makefiles be generated here
> > SUBMAKEFILES += $(addsuffix /Makefile, $(APP_LIBXUL_DIRS) $(APP_LIBXUL_STATICDIRS))
> >+endif
> I don't think you meant to attach this bit ;-)

Ahh.. Yes.  I guess I refreshed the mq along with my changes to the
makefile.in.  I'll get that changed and forward along the r+?
Removed wrong changes from the patch.
Attachment #485689 - Attachment is obsolete: true
Attachment #485726 - Flags: review+
Edmund. Is this ready for checkin?
Blocks: 601493
You need to sync the rest of the changes from:
http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/themes/winstripe/mozapps/plugins/pluginProblem.css
Looking at the history might help.
http://hg.mozilla.org/mozilla-central/log/ddd48e3b173a/toolkit/themes/winstripe/mozapps/plugins/pluginProblem.css
You'll need to copy over (or adapt) a bunch of PNGs as well.
Bug 601493 blocks final so this one should, too.
blocking-seamonkey2.1: --- → ?
blocking-seamonkey2.1: ? → final+
Attachment #485726 - Attachment is obsolete: true
Attachment #523582 - Flags: review?(neil)
> +  color: white; 
Modern uses hard coded colour codes. e.g. #FFF

> +  background-image: url(chrome://mozapps/skin/plugins/contentPluginDownload.png);
> +  background-image: url(chrome://mozapps/skin/plugins/contentPluginDisabled.png);
> +  background-image: url(chrome://mozapps/skin/plugins/contentPluginBlocked.png);
> +  background-image: url(chrome://mozapps/skin/plugins/contentPluginCrashed.png);
....etc....
You need to copy the missing images from winstripe into suite/themes/modern/mozapps/plugins/ (and update jar.mn)

> +  background: url(chrome://global/skin/icons/loading_16.png) no-repeat;
Use the modern throbber:
url("chrome://communicator/skin/brand/throbber16-anim.png");
Attachment #523582 - Attachment is obsolete: true
Attachment #523780 - Flags: review?(neil)
Attachment #523582 - Flags: review?(neil)
(In reply to comment #11)
> Created attachment 523780 [details] [diff] [review]
> Update Modern theme from missingPlugin.css to pluginProblem.css (v4)

The patch still doesn't contain any images (actual files)...
> Jens Hatlak (:InvisibleSmiley)      2011-04-02 07:05:49 PDT
> 
> The patch still doesn't contain any images (actual files)...
ewong: did you remember to use hg add <new files> ?

> +  color: white;
> +  border-radius: 12px;
> +  /* recessed effect with dark inner shadow and lightened bottom */
Missed one #FFFFFF. You can use #FFF as a shortcut for #FFFFFF
Attachment #523780 - Attachment is obsolete: true
Attachment #523786 - Flags: review?(neil)
Attachment #523780 - Flags: review?(neil)
Comment on attachment 523786 [details] [diff] [review]
Update Modern theme from missingPlugin.css to pluginProblem.css (v5)

>+  background: uurl("chrome://communicator/skin/brand/throbber16-anim.png"); no-repeat;
Typo: uurl
Also this should point to loading.gif
Comment on attachment 523786 [details] [diff] [review]
Update Modern theme from missingPlugin.css to pluginProblem.css (v5)

>+  background: uurl("chrome://communicator/skin/brand/throbber16-anim.png"); no-repeat;
background: url("chrome://communicator/skin/icons/loading.gif") no-repeat;
r=me with that fixed.

If possible, the images should be run through pngcrush and/or optipng before checkin. (See bug 593840 for details.)
Attachment #523786 - Flags: review?(neil) → review+
Attachment #524178 - Flags: review?(neil) → review+
Keywords: checkin-needed
Comment on attachment 524178 [details] [diff] [review]
Update Modern theme from missingPlugin.css to pluginProblem.css (v6) [Checkin: comment 18]

http://hg.mozilla.org/comm-central/rev/ba0b24724d52
Attachment #524178 - Attachment description: Update Modern theme from missingPlugin.css to pluginProblem.css (v6) → Update Modern theme from missingPlugin.css to pluginProblem.css (v6) [Checkin: comment 18]
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1final
Duplicate of this bug: 567599
Depends on: 666555
You need to log in before you can comment on or make changes to this bug.