Switching from portrait to landscape or vice versa will close the virtual keyboard

RESOLVED WONTFIX

Status

Firefox for Android Graveyard
General
P3
normal
RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

Trunk
ARM
Android

Details

(Whiteboard: [VKB] )

Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101012 Firefox/4.0b8pre Fennec/4.0b2pre

1. close the hardware keyboard if any
2. go to url : http://www.google.com
3. click in the textbox to bring up the Virtual keyboard
4. switch from portrait mode to landscape or vice versa

Expected: Virtual keyboard does not disappear
Actual: the virtual keyboard closes

Note:
1. Maemo works as expected (though... it doesn't have a portrait VKB?)
Summary: [VKB] Switching from portrait to landscape or vice versa will close the virtual keyboard → Switching from portrait to landscape or vice versa will close the virtual keyboard
Whiteboard: [VKB]
Priority: -- → P3

Comment 1

7 years ago
confirmed on that Xoom tablet also.

Mozilla/5.0 (Android; Linux armv71; rv:6.0a1) Gecko/20110511 Firefox/6.0a1 Fennec/6.0a1

Updated

7 years ago
Duplicate of this bug: 686974
If we'll continue with the change in bug 698114 (do not re-create the activity on orientation change), this bug will be fixed automatically.
Fixed by bug 698114.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 5

6 years ago
Mozilla/5.0 (Android; Linux armv71; rv:10.0a1) Gecko/20111107 Firefox/10.0a1 Fennec/10.0a1
Device: HTC Desire Z - Android 2.3
        Acer A500 Iconia - Android 3.2

Issue is still reproducing on both tablet and phone, exactly as described in Description.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Camelia Urian from comment #5)
> 
> Issue is still reproducing on both tablet and phone, exactly as described in
> Description.

Camelia, I guess you could reproduce it in the official XUL nightly, but we are now working on the native UI, so the latest and greatest builds are now here:
http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-birch-android/

I'm not sure if it would be correct to switch the product in this bug to Fennec Native, as it was reported for Fennec (and still there), but it's fixed for the native UI build.

Can you please confirm with the birch build?
Thanks.

Comment 7

6 years ago
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1) Gecko/20111108 Firefox/10.0a1 Fennec/10.0a1 - Native Fennec build
Device: HTC Desire Z - Android 2.3

Issue is not reproducing on latest birch build. When rotating device, keyboard is not closed.

This bug is still reproducing on Fennec, so I'm not sure if I should close it, or put a Whiteboard  [Verified Native/Birch]? 

Kevin, Aaron, Tony what do you think?
I filed bug 698419 which is WONTFIX under Native Fennec. I'd imagine the same falls for XUL Fennec.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.