Closed Bug 605468 Opened 11 years ago Closed 11 years ago

urls not directly visited are showing up in location bar

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 4.0b9
Tracking Status
blocking2.0 --- final+

People

(Reporter: anamaria.moldovan, Assigned: mak)

References

()

Details

(Keywords: regression, Whiteboard: [hardblocker])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101019 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101019 Firefox/4.0b8pre

After www.cnn.com, among the website's history, a strange instance of the website appears:  http://static.ak.fbcdn.net/connect/xd_proxy.php.

Reproducible: Always

Steps to Reproduce:
1.Navigate to different pages into 3 different tabs: www.cnn.com, www.digg.com, www.engadget.com
2.Open a new tab
3.Type www.cnn.com
4.Among cnn.com history, a strange instance: http://static.ak.fbcdn.net/connect/xd_proxy.php appears (facebook hasn't been loaded)

On other browsers it does not appear !
Actual Results:  
The http://static.ak.fbcdn.net/connect/xd_proxy.php appears!

Expected Results:  
That instance should not appear since the www.facebook.com was not previously loaded.
Attached image The strange instance.
CNN uses facebook connect, http://developers.facebook.com/blog/post/108 . On a clean profile I do not see this upon visiting cnn.com and viewing an article. Are you logged in to facebook? Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101019 Firefox/4.0b8pre
I was checking the history in the sidebar, ctrl + h. It does show in the address bar autocomplete.
No, I was not logged into facebook. That's the weird thing.
From live http headers, the page is requested as part of visiting cnn.com.

http://static.ak.fbcdn.net/connect/xd_proxy.php#cb=fe41b400439fc6&origin=http%3A%2F%2Fwww.cnn.com%2Ff2044f1a81554ce&relation=parent&transport=postmessage&frame=f1f05635257ff5a

GET /connect/xd_proxy.php HTTP/1.1
Host: static.ak.fbcdn.net
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101019 Firefox/4.0b8pre
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
Connection: keep-alive
Referer: http://www.cnn.com/

HTTP/1.1 200 OK
Content-Type: text/html; charset=utf-8
Content-Encoding: gzip
X-Cnection: close
Content-Length: 1452
Vary: Accept-Encoding
Cache-Control: public, max-age=568
Expires: Tue, 19 Oct 2010 16:29:03 GMT
Date: Tue, 19 Oct 2010 16:19:35 GMT
Connection: keep-alive
I can reproduce this problem on a new Windows 7 Pro VM, with a new installation of the latest nightly (20101026) using the steps in comment #0.

Is there any way we can avoid that? Should we avoid listing that page in the results on the location bar?
Status: UNCONFIRMED → NEW
Component: General → Bookmarks & History
Ever confirmed: true
QA Contact: general → bookmarks
How is that url loaded by cnn?
Summary: A strange instance: http://static.ak.fbcdn.net/connect/xd_proxy.php appears when navigating the www.cnn.com website → urls not directly visited are showing up in location bar
There's some JS fu in it which loads a Facebook session handler panel in the page.
It can really dilute the value of the results in the location bar, and it doesn't happen on 3.6nightly
blocking2.0: --- → ?
Keywords: regression
blocking2.0: ? → final+
see also Bug 596347
Duplicate of this bug: 596347
Last good nightly: 2010-07-15 
First bad nightly: 2010-07-16

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5fda39cd703c&tochange=96de199027d7

Reduced STR:
1) In a clean profile visit cnn.com in current tab
2) Press ctrl-t to open a new tab
3) Type "www.cnn.com" in awesomebar

Actual:
- http://static.ak.fbcdn.net/connect/xd_proxy.php appears in dropdown

Expected:
- Above URL does not appear

Occurs in latest nightly: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101214 Firefox/4.0b8pre ID:20101214030322
Version: unspecified → Trunk
Regression from bug 556400?
taking for investigation.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Looks like this has already been fixed with other places branch stuff, particularly bug 610442 correctly made embed check the first one, handling redirects in non top-level iframes as embeds.
The above urls from facebook are now correctly marked as embed and never added to the database.

Can anybody reproduce on a clean profile with current nightlies?

Notice there are still bug 621273 and bug 621274 that have similar effects but are due to a different code path (icons actually) and confirmed still happening.
Blocks: 556400
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Depends on: 610442
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b9
Whiteboard: [hardblocker]
Verified
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110111 Firefox/4.0b10pre
Built from http://hg.mozilla.org/mozilla-central/rev/4413ed6ba5a5

Created a new profile. Visited cnn.com hompage and an article. Checked for instances of http://static.ak.fbcdn.net/connect/xd_proxy.php matching in the smart location bar, it was not listed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.