Image right-click context menu options (View, Save. Block, Copy, etc) aren't available on image maps

VERIFIED DUPLICATE of bug 33583

Status

()

Core
XUL
P3
minor
VERIFIED DUPLICATE of bug 33583
17 years ago
9 years ago

People

(Reporter: Biesinger, Assigned: David Hyatt)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001112
BuildID:    2000111220

In pages with Image Maps (for example, http://mmc.sourceforge.net or
http://astroinfo.de.vu), it's not possible to save the image from the image map
using the right mouse button when the mouse is over a link.
The Option "Save Image.." doesn't exist in the context menu.

Reproducible: Always
Steps to Reproduce:
1. Go to page with image image map
2. Click the right mouse button while over a link from the imagemap.


Actual Results:  There's no entry "Save Image as..." in the context menu.


Expected Results:  There should be such an entry.

Comment 1

17 years ago
Confirmed Win98 Mozilla build:2000111704

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Peter, please triage ASAP. Find the correct owner for this bug and reassign this.
Assignee: clayton → peter.vanderbeken

Comment 3

17 years ago
The context menu has a HTMLAreaElement as its .target (set to
document.popupNode). Because that is not an image, "Save image as..." gets
disabled (in mozilla/source/xpfe/communicator/resources/content/nsContextMenu.js).
Assignee: peter.vanderbeken → pinkerton
Component: HTML Element → XP Toolkit/Widgets: Menus
QA Contact: lorca → jrgm
if the target is wrong, that's gecko. if the target is being handled
incorrectly, it's an xpapps problem.
Assignee: pinkerton → law

Comment 5

16 years ago
Setting target milestone.
Target Milestone: --- → mozilla0.9.6

Updated

16 years ago
Target Milestone: mozilla0.9.6 → mozilla1.0

Comment 6

16 years ago
->context menu owner

Steve, can you look into this one and triage it appropriately?  thanks
Assignee: law → morse

Comment 7

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

16 years ago
Status: NEW → ASSIGNED
*** Bug 141696 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Target Milestone: mozilla1.0.1 → mozilla1.1alpha

Comment 9

16 years ago
Reassigning to component owner
Assignee: morse → hyatt
Status: ASSIGNED → NEW
QA Contact: jrgm → shrir

Comment 10

15 years ago
Please fix this, I beg you. It is a hassle for Web development work. This bug
has been around since 2000. Egad. This still doesn't work in Mozilla 1.1!

Good thing I still have Internet Explorer installed so I can open it up and grab
those images I need.

Comment 11

15 years ago
This bug still exist with build ID # 2003-05-06-10 or Mozilla 1.4 Beta on WinXP.
 Have anyone ever work on this bug lately?  Any progress so far?  Thanks!

Comment 12

15 years ago
*** Bug 212006 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
(From bug 212006)

OS -> All
Summary changed
OS: Windows 98 → All
Summary: Can't save Image from Image Map when over Link → Image right-click context menu options (View, Save. Block, Copy, etc) aren't available on image maps

Comment 14

14 years ago
retargeting
Target Milestone: mozilla1.1alpha → Future

Comment 15

14 years ago
*** Bug 227576 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
isn't this bug 33583 ?

Comment 17

14 years ago

*** This bug has been marked as a duplicate of 33583 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.