Status

Firefox Graveyard
Panorama
RESOLVED DUPLICATE of bug 592183
7 years ago
2 years ago

People

(Reporter: Matthew Galloway, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101022 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101022 Firefox/4.0b8pre

Sorry for being late to the party, but...

Ctrl + E, really?
>50% of the time I don't have the presence of mind to hit ctrl + e and not ctrl + w or ctrl + r, which are drastically different than the intended action of bringing up panorama/tabview. 

After looking at the lengthy argument about it, it seems that there's no one solution that can make everyone happy. 
So lets make it a preference (either via options or about:config)?

Reproducible: Always

Steps to Reproduce:
Press ctrl + e to show panorama. 
That is, after accidentally pressing ctrl + w twice and ctrl + r once.

Comment 1

7 years ago
As I recall, the lengthy discussion mentioned a pref as one option and we decided that wasn't a viable option.  We don't pref other command keys like ctrl+t, ctrl+n, (or ctrl+e when it was search), etc, and we probably won't start with this one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

7 years ago
Yes, but ctrl + e is neither convenient nor a mnemonic for the functionality of panorama mode. 

Not convenient for the reasons stated before (ie, the proximity to ctrl + w and the persistent issues with reopened tabs not adding themselves to the proper group). 
Not a mnemonic as where exactly in an E in panorama? Tabcandy? TabviEw? Seems to be a stretch for me. 

I enjoyed ctrl + space as it was the easiest combination to press (out of ctrl + space, ctrl + e, and ctrl + alt + space)  and, on a personal note, nicely complimented Launchy's alt + space shortcut. 

As yet another alternative, how about an "Enter Panorama Mode" item in the right click menu? It might not be the most intuitive thing in the world, but seeing as how panorama is very mouse-centric, it would also be cool to see some options view viewing groups that aren't through shortcuts or icons that are at the edge of the screen.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 3

7 years ago
(In reply to comment #2)
> Yes, but ctrl + e is neither convenient nor a mnemonic for the functionality of
> panorama mode. 
> Not convenient for the reasons stated before (ie, the proximity to ctrl + w and
> the persistent issues with reopened tabs not adding themselves to the proper
> group). 
> Not a mnemonic as where exactly in an E in panorama? Tabcandy? TabviEw? Seems
> to be a stretch for me. 

Mnemonics are hardly a requirement for hot key: ctrl+x, ctrl+k, ctrl+l, ctrl+w are all hot keys that have little if anything to do with their key.

Ctrl+e is certainly more more convenient than a shift+ctrl+ whatever key. Proximity to w and q are similarly poor reasons to move a key; we use ctrl+s, ctrl+tab and ctrl+a effectively despite proximity to q and q.
 
> I enjoyed ctrl + space as it was the easiest combination to press (out of ctrl
> + space, ctrl + e, and ctrl + alt + space)  and, on a personal note, nicely
> complimented Launchy's alt + space shortcut. 

I enjoyed it, too, but it conflicts with some major use-cases.

> As yet another alternative, how about an "Enter Panorama Mode" item in the
> right click menu? It might not be the most intuitive thing in the world, but
> seeing as how panorama is very mouse-centric, it would also be cool to see some
> options view viewing groups that aren't through shortcuts or icons that are at
> the edge of the screen.

With a hot key, a tool bar button, and a drop down menu selection, we don't necessarily need more ways to enter Panorama, though that could certainly be filed as a bug separate to this for discussion.

A hot key preference mechanism is DOA, as it would first need to be implemented (which would be a challenge) and make it far to easy for users to set up conflicting hot keys. This is definitely more of an add-on than a Firefox native preference.

All of that aside, all of these comments relate to bug 592183.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 592183
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.