Closed Bug 592183 Opened 9 years ago Closed 9 years ago

Change Panorama key combination to ctrl/cmd+E

Categories

(Firefox Graveyard :: Panorama, defect, P2)

defect

Tracking

(blocking2.0 beta7+)

VERIFIED FIXED
Firefox 4.0b7
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: aza, Assigned: raymondlee)

References

Details

(Keywords: user-doc-needed, Whiteboard: [strings])

Attachments

(1 file, 1 obsolete file)

For all locales that use a IME, we need a different default keyboard combination.
Assigning to Faaborg to decide on keyboard shortcut.
Assignee: nobody → faaborg
can we go with control-shift it's a little meta (just two modifiers) but then again tab view is kind of meta as well.  We need to go with two keys, and accessible with a quick gesture, and not much else is available.

We might want to consider enabling control-shift for all locals, people are going to have built up muscle memory and it will be frustrating if they sit down at a different instance of Firefox and it isn't the same.
Assignee: faaborg → nobody
Unfortunately we can't go with control-shift as that is used for typing strange unicode characters (think ◊ or ).
Those are made with alt like alt-shift-k for .
(In reply to comment #2)
> We might want to consider enabling control-shift for all locals, people are
> going to have built up muscle memory and it will be frustrating if they sit
> down at a different instance of Firefox and it isn't the same.

Control-shift is also used by some OS's/keyboards to switch between IME's.
The problem is that it is now 2010. Everything is taken.

Alex: I'd prefer to stick with Option-Space for everything but IME'd systems. Maybe for them we can go with double-tapping option? Or, perhaps just go for more standard but unused ones. Like Command-E, etc.
(In reply to comment #6)
> Or, perhaps just go for
> more standard but unused ones. Like Command-E, etc.

I think this is the way to go... it could be much less likely to have IME conflicts, and may be more normal to invoke even when in an input (re: your comment elsewhere).
Priority: -- → P2
Summary: Create non-IME keyboard shortcut default for eastern language packs → Create non-IME keyboard shortcut default
Duplicate of this bug: 589378
(In reply to comment #2)
> We need to go with two keys, and
> accessible with a quick gesture, and not much else is available.
> 
> We might want to consider enabling control-shift for all locals, people are
> going to have built up muscle memory and it will be frustrating if they sit
> down at a different instance of Firefox and it isn't the same.

How about Alt+` (backtick) ?
We have Ctrl+` already for quickly switch between different tab groups, it makes sense of using ` key.
Duplicate of this bug: 592649
Assignee: nobody → aza
(In reply to comment #9)

> How about Alt+` (backtick) ?
> We have Ctrl+` already for quickly switch between different tab groups, it
> makes sense of using ` key.

The backtick is hard to get at on some keyboard layouts (on French AZERTY and German QWERTZ, I think, it already requires the use of a control sequence), so we would need to find out what would be involved in producing this keystroke on different systems.
(In reply to comment #9)

> How about Alt+` (backtick) ?
> We have Ctrl+` already for quickly switch between different tab groups, it
> makes sense of using ` key.

This made my day.

Leaving out all the other reasons comment #11 mentioned, you do know that what you just suggested is the official IME switch key on _Windows_ ?

One broken system is one too much. This makes, unfortunately, both of these examples unusable. Even if it is one less, since OS X gets unbroken in the process as well (do mention it if I am incorrect, but alt+space IIRC was the official way to switch IMEs/keyboard layouts on the Mac).

As for ctrl+shift, I might have to check out my linux and windows systems and see if it breaks anything there. It seems like a semi-good one because you can input most of those weird unicode/ASCII/whatever symbols via IMEs as well if I can recall correctly. Of course, breaking someone's input is never fun, though. But I just don't have any new ideas on a keyboard shortcut that wouldn't break anything major on any of the three major systems.
blocking2.0: --- → ?
It seems like this may actually need strings, in which case it needs to block beta 7.
Whiteboard: [strings]
(Basically, as soon as you include a letter in the shortcut, that will need a localized string.)
(In reply to comment #12)
> As for ctrl+shift, I might have to check out my linux and windows systems and
> see if it breaks anything there.

As mitcho said in comment #5, Ctrl+Shift is another hotkey for switch IME, in both Windows and Linux (Ubuntu with ibus / gcin / SCIM).

Also, I'm not sure if we should make the shortcut different between locale builds. Even if you speaking Japanese and install IME in your computer, you are possibly using an en-US build.
(In reply to comment #15)
> As mitcho said in comment #5, Ctrl+Shift is another hotkey for switch IME, in
> both Windows and Linux (Ubuntu with ibus / gcin / SCIM).
On Windows, it doesn't actually switch the IME, it switches the keyboard layout, so it's worse than only affecting IME users. It also switches the IME because IMEs are implemented as different keyboard layouts.

> Also, I'm not sure if we should make the shortcut different between locale
> builds.
Please don't. Microsoft Office does this and it's a disaster and the main reason I avoid using MS Office at all (pt-br locale, that is). Seriously, Ctrl+S to underline, Ctrl+B to save, Ctrl+A to open a file?

(In reply to comment #12)
Alt-` is not exactly a global IME switching key, but it is consumed by the Japanese IME to toggle between latin (where it behaves exactly like the US keyboard layout) and kana input. The global keys that are IME-independent are Ctrl+Shift (switch layout) and Alt+Shift (switch language).
l10n: we need guidance on the most appropriate thing to do here.
Whiteboard: [strings] → [strings][needs input l10n]
I don't understand the urge to use unusual keyboard shortcuts here (the ones involving either only control keys or a combination of control keys and non-letter characters (such as space, tab, `, etc.)

Why can't we just use a normal combination like nearly every other one that we already support?  I don't think that we're going to find any "unusual" keyboard shortcuts that are not being used by something already...
(In reply to comment #18)
> Why can't we just use a normal combination like nearly every other one that we
> already support?

+1
Ehsan, Mitcho, can you propose a normal combination that works?
(In reply to comment #20)
> Ehsan, Mitcho, can you propose a normal combination that works?

Hmm, how about Ctrl+Shift+P?  (P as in Panorama)
I'd really like to keep this to a two-key shortcut. This is a primary and common action.
Keywords: uiwanted
Aza, agreed on the two-key shortcut. Was there a problem with the ctrl-E that we were using for a brief period in the past?
(In reply to comment #23)
> Aza, agreed on the two-key shortcut. Was there a problem with the ctrl-E that
> we were using for a brief period in the past?

ctrl-e is the key combo for putting the focus in the Fx search box.
I just looked at http://support.mozilla.com/en-US/kb/Keyboard+shortcuts and established that all {ctrl/command}+{single letter} shortcuts are taken. Blast!

So if we think about tabs or groups... {ctrl/command}+opt+T? {ctrl/command}+opt+G?
(In reply to comment #25)
> I just looked at http://support.mozilla.com/en-US/kb/Keyboard+shortcuts and
> established that all {ctrl/command}+{single letter} shortcuts are taken. Blast!

Isn't Ctrl+M still available? But anyway it might hard to memorize the combination with the action "Group your tab."

We have a few actions which has over 2 shortcuts binding on, like Select Location Bar (Alt+D, Ctrl+L, and F6,) Bookmark sidebar (Ctrl+B, Ctrl+I... why?), etc. Maybe we could take one from them.

How do you think Ctrl+Backspace, which are both located on the edges of the main keyboard area? It can be memorized as "back to the overview of groups."
(In reply to comment #26)
> (In reply to comment #25)
> > I just looked at http://support.mozilla.com/en-US/kb/Keyboard+shortcuts and
> > established that all {ctrl/command}+{single letter} shortcuts are taken. Blast!
> 
> Isn't Ctrl+M still available? But anyway it might hard to memorize the
> combination with the action "Group your tab."

Command+M minimizes the window in OS X.
I know that at least on Mac, command-e isn't taken. We can also displace other lower-value keyboard shortcuts.
We can kill old keyboard shortcuts. There are two for focusing the search box (ctrl/cmd + e, ctrl/cmd + k) and technically only one is needed. Many of these things are here for legacy reasons supporting users of IE5 and Netscape 3. That can, thankfully, go away.

I would rather the shortcut make sense than not.

Ctrl-Backspace doesn't seem to make a ton of sense to me, and overrides some well known cross-application editing commands. We shouldn't take anything that is cross-application, IMO. Ctrl+. or Ctrl+, might be good options if we want to use non-latin characters.

This blocks, and sadly I think it blocks Beta 7, though it should be a quick patch. We just need to decide.
blocking2.0: ? → beta7+
(In reply to comment #29)
> We can kill old keyboard shortcuts. There are two for focusing the search box
> (ctrl/cmd + e, ctrl/cmd + k) and technically only one is needed. Many of these
> things are here for legacy reasons supporting users of IE5 and Netscape 3. That
> can, thankfully, go away.

Thanks for chiming in and noting that this is possible, Mike. My vote is for usurping ctrl/cmd+E, as it disrupts less users: ctrl/cmd+E is only used in one platform right now (Windows) with the same functionality as ctrl+K. ctrl/cmd+K, on the other hand, calls up web search in all three platforms.

> I would rather the shortcut make sense than not.

Unfortunately ctrl/cmd+E doesn't really make sense... but it seems to be the option we have, if we want it to be a nice, normal, two-key combination.
What about
ctrl+win
ctrl+alt
alt+win
on windows?
(In reply to comment #30)
> Thanks for chiming in and noting that this is possible, Mike. My vote is for
> usurping ctrl/cmd+E

Ctrl/cmd+E +1

(In reply to comment #31)

We should not use Win key for this kind of shortcut. Not every keyboard has the key, and a shortcut is, IMO, important for using tabcandy.

BTW, good to see this blocks beta7.
Blocks: 597043
Sadly, doesn't look like there's a good way to detect "user is using IME" so we can't have a different shortcut for IME users, which would be the ideal.

Ctrl+E on Windows is "Search" in the File Explorer, which is why we aped the shortcut on Windows PCs. I think we can live without that parity, and as Aza says, in the tight keyboard real-estate world of 2010 it's hard to find any space left so we might not be able to be very choosey here.

So ...

Ideal world: ctrl/cmd+space when !IME, ctrl+cmd+e when IME
Otherwise: ctrl/cmd+e always

Over to Ian and co to see if we can reliably get IME state :)
The other two options are: command+/ and command+shift. I'm in favor of command+e over the first as it requires one hand, and the second because that keyboard shortcut just looks weird (and we'd have to detect whether command+shift was being held down as part of another sequence).

So a second to Beltzner's proposal.
Raymond, can you please look into whether it's possible to detect an IME system (i.e. one where ctrl+space would be a conflict)? I believe this is an issue only on Windows (though I could be wrong). One possible starting place: 

http://mxr.mozilla.org/mozilla-central/source/dom/interfaces/base/nsIDOMWindowUtils.idl#484

Another possibility might be to base it on navigator.language.
Assignee: aza → raymond
If someone knows, it's probably Masayuki.
The keyboard conflict is not IME in general, since that's a system for text input that can be used in many different ways. So changing the shortcut based on whether whether Mozilla IME handling code is active is not really what you want, and using the locale/language as an attempt to guess at the likelihood of IME use is certainly not what you want. I think IME is somewhat of a red herring - it's only one of the possible causes of keyboard shortcut conflict, and the only information we have about seems to be anecdotal evidence that Alt+Space (or Ctrl+Shift, or ...) is used "a lot".

I think we should focus on using finding a shortcut that can be used across the board and doesn't have any obvious conflicts (Ctrl+E? some other "simple shortcut"?), and forget about the IME detection ideas.
Combination of Accel (Ctrl on Win/Linux, Cmd on Mac) and an alphabet key is safest. That cannot be conflict with any system shortcut keys and can be used all keyboard layout.

Combination of Accel and Shift and an alphabet key is also safest too.

Combination of Accel and a non-alphabet key (like number key, ';', ':', '/', etc, except Space) isn't safe because some characters need another key (E.g., Shift key on all platforms or Option key on Mac).

Combination of Accel and Shift and non-alphabet key must not be used because there are many problems. For example, on Windows, some keyboard layout may use such combination for character input, see bug 414130. And also, if the specified character can input without shift on a keyboard layout, the shortcut key isn't accessible on the keyboard layout, see bug 433907.

Other key combinations except well known shortcut key (like Backspace is "Back") shouldn't be used for any shortcut keys. In other words, don't use other modifier keys like Alt and Meta on Windows and Linux, Ctrl and Alt(Option) on Mac. And also don't use non-character input keys like Home, End, Delete, Backspace, Arrow keys, Esc and Space.
(In reply to comment #35)
> Raymond, can you please look into whether it's possible to detect an IME system
> (i.e. one where ctrl+space would be a conflict)? I believe this is an issue
> only on Windows (though I could be wrong).

No, cannot detect that. And this problem isn't only on Windows.

Cmd+Space/Cmd+Shift+Space is used for switching keyboard layout on Mac.
Some IME uses Ctrl+Space for turning it on/off on both Win and Linux.

> Another possibility might be to base it on navigator.language.

It doesn't make sense. English version is used by all language users for testing.
Keywords: uiwanted
Whiteboard: [strings][needs input l10n] → [strings][needs patch]
Blocks: 595762
I'd prefer a 2 key shortcut, which is more usable than a 3-key one, as Aza said in Comment 22.
I must admit I haven't read all the comments, but I find one thing weird: it seems the shortcut is not going to be localizable? Why?

Most keyboard shortcuts (and sometimes even modifiers) are localizable in Firefox, just look at http://mxr.mozilla.org/mozilla-central/search?string=commandkey&case=on&find=.*\.dtd&findi=&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central

I suggest to find a sane shortcut that would work for most locales out there, and leave it localizable for those that need to change it. Ctrl+Space seems to work well in Windows and Linux, so you just need to change the default from Alt+Space to something else on Mac (because Alt acts as Level3 shift on Macs).
(In reply to comment #41)
> I must admit I haven't read all the comments, but I find one thing weird: it
> seems the shortcut is not going to be localizable? Why?
Because that implies that users of a certain keyboard layout or certain IME will be using a firefox in the language of their IME. What if some person writes both chinese and japanese, for example?
And as I mentioned they're a source of confusion when you use a product in one language on one computer and in a different language in another computer, specially for frequently-used shortcuts. It wouldn't be nice if some program replaced Ctrl+Z with Ctrl+Shift+-, wouldn't it?

> I suggest to find a sane shortcut that would work for most locales out there,
> and leave it localizable for those that need to change it. Ctrl+Space seems to
> work well in Windows and Linux, so you just need to change the default from
> Alt+Space to something else on Mac (because Alt acts as Level3 shift on Macs).
Ctrl+Space does NOT work well on Linux since it's the default IME enable / disable key, and was noted so early in the discussion. I always change it to something else because I accidentally triggered it all the time anyway but that's besides the point :)
Also, Alt also acts as a Level3 shift on Windows and Linux too, at least the right Alt (AltGr) on most layouts.
Diogo: like I said, most if not all keyboard shortcuts are localizable in Firefox. I fail to see why Panorama is so special it should be an exception.

Thanks for explaining about IMEs by the way, I was just about to ask Masayuki about them, cause I checked with my Win7 installation, and the keyboard layouts there can only be toggled using one of Ctrl+Shift, Alt+Shift, or the backtick key. Ctrl+Space is not mentioned, but I'm not using an IME, so I wasn't completely sure that haven't missed anything.

Re Alt: Alt and AltGr are different keys on Windows and Linux (in fact, AltGr = Ctrl+Alt on Windows). More on this below.

Aza: you should probably expand the scope of this bug a little, see bug 587505. 

In general:
Shortcuts with Ctrl+Alt should not be used on Win, where Ctrl+Alt = AltGr = L3Shift.
Shortcuts with Alt only should not be used on Mac, where Alt = AltGr = L3Shift.
Shortcuts with Alt only should not be used on Linux or Windows too, because Alt usually acts as the mnemonic access key. E.g. Alt+F activates File menu, Alt+Space activates window menu, Alt+C activates Cancel button in OK/Cancel dialogs and so on, thus in general, it's always visible what the key activates. At least to me, shortcuts like Alt+something for accessing a function and not a button always seems like a developer's mistake.
We're not expanding the scope of this bug to include bug 587505.

The shortcut will be localizable, just as the others are, but that doesn't mean that we don't need to pick it carefully (most locales do not make changes to the default shortcuts, for good reason).

This is one of the few remaining frontend b7 blockers - what's the status? Have we settled on Ctrl/Cmd+E? That's going to frustrate some Windows users who are used to using it for search, but there aren't really any other options.
Duplicate of this bug: 587505
(In reply to comment #44)
> This is one of the few remaining frontend b7 blockers - what's the status? Have
> we settled on Ctrl/Cmd+E?

That's my understanding. All other options seemed worse or unworkable.

Adding the shortcut, ripping out the ctrl+space code and adjusting the test sounds like it should be pretty straightforward, but maybe Raymond is still trying to get ctrl+space working without conflicts? :\
(In reply to comment #44)
> We're not expanding the scope of this bug to include bug 587505.

Actually I meant changing the title to cover not just the IME case. The shortcut should work on all locales, not just far-eastern ones. :)
If this really does block beta 7, we need an ETA on it. There aren't many b7 blockers left, and this doesn't have a patch or reviews yet.
I must say again. Don't use Ctrl(Cmd)+Space on all platforms and all locations. That is important shortcut key for multilingual users on Mac and IME users on others. If the shortcut key is used by some localized builds, multilingual users cannot use the build on Mac. And also some multilingual users who can use both the localized language and IME using language cannot use the build on other platforms.
I agree with Masayuki in comment #49 that it's not ideal to use ctrl (cmd)+space. Can someone confirm that what key combo we should use? Ctrl(cmd)+e?
I completely agree that we should not use cmd+space, and we should not attempt an imperfect IME detection, nor try to change the combination based on that.

Raymond, based on this consensus, together with Beltzner's comment (33) above, my understanding is that we have settled on ctrl/cmd+E. Could you start on this work and update us on an ETA or with a patch, as johnath inquired?
Summary: Create non-IME keyboard shortcut default → Change Panorama key combination to ctrl/cmd+E
AltGr + Space is not possible ? 
Ctrl + E is not easy to press.
Célian: AltGr (or plain Alt on Macs) is used for entering Level3 characters. In particular, some keyboard layouts specify AltGr+Space as no-break space. So no, it's not really an option.
It seems I don't see Ctrl + Fn mentioned.
(In reply to comment #54)
> It seems I don't see Ctrl + Fn mentioned.

Some Ctrl + Fn are used by Japanese IME.
[Ctrl] + [>] is used ? In European's Keybord, it is easy to press. 

For me, the best solution has shortcut's editor.
(In reply to comment #56)
> [Ctrl] + [>] is used ? In European's Keybord, it is easy to press. 
> 
> For me, the best solution has shortcut's editor.

See comment 38, we shouldn't use non-letter keys for shortcut.
Attached patch v1 (obsolete) — Splinter Review
The patch changes the key combo to ctrl/cmd+E
Attachment #478706 - Flags: feedback?(ian)
Status: NEW → ASSIGNED
Blocks: 591190
As we were using Alt+Space on Windows and Cmd+Space on Mac before, I'd like to move to Alt+E on Windows and Cmd+E on Mac. This is doubly true because Alt+E is easier to type than Cntrl+E.
PLEASE DO NOT!

Alt+E opens the edit menu, that's what it should do.
And Ctrl+Alt+E = AltGr+E = € sign on many european layouts.

Please don't reinvent the wheel. Command shortcuts use Control key on Windows, and they should keep on doing so.
A less emotional and more kind explanation:
Function   Mac     Win/Lin
Find       Cmd+F   Ctrl+F
Quit       Cmd+Q   Ctrl+Q   (not available on Windows)
Cut        Cmd+X   Ctrl+X
Select All Cmd+A   Ctrl+A
....
Panorama   Cmd+E   Alt+E    – what the heck?
Comment on attachment 478706 [details] [diff] [review]
v1

Aza: alt's a bad idea, as is adding churn to this already incredibly ridiculous bug.

I am disappointed that we can't just figure out a way to be intelligent about cases where an IME might conflict, even if that is to no longer register any keyboard shortcut. I don't think there's any sense talking more about that or further confusing this bug with alternative proposals.

As far as I can see, this patch implements the proposal from comment 33 - gets my ui+r
Attachment #478706 - Flags: ui-review+
Comment on attachment 478706 [details] [diff] [review]
v1

Gavin: can you review this? Simple patch, rips out the cmd+space code and adds the shortcut
Attachment #478706 - Flags: review?(gavin.sharp)
Lots of debating about IME and other conflicts here. One point that I don't see brought up, but it can't just be me: alt+space is too easy to hit by accident. On my laptop keyboard I have accidentally brought up Tab Candy more than once because of this shortcut.

Ctrl+E is fine by me as a primary shortcut if it doesn't conflict.

Another more natural suggestion to be used instead of or in addition to this:

--> HOLD ctrl+tab

(shift+)ctrl+tab cycles through tabs. Pressing it a bunch of times jumps through a bunch of tabs. Holding it for auto-repeat just runs through a bunch without much control. Instead, how about we intercept the attempt to auto-repeat and use that as a shortcut to open Panorama? It would actually make sense as an extension of the existing shortcuts.
Dave: thanks, but we don't need additional comments here. We have a strategy and a patch, and additional debate and commentary just distracts us from getting things done.
Fair enough. Filed bug 599872 for the hold ctrl+tab idea in comment 64.
Comment on attachment 478706 [details] [diff] [review]
v1

>diff --git a/browser/base/content/browser-sets.inc b/browser/base/content/browser-sets.inc

> # Search Command Key Logic works like this:

Not really related to this bug, so feel free to ignore in the interests of expediency, but it would be nice to update this comment (both here and in the DTD) to reflect bug 348472 (Cmd+Opt+F on Mac).

>diff --git a/browser/locales/en-US/chrome/browser/browser.dtd b/browser/locales/en-US/chrome/browser/browser.dtd

>   Do *not* tamper with these values without talking to ben@mozilla.org

... and remove this.
Attachment #478706 - Flags: review?(gavin.sharp) → review+
Whiteboard: [strings][needs patch] → [strings][can land once nits addressed]
Attached patch updated patchSplinter Review
I took the liberty of updating the patch to address my nits, and fixing the commit message. I'll land this shortly.
Attachment #478706 - Attachment is obsolete: true
Attachment #478834 - Flags: feedback?(ian)
Attachment #478706 - Flags: feedback?(ian)
Thanks, Gavin.
https://hg.mozilla.org/mozilla-central/rev/54f9c7089269
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [strings][can land once nits addressed] → [strings]
Target Milestone: --- → Firefox 4.0b7
Comment on attachment 478834 [details] [diff] [review]
updated patch

Looks great; thanks for landing this, Gavin!
Attachment #478834 - Flags: feedback?(ian) → feedback+
Keywords: user-doc-needed
Thanks on fixing this and bug 594508 whit it ;-)

Edited https://wiki.mozilla.org/Firefox/Projects/TabCandy/FAQ#What_are_the_current_features_of_Tab_Candy_and_how_do_I_use_them.3F accordingly FWIW

Kind of like what's described on comment #64
Duplicate of this bug: 594508
Blocks: 598809
How about using Shift+Enter ? and move .net shortcut to this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=512176
This bug is FIXED, no further suggestions required.
verified on recent nightly builds of minefield
Status: RESOLVED → VERIFIED
This is HORRID!  Who's brilliant idea was this?  This isn't a fix, it's a bug!  Don't change shortcuts to implement a BS feature!
Duplicate of this bug: 606535
Duplicate of this bug: 611299
My computers aren't very top notch, so I don't know how good or useful Panaroma or however you spell it is supposed to be. Right now, it is slow and not attractive. There's probably a larger market for users that search than users that have a good enough PC and use enough tabs for this to be useful (addon anyone?).


"Thanks for chiming in and noting that this is possible, Mike. My vote is for
usurping ctrl/cmd+E, as it disrupts less users: ctrl/cmd+E is only used in one
platform right now (Windows) with the same functionality as ctrl+K. ctrl/cmd+K,
on the other hand, calls up web search in all three platforms."

Ok, but that 1 platform accounts for over half the market.
Bodhisattvah, John: as this particular bug/task was already implemented, I suggest you open up new bugs with concrete suggestions for how to improve the situation.
Duplicate of this bug: 616998
Okay I have read the comments and the changes in the source.
It says CLOSED/FIXED, committed. Fine.

BUT. A while ago this CTRL+E disappeared from nightly.
I'm using the Nightly trunk, x64 version.

Currently: 4.0b10pre (2011-01-25).

Sometime ago.. when this CTRL+E got committed it worked. And then.. nothing.
I'm using Windows 7 Professional x64.

If you need any other information, just say.
The shortcut has been changed to Ctrl+Shift+E in bug 624588. See the discussion there.
Blocks: 624588
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.