Tab close button doesn't show after moving some tabs to other group

VERIFIED FIXED in Firefox 4.0b8

Status

Firefox Graveyard
Panorama
P3
normal
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: ithinc, Assigned: raymondlee)

Tracking

Trunk
Firefox 4.0b8
Dependency tree / graph
Bug Flags:
in-testsuite +

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101024 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101024 Firefox/4.0b8pre

After moving some tabs to another group, tab close buttons doesn't appear on the background tabs even when they're wider than tabClipWidth.

Reproducible: Always

Steps to Reproduce:
1. Open 10 tabs or so, and tab close buttons on background tabs disappear.
2. Move tabs to another group one by one.
(Reporter)

Updated

8 years ago
Blocks: 597043
(Assignee)

Updated

8 years ago
Assignee: nobody → raymond
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

8 years ago
Created attachment 486668 [details] [diff] [review]
v1
Attachment #486668 - Flags: feedback?(ian)
(Assignee)

Updated

8 years ago
Blocks: 606905
(Assignee)

Updated

8 years ago
No longer blocks: 606905
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Blocks: 606905
(Assignee)

Updated

8 years ago
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
Comment on attachment 486668 [details] [diff] [review]
v1

Looks good to me.
Attachment #486668 - Flags: review?(dao)
Attachment #486668 - Flags: feedback?(ian)
Attachment #486668 - Flags: feedback+
Comment on attachment 486668 [details] [diff] [review]
v1

It seems to me that this should be done as part of hideTab and showTab.
Attachment #486668 - Flags: review?(dao) → review-
(Assignee)

Comment 4

8 years ago
Created attachment 486830 [details] [diff] [review]
v1

Based on dao's comment, put adjustTabstrip() in showTab() and hideTab()
Attachment #486668 - Attachment is obsolete: true
Attachment #486830 - Flags: feedback?(ian)
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> Based on dao's comment, put adjustTabstrip() in showTab() and hideTab()

Doesn't this add too many unnecessary adjustTabstrip calls? We don't have an UI command to trigger showTab/hideTab directly.
(Reporter)

Comment 6

8 years ago
I filed another bug 608184, which is also related to moveTabToGroup.

Updated

8 years ago
Duplicate of this bug: 606905
(In reply to comment #5)
> We don't have an UI command to trigger showTab/hideTab directly.

Doesn't matter -- It's part of the tabbrowser API.
(Assignee)

Comment 9

8 years ago
Comment on attachment 486830 [details] [diff] [review]
v1

Passed try!
Comment on attachment 486830 [details] [diff] [review]
v1

Looks good
Attachment #486830 - Flags: review?(dao)
Attachment #486830 - Flags: feedback?(ian)
Attachment #486830 - Flags: feedback+
Comment on attachment 486830 [details] [diff] [review]
v1

>+  // a setTimeout() in addTab is used to trigger adjustTabstrip() so we need a delay here as well.
>+  executeSoon(function() {
>+    is(gBrowser.tabContainer.getAttribute("closebuttons"), "activetab", "Only show button on selected tab.");

I wouldn't be surprised if this fails intermittently...
Attachment #486830 - Flags: review?(dao) → review+
Attachment #486830 - Flags: approval2.0?
Priority: -- → P3
Target Milestone: --- → Firefox 4.0b8
(Assignee)

Comment 12

8 years ago
Could someone give approval2.0 to this please?
Comment on attachment 486830 [details] [diff] [review]
v1

a=beltzner
Attachment #486830 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 14

8 years ago
Created attachment 493345 [details] [diff] [review]
Patch for check-in
Attachment #486830 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
(Assignee)

Comment 15

8 years ago
Passed Try

Comment 16

8 years ago
http://hg.mozilla.org/mozilla-central/rev/b1eda2bd8812
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
verified in current minefield nightly.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.