Closed Bug 607383 Opened 12 years ago Closed 7 years ago

Reduce redundant display of app tabs in panorama view

Categories

(Firefox Graveyard :: Panorama, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: mgway12, Unassigned)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101024 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101024 Firefox/4.0b8pre

The way that app tabs are currently handled by Panorama seems counter-intuitive. While I appreciate the favicons in each tabgroup, the group in which new tabs opened by an app tab is confusing and (at least for me) leads to a lot of rearranging tabs. 
(more prose omitted)

The idea:
- Get rid of the app tab favicons present in each group. 
- Place each favicon on the [left|right|bottom] of the panorama view in a little container similar to the close button. 
- Create a 'hidden' tabgroup for each app tab, optionally named as the TLD
- When an app tab is selected, mark the associated tabgroup as active. 
- When in panorama mode, all app tab groups are hidden
- When in panorama mode and the user hovers over the favicon, the associated tabgroup rolls out. If the favicon is clicked on, active the app tab itself. 
- Unpinning an app tab simply removes the icon from the list but keeps the tabgroup alive

Expected benefits:
- Similar to how the Mac dock works
- Similar to how the Win7 taskbar works
- Users always know where child tabs of app tabs will open (instead of opening in the arbitrary active group)

I'll attach some images to help my mediocre wording along. 

Reproducible: Always
Severity: normal → enhancement
Seems like the idea has some merit, though we won't get to it before FF4.0 I'm thinking. 

Assigning to Aza to spec/design/ruminate.
Assignee: nobody → aza
Target Milestone: --- → Future
This was something we played around with in early mockups of App Tabs, and is worth reconsidering in the future.

(In reply to comment #2)
> Seems like the idea has some merit, though we won't get to it before FF4.0 I'm
> thinking. 
> 
> Assigning to Aza to spec/design/ruminate.

(In reply to comment #3)
> This was something we played around with in early mockups of App Tabs, and is
> worth reconsidering in the future.



Let's just set it to NEW, despite the fact that it is not going to land in Fx 4. It's a good idea.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Just adding that I got puzzled by the behavior of Panorama in FF4b9. I expected the app tab to have a normal tab preview in the tab group, like other tabs. That would have made it a decent click target. But no, it was a tiny favicon stuck to the right (uhh??) of the tab group. Not properly aligned with anything, hard to spot… I hope there will be some improvements to this, even small, before FF4 final lands.
(In reply to comment #5)
> Just adding that I got puzzled by the behavior of Panorama in FF4b9. I expected
> the app tab to have a normal tab preview in the tab group, like other tabs.
> That would have made it a decent click target. But no, it was a tiny favicon
> stuck to the right (uhh??) of the tab group. Not properly aligned with
> anything, hard to spot… I hope there will be some improvements to this, even
> small, before FF4 final lands.

We're doing some quick last-minute design reconsiderations here: bug 595965. Feel free to weigh in.
Assignee: azaaza → nobody
I am against - https://bugzilla.mozilla.org/show_bug.cgi?id=588058

I think AppTabs should not be scattered and to the only good way I can see so far is what I tried to make in the mockup.

***Skipping the lecture about how it is better from UX perspective.
Trying to clarify the title, based on how I understand this bug.
Summary: Panorama handling of App Tabs → Reduce redundant display of app tabs: keep app tab tray in each group, but have it roll out on hover
(In reply to comment #8)
> Trying to clarify the title, based on how I understand this bug.

Not even close. My idea (and the ideas presented in the two attachment images) was to _not_ have app tab icons in each tab group in any capacity, instead, to have all of the app tab icons in one location on the right of the screen.
(In reply to comment #7)
> Created attachment 508350 [details]
> Versatile AppTabs (as buttons) in panorama view [MockUp]

Tend to agree with this proposal. Not only does it save up space in Panorama but it also eliminate the redundancy of having each apptab present in each group.

Also, having all the apptabs displayed as in the MockUp,eliminates the need to hide some of them when group is too small.
Keywords: uiwanted
Hardware: x86 → All
Summary: Reduce redundant display of app tabs: keep app tab tray in each group, but have it roll out on hover → Reduce redundant display of app tabs in panorama view
Version: unspecified → Trunk
Blocks: 627037
Depends on: 630792
Assignee: nobody → limi
Keywords: uiwanted
Please also consider that App tabs is horizontal and on the left side of tab bar, the current design with vertical and on the right side of panorama may cause visual inconsistency.
Assignee: limi → nobody
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.