Cross-folder navigation should not land on Trash folder.

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: laurel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla0.9.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using nov 17th commercial trunk build

This is one of the issues carried forward from main feature bug #17801...

Trash folders should be ignored by cross-folder navigation. Currently it seems
if the trash folder has unread messages, it is not landed on immediately, but
rather takes a couple rounds through the folders... I haven't figured out the
details, but you will be promptec for navigation to the trash folder (I was
using IMAP).

Comment 1

17 years ago
*** Bug 60777 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

17 years ago
QA Contact: esther → fenella
(Reporter)

Comment 2

17 years ago
*** Bug 61214 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

17 years ago
*** Bug 61214 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

17 years ago
nominating for 6.5
Keywords: nsbeta1

Comment 5

17 years ago
marking nsbeta1+ and moving to mozilla0.8 milestone
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.8

Comment 6

17 years ago
moving to mozilla0.9
Target Milestone: mozilla0.8 → mozilla0.9

Comment 7

17 years ago
I think I have a fix for this. I will attach it shortly.

Comment 8

17 years ago
Created attachment 23921 [details] [diff] [review]
patch for bug.

Comment 9

17 years ago
reassigning to me.  I might wait a bit to go through the review and checking in
process because I think I know how to fix a bunch of the other folder navigation
bugs and this might have to change because of that.
Assignee: sspitzer → putterman

Comment 10

17 years ago
reassigning to chuang. Candice, if this patch still works, can you check this
in? I'm not sure if this will cause a merge problem with the perf branch landing.
Assignee: putterman → chuang
taking from chuang.  this will cause a conflict on the branch.  I'm about to get
"cross folder" navigation to work on the branch, so I'll apply this patch there.
Assignee: chuang → sspitzer

Comment 12

17 years ago
moving to mozilla0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1
fixed.

thanks to putterman for the initial patch.  (I've since changed
IsSpecialFolder() to use bit flags instead of strings.)
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
Linux (2001-03-27-05 mtrunk)
Win32 (2001-03-27-06 mtrunk)
Mac (2001-03-26-12 mtrunk)
This works fine now.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.