mail.check_all_imap_folders_for_new is ignored by "Check for new messages at startup"

RESOLVED DUPLICATE of bug 221792

Status

RESOLVED DUPLICATE of bug 221792
8 years ago
8 years ago

People

(Reporter: theduck02, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.1; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.1.6

"Check for new messages at startup" only checks the Inbox and mail.check_all_imap_folders_for_new is ignored. However, it the "Get Mail" button is pressed the mail.check_all_imap_folders_for_new preference is honoured.

This used to work in version 2 of Thunderbird, but I have not seen it work in version 3.


Reproducible: Always

Steps to Reproduce:
1. Set "Server Setting" - "Check for new messages at startup"
2. Set mail.check_all_imap_folders_for_new preference
3. Stop Thunderbird
4. Wait for some new mail in a box other that Inbox
3. Start Thunderbird
Actual Results:  
The directory (other than the Inbox) in which new mail has arrived will not be highlighted.

Expected Results:  
All imap folder should be check at startup for new mail and the directories highlighted appropriately.
This sounds like bug Bug 221792

Comment 2

8 years ago
in particular, see bug 221792 comment 39 and comment 38.
If that doesn't describe your issue, we can undo the duplication
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 221792
You need to log in before you can comment on or make changes to this bug.