Open Bug 221792 Opened 17 years ago Updated Last year

IMAP subfolders marked "Check...for new messages" not checked automatically (via STATUS command)

Categories

(MailNews Core :: Networking: IMAP, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

People

(Reporter: mozilla, Unassigned, NeedInfo)

References

Details

(Whiteboard: [need protocol log][datalossy])

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Mozilla Thunderbird 0.3 (20030924)

For a number of my IMAP subfolders, I've selected 'Check this folder for new 
messages' under the folder 'General Information' property tab.  I also have 
configured the IMAP account to 'Check for new messages at startup' and 'Check 
for new messages every 5 minutes'.

When I start Thunderbird, it checks the inbox for new messages, but the 
subfolders don't appear to be not checked.  

When I start Thunderbird, it checks the inbox and doesn't appear to check 
subfolders.  Then if I leave the selection on the Inbox in the folder tree and 
select 'Get Mail'.  The subfolders still do not updated.  Next,if I explicitly 
select one of the subfolders of them, then it will updated immediately.  But 
other subfolders will not.  Finally, if I select 'Get Mail' again, with the 
folder selection on the subfolder, all subfolders get checked.

BTW, I am using Cyrus IMAP server on FreeBSD doing server side cyrus-seive 
filtering of the messages for all the mailing lists I'm on.

Reproducible: Always

Steps to Reproduce:
Assuming server-side filtered IMAP folders which regularly receive new content 
(e.g. high volume mailing lists):
1. Select some subfolders to 'Check this folder for new messages'
2. Configure IMAP server account to check for messages on startup and 
periodically
3. Exit Thunderbird
4. Start thunderbird
5. Select 'Get Mail'
6. Select Subfolders that you expect to have new content in
7. Select 'Get Mail' again

Actual Results:  
After #4, only Inbox is shows new messages
After #5, no change
After #6, selected subfolder is checked and shows new messages
After #7, folders marked 'Check...for new messages' which have new messages 
are checked and show new messages

Expected Results:  
After, step #4 all subfolders with new content show that they contain new 
messages.  As I've configured Thunderbird, I do not expect to have to 
explicitly select subfolders to see if they've been updated.

Once I've gone through the scenario above, the subfolders appear to get 
checked every 5 minutes, for a while.  If I leave Thunderbird up for a long 
time, it stops checking the subfolders after a while.

I have made no attempts to log the IMAP socket traffic to see if Thunderbird 
is checking and Cyrus is not cooperating or if Thunderbird is simply not 
checking.

This has been a problem in all prior versions of Thunderbird.
Correction: 2nd paragraph of detail should read,

"When I start Thunderbird, it checks the inbox for new messages, but the 
subfolders don't appear to be checked."
I have this problem as well, in 0.3 on both Win32 and OSX. Extremely annoying.
I also have this problem, I think.  I have not been bothering with the "get
mail" button, as I didn't find a way to get it to force the update like the
initial bug reporter here did. -- New mail is picked up for the folders I've
selected at the regular check-for-new-mail interval (set for 10 mins), but not
at startup.

Frusterating and dissapointing.  I have a number of seperate email addresses
that are piped through one imap account; server-side rules seperate the emails
for each address in to seperate folders, as well as filter out known viruses and
junk mail.

When I was using 0.3, new messages in subfolders were nearly always checked just
fine.  After upgrading to 0.4, this problem is much worse, with Tbird almost
never noticing new messages.  I now have to click on frequently-used subfolders
to check for new messages.
Agreeing with #4 - didn't happen in 0.3, but happens always in 0.4. Could it be 
related to upgrading from 0.3 to 0.4 and keeping the preference directory?
When I installed 0.4, I completely deleted my 0.3 directory as usual, so I don't
think that is the cause.  By preference directory, do you mean your user
profile?  The only dir you should have to delete when upgrading is the actual
application directory.
Yes, I meant the user profile. I know the docs say you shouldn't need to 
delete it.

Just as an experiment I deleted my user profile directory and re-added my 
email accounts to thunderbird 0.4 - and now it works! Subfolders that get new 
messages are actually checked. There is something fishy with the old user 
profiles.
I renamed my old profile directory and set up a brand new profile, however it
does not seem to be fixed for me.  I was viewing my Inbox and sent several
messages that would be auto-filtered into a subfolder via procmail.  The
messages were delivered but Tbird did not biff until I clicked on the subfolder
with the messages.  Clicking on other subfolders or clicking 'Get Mail' had no
effect.

I compared my old and new prefs.js file and could only really find one line that
was different:

New:
user_pref("mail.server.server1.capability", 270881);

Old:
user_pref("mail.server.server1.capability", 274977);

FYI, just as Andy reported (in comment #8), I can reproduce the problem using 
both new and migrated profiles in 0.3 and 0.4.
See Bug #224381 for a possible fix/workaround:

Set "mail.imap.use_status_for_biff" to false
try updating to a newer version of thunderbird - I believe this has been fixed.
I'm using Thunderbird 0.4 and setting "mail.imap.use_status_for_biff" to false 
seems to correct the problem for when I select "Get Mail" (i.e. if I click the 
button it scans all folders marked to be checked).  However, when I startup 
Thunderbird, it only checks the inbox.

So this is a marked improvement.  However, it's not 100% as not all folders are 
checked on startup.
*** Bug 230502 has been marked as a duplicate of this bug. ***
> try updating to a newer version of thunderbird - I believe this has been fixed.

newer then what? Which builds will include the fix and which bug was it fixed as
part of?

I'm using mozilla 1.6 and can reproduce the problem there too. Checking "check
this folder for new messages" checkbox seems to have no effect at all.
Try Mozilla 1.7b or Thunderbird .5. If they don't work, please try attaching or
e-mailing me an imap protocol log.  Without a protocol log, I can't tell what
particular problem you're having...
Dup of 186894? I'll try to create a log
I have this problem too. I'm using the latest 31st March build (0.5+ 20040331). 
It seems to check for new messages properly on startup sometimes for me, but it 
NEVER seems to check properly if I press the "Get Mail" button or at the timed 
mail check interval. Selecting the folder always shows the new messages that 
have arrived in it (I use server side IMAP rules).

I do not believe this bug exists if the messages were moved to the subfolders 
CLIENT side.
Not sure if this has been fixed in .6 but I know for a fact that it still 
exists in .5 ,  will upgrade and report.

Just to make sure, (Still getting used to actively reporting bugs, so please 
don't flame me... :)  )

This bug represents:
When I open thunderbird, IMAP folders other than the inbox will not display 
new messages unless clicked on.  Right?
dup of bug 186894 - not sure which tbird build this is fixed in. Definitely
trunk builds after 05/06

*** This bug has been marked as a duplicate of 186894 ***
URL: n.a.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Not sure if I should reopen this or bug 186894, but i'll choose this since the
other explicitly mentions startup.

The way things work now is that all appropriate folders are checked on startup,
however when the mailbox is rechecked every so often only the INBOX folder is
checked, not other folders marked with "Check this folder for new messages".

So in other words the bug seems to be fixed for startup, but not for the timed
recheck.

This is with mozilla1.7RC2 which was released after any activity in bug 186894
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
does the 1.8 trunk work? Can you attach an imap protocol log?
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
Hmm.. i can't really reproduce it so I suspect that i was just confused. 
Status: REOPENED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → FIXED
I can reproduce this with Thunderbird 1.5, and I've got an IMAP protocol log.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached file thunderbird IMAP log
This is a log with NSPR_LOG_MODULES set to IMAP:4. I had folder Inbox/Bug Mail open, and I didn't get a new mail notification from Inbox/Commits.
Seeing this as well on Thunderbird 2.0 beta 2 on Mac OS X.

Potential duplicates of this bug: bug 288699 and bug 221792

QA Contact: front-end
(In reply to comment #26)
> Created an attachment (id=204805) [details]
> thunderbird IMAP log
> 
> This is a log with NSPR_LOG_MODULES set to IMAP:4. I had folder Inbox/Bug Mail
> open, and I didn't get a new mail notification from Inbox/Commits.
> 

CC'ing Emre to look into this.
all bugs that mention "check this folder for new messages" - http://tinyurl.com/6gcrf4
Assignee: mscott → nobody
Status: REOPENED → NEW
Severity: minor → normal
Component: Mail Window Front End → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: front-end → networking.imap
I also experience this using Thunderbird version 2.0.0.21 (20090302) on Windows.

I have manually checkboxed every single folder with Check This Folder for New Messages.

In addition, I have set mail.check_all_imap_folder_for_new set to "true" in the config editor. This has NO EFFECT. The counts on the imap folders still are not updated.
I'm seeing this same problem using TB 2.0.0.21, both on Windows XP Pro and also Ubuntu 9.04.
Same problem in Thunderbird 3 Beta4.
Can somebody take a look on this 6 years old bug?

I have 15 subfolders in my IMAP account, and after install Thunderbird I need do a right-click on each one and go to Properties --> Check new messages on this folder.
Even when I check the "Check new bessages" properties box for a folder, this still does NOT cause new messages to be detected consistently.

This used to work.  I know it worked when I first started using TB two or three years ago; I probably would not have adopted TB if this feature hadn't worked.

However, sometime in the past several months, it stopped working.  I've tried testing betas of TB3, and the feature appears broken there too.

In case it makes any difference, I'm using TB to access mail stored in a Cyrus IMAP server.
if when using v3.1 or higher ...
* problem is gone for you, please comment in the bug.
* you see this problem, please create an imap log while reproducing the issue (see https://wiki.mozilla.org/MailNews:Logging for instructions) and attach log file to bug
* is IDLE enabled or disabled

in other words, if you get this bugmail, please update the bug with your present status.

(Lisa's adddress is dead)
Whiteboard: [needs protocol log]
do you you still see this in version 3.1?
or, is it gone?

replies appreciated.
Whiteboard: [needs protocol log] → closeme 2010-09-15 [needs protocol log]
Yes, this still happens. IDLE is enabled. Is the protocol log I attached in comment 26 no good?
Whiteboard: closeme 2010-09-15 [needs protocol log] → [needs protocol log]
Joe, which version of 3.1 are you using? 

That log didn't show Commits receiving any idle notifications. Had you selected the Commits folder prior to when it was supposed to have received new messages.
I'm using 3.1.2 now.

I don't remember whether I selected Commits - it's been years, after all. :) Is it necessary to select the folder before IDLE notifications get received?
Yes, we only do IDLE for cached connections, and we only cache a connection when you open a folder. But, if you've set the folder to be checked for new messages, we'll use the STATUS command to see if there any new unseen or recent messages in the folder. If IDLE wasn't working correctly on your server, you would see the bug happen with folders you had selected in the current session (very roughly...we only cache five connections by default).
Duplicate of this bug: 607892
Anyone besides Joe still see this?
I'm on TB12 now and haven't noticed myself noticing anything related to this bug for a long while now. Long while.
I also haven't seen this for a while, but OTOH I also use Aurora (Earlybird) and hence restart very frequently.
Hey,

I keep experiencing this issue and came across this website by google.
I'm using Thunderbird 14.0 and played a bit around to check on the bug behavior.

I'm using IMAP and when TB is minimized if a new mail arrives in:
- main inbox folder or any other custom main folder on the server: notification sound + popup occurs

- a subfolder of main inbox folder: nothing happens after a few minutes. I have to click on the subfolder so it updates and I see the email (all settings in folder property are set correctly to auto update this folder when new messages arrive etc).
Once in a while the subfolder is highlighted in black and sound occurs (yet still no notification popup) before I click it but that happens just sometimes.

Next thing I tried was unsubscribing from most folders (I had way more than 10 subscribed folders/subfolders).
Now suddenly I get a notification once a new mail arrives in one of my inbox subfolders (e.g. inbox/testfolder).
Read something about connection and caches here. Is there a limit for folder subscription to cause this behavior? If yes, please give me some numbers. Doesn't seem to be a permanent good solution to only see some of my inbox folders in Thunderbird.

Hope that helps. Else let me know what other information you need.
After setting up a new profile with one pop3 and one imap account, I  experienced this problem again. (This happens every few years when I try to use imap and then stop because of this problem.)

The problem (in my case) is not that some subfolders aren't updated, but that Thunderbird doesn't contact the server at all until I click on a folder (in case of imap) or manually refresh the account (in case of pop3). After that everything runs fine. (If I do not store the password for the accounts I do not get the password prompt until I do that.)

The reason for this behavior in my case seems to be that none of my accounts was selected as "default account". As soon I select one (it doesn't matter which one) everything starts to work right - I get a prompt for both passwords after restart and both accounts get updated continuously.

I took a look in the prefs.js and before I set one account as default I have this line in it:

user_pref("mail.accountmanager.defaultaccount", "account1");

When I switch between my accounts I get account2 and account4 as values, so account1 seems to be no valid value for that option. I can trigger the problem again by setting this pref back to account1.

I am using Thunderbird 7.0.1 - not quite up to date. Can anyone with a recent version check whether this problem still exists?
I'm using 23.0a2 (2013-06-21) @ Mac OS X 10.8.3 – the problem is still exists.
(In reply to Christian Weihs from comment #45)
> The problem (in my case) is not that some subfolders aren't updated, > but that Thunderbird doesn't contact the server at all
> until I click on a folder (in case of imap)
> or manually refresh the account (in case of pop3).

This bug is for "IMAP" only and "IMAP sub folder" only problem.
How can your peoblem be same problem as this bug which was opened on 2003-10-10?

> The reason for this behavior in my case seems to be that
> none of my accounts was selected as "default account".

POP3 case is dup of bug 854098. IIRC, problem of that bug occured at least in Tb 3.
If I understand problem of that bug correctly, problem occurs in IMAP too, and "check new message every N minutes" works in both POP3 case and IMAP case even when bug 854098 occurs, although I'm not sure because I checked POP3 case only.

Anyway, watch bug 854098, please.
Sorry, wrong bug number. correct one : Bug 881114
I'm using Thunderbird for half a year. Currently it's 24. I checked all folders to sync and this NEVER worked. Only Inbox was synchronized. Tried these properties as well, no result.

mail.check_all_imap_folders_for_new
mail.server.default.check_all_folders_for_new
I have Thunderbird 38.6.0 under Fedora 23, and this problem is a huge embarrassment because emails seem not to have arrived, and the odd thing here is that these are messages that came into my INBOX, were processed by Thunderbird's filters, put into a folder on the IMAP server by Thunderbird itself, yet do no show up as new messages (e.g. in a "virtual folder"/"saved search", nor in any indication of new messages) until a few seconds after I click on the folder it was sent to (even if it has "When getting new messages for this account, always check this folder" ticked)!  Not only is Thunderbird meant to be repeatedly checking this folder every few minutes, it cannot even see a message it moved there itself!

Anyone (Mark, Damian, etc) still see this issue?

Flags: needinfo?(twilightfeel)
Flags: needinfo?(spam)
Flags: needinfo?(maitchy)
OS: Windows XP → All
Summary: IMAP subfolders marked "Check...for new messages" not checked automatically → IMAP subfolders marked "Check...for new messages" not checked automatically (via STATUS command)
Whiteboard: [needs protocol log] → [need protocol log][datalossy]
You need to log in before you can comment on or make changes to this bug.