88 error entries after a failed install from AMO Editors Hub

VERIFIED FIXED in mozilla2.0b8

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: kinger, Assigned: mossop)

Tracking

Trunk
mozilla2.0b8
Points:
---
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 487303 [details]
88 Error entries

When trying to install an add-on from the Editor Hub on AMO, I get 88 error entries in the Add-ons Manager (see attached screenshot).

https://addons.mozilla.org/en-US/editors/review/120555

Multiple Error console messages:

Warning: WARN addons.xpi: Download failed: [Exception... "Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [nsIZipReader.open]"  nsresult: "0x8052000b (NS_ERROR_FILE_CORRUPTED)"  location: "JS frame :: resource://gre/modules/XPIProvider.jsm :: AI_loadManifest :: line 4814"  data: no]

After download the doorhanger message tells me the file is corrupt.

I can reproduce on Win Vista and Mac OS X
(Reporter)

Updated

7 years ago
Summary: 88 error entries after a fialed install → 88 error entries after a failed install
(Reporter)

Comment 1

7 years ago
It is happening for all add-ons in the Editors hub, but regular listings on AMO are working fine.

This is reminiscent of bug 590119, but there were different errors that time.
Summary: 88 error entries after a failed install → 88 error entries after a failed install from AMO Editors Hub
Does it also happen when you install it from the local disk or the public AMO page (if accessible)? Is it a regression?
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> Does it also happen when you install it from the local disk or the public AMO
> page (if accessible)? Is it a regression?

I've been doing most of my reviews on 3.6 'til now, so I am not sure if it is a regression. I am sure another editor would have noticed it however, so I would say it is something unique to my environment.

Regular AMO listings and local installs work fine.
What about a fresh profile? Have you tried that yet? Would be good to be able to exclude any user set preferences and other installed add-ons.
(Assignee)

Comment 5

7 years ago
I can reproduce this, not sure yet what is going on though
(Assignee)

Comment 6

7 years ago
This is caused by a broken call to InstallTrigger.install (bug 608762) and a failure in the new implementation of InstallTrigger to identify the bad arguments.

This code should be throwing an exception, not attempting to install from random URLs:

InstallTrigger.install('https://addons.mozilla.org/en-US/firefox/downloads/file/102295/outwit_pack-1.0.0.1-fx.xpi',
'OutWit Hub 1.0.0.1', '',
'sha256:c750017b572ebc6417324196f216a13216e5f65de6abd8b1a5a1ce07618ccfdc');
Assignee: nobody → dtownsend
blocking2.0: --- → betaN+
So, is this a dupe of 608762?
(Assignee)

Comment 8

7 years ago
(In reply to comment #7)
> So, is this a dupe of 608762?

No there are two different bugs, AMO are doing the wrong thing and so is Firefox.
(Assignee)

Comment 9

7 years ago
Created attachment 487360 [details] [diff] [review]
patch rev 1

This does proper checking that the arguments passed to InstallTrigger.install are what we expect them to be and adds a test to ensure we throw an exception in the case of passing a string.
Attachment #487360 - Flags: review?(robert.bugzilla)
(Assignee)

Updated

7 years ago
OS: Windows Vista → All
Hardware: x86 → All
Whiteboard: [has patch][needs review rs]
(Assignee)

Updated

7 years ago
Attachment #487360 - Flags: review?(robert.bugzilla) → review?(bmcbride)
Comment on attachment 487360 [details] [diff] [review]
patch rev 1

>+    if (!aArgs || typeof aArgs != "object")
>+      throw new Error("Incorrect arguments passed InstallTrigger.install()");

You appear to be missing a proposition.

r=me with that fixed.
Attachment #487360 - Flags: review?(bmcbride) → review+
(Assignee)

Comment 11

7 years ago
Landed: http://hg.mozilla.org/mozilla-central/rev/6a04da069ef7
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Whiteboard: [has patch][needs review rs]
Target Milestone: --- → mozilla2.0b8
Brian, can you please check that it is fixed? Thanks.
(Reporter)

Comment 13

7 years ago
(In reply to comment #12)
> Brian, can you please check that it is fixed? Thanks.

Verified.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.