All users were logged out of Bugzilla on October 13th, 2018

Make bugmail smarter (when changing keyword, dependencies, and CC)

VERIFIED DUPLICATE of bug 55161

Status

()

P3
enhancement
VERIFIED DUPLICATE of bug 55161
18 years ago
6 years ago

People

(Reporter: jacob, Assigned: justdave)

Tracking

Details

(Whiteboard: 2.16)

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
Currently, if someone adds/removes themselves to a CC, changes a dependancy, or
keyword You get a the three column "What | Old | New" stuff.  On bugs with high
amounts of dependencies, CC's and/or keyword this can make it very difficult to
figure out what really changed.

I wrote a patch that uses a sort of parsing to figure out what really changed
between $old and $new and then using FormatDouble to include it in the BugMail.
I set it up to work with BugsThisDependsOn, CC, Keywords, OtherBugsDependingOnThis.
I also made a change in the FormatDouble subroutine to make it visually similar
to FormatTriple.
(Reporter)

Comment 1

18 years ago
Created attachment 19632 [details] [diff] [review]
[PATCH] Make Bugmail more readable
(Reporter)

Comment 2

18 years ago
Adding patch keyword and "block" status on bug 53044.
Blocks: 53044
Keywords: patch
(Reporter)

Comment 3

18 years ago
Just as I was afraid of... it crashed... :(
(Reporter)

Comment 4

18 years ago
Oops... I typed that comment in the wrong window!! It was supposed to go into my
test bugzilla db.  Sorry...
(Reporter)

Comment 5

18 years ago
The 11/22 patch doesn't work.  There are a couple missing commas and a logic
error.  As soon as cvs-mirror is back up (see bug 62130), I'll pull of DIFF of
my latest (and working) changes.
Keywords: patch
(Reporter)

Comment 6

18 years ago
Created attachment 20361 [details] [diff] [review]
[PATCH] Working version of previous patch
(Reporter)

Comment 7

18 years ago
Created attachment 20362 [details]
Sample e-mail created by above patch
(Reporter)

Updated

18 years ago
Keywords: patch, review
Is this a dupe of bug #30359?
(Reporter)

Comment 9

18 years ago
*** Bug 30359 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

18 years ago
I marked 30359 a dupe of this one 'cause this one has the patch.  As I mentioned
there, I'll update this patch after dmose lands his mail filtering stuff.

Comment 11

18 years ago
-> jake
Assignee: tara → jake
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 12

18 years ago
Created attachment 23455 [details] [diff] [review]
patch v3
(Reporter)

Comment 13

18 years ago
Just attached patch v3 to update to the CVS tip (after bug 17464 landed).
I also used Dan's new filterExcludeList() subroutine instread of the 
"if (!($new =~ /$val/)) {" like I was before (this cleared up the problem 
where if you were changing from rtm- to rtm it wouldn't pick up on the change).
 The e-mail is essentially the same as shown 12/8.

Comment 14

18 years ago
Is this patch just going to rot?  This would be rather nice to have :)
(Reporter)

Comment 15

18 years ago
I agree this would be nice to have (enough to write the patch, at least :). 
2.12 is predicted for RSN and thus should have anything else added to its list.

Nominating for 2.14.
Whiteboard: 2.14
(Reporter)

Updated

18 years ago
Whiteboard: 2.14 → 2.16
moving to real milestones...
Target Milestone: --- → Bugzilla 2.16

Comment 17

18 years ago
Great, so it will take at least another seven months, if not much longer, until
I can really see again which changes were made in the CC field of a bug with
lots of CCs.  At the moment, bugmails (and show_activity.cgi output) regarding
CC changes are rather useless.  And as the popularity of Mozilla increases, the
number of bugs with a huge CC list increases as well.

This is frustrating.  Please either include more submitted patches in 2.12 or
bring out releases much more frequently.  See also
http://www.tuxedo.org/~esr/writings/cathedral-bazaar/cathedral-bazaar/x147.html

Currently there are at least 40 bugs outside the 2.12 target milestone with a
patch attached.  The list is here for your convenience:
http://bugzilla.mozilla.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&product=Webtools&component=Bugzilla&target_milestone=---&target_milestone=Future&target_milestone=Bugzilla+2.14&target_milestone=Bugzilla+2.16&target_milestone=Bugzilla+2.18&target_milestone=Bugzilla+3.0&target_milestone=Bugzilla+3.2&keywords=patch%2Creview&keywords_type=anywords

And sorry for the offtopic rant.
Can someone please paste what an email with this looks like.  I want to make
sure all the issues raised in the dupes are covered.
*** Bug 73001 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 20

18 years ago
matty@chariot.net.au:
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=20362

The e-mail produced by patch v3 is almost identical (very minor formating
differences).
Do we really need to spray all the old values everywhere, especially with CC?

Also correct me if I'm wrong but AFAICS this does nothing to align each email
address on a new line which would be ten times more readable, yet dupes have
been marked of this which ask for that.
(Reporter)

Comment 22

18 years ago
I kinda went back and forth on the inclusion of the current Old/New columns.  At
this point in time I think the best bet would be to change the bug activitiy
from the current Old/New style to a Removed/Added style (which has been
discussed in IRC before).
We might want to eventually add support to let users customise this as follows:

Field X:

[ ] Always show.
[ ] Show entire field on changes to field.
[ ] Show just changes to field.

(2) would only appear for list fields because the others aren't relevant.  There
is significant support for (1) around in various bugs for different fields.

Comment 24

18 years ago
See also bug 28736, which would make dependency changes more readable by 
including the summary of the other bug and maybe also a link.

Comment 25

18 years ago
couldn't the patch be implemented and fine-tuned later? 

Checking dependencies has become very difficult on long lists (meta bugs) ;)
Myk, see comments from st.n@gmx.net 2001-02-28 08:44 in this bug about the "help
getting the backlog of existing patches for bugzilla reviewed and checked in"
challenge.
(Reporter)

Comment 27

18 years ago
While not a direct duplicate, I believe bug 55161 is the better way to fix this
(and was going to morph this bug into that concept before I stumbled accross
that one [OK, before Matthew targeted it so it appeared in my Inbox]).  While
that nullifies the patch here, I think it's better in the long run.

*** This bug has been marked as a duplicate of 55161 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 28

17 years ago
Bug 55161 fixed the *activity* display, but not the email format. Can we get the
e-mail format updated the same way?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 29

17 years ago
The e-mail data is pulled directly from the activity log, so this was fixed by
bug 55161 (to test this, try http://landfill.tequilarista.org/bugzilla-tip/ as
mozilla.org hasn't updated yet.)

*** This bug has been marked as a duplicate of 55161 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

17 years ago
No longer blocks: 53044
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: jake → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Target Milestone: Bugzilla 2.16 → ---
Version: other → unspecified

Comment 31

17 years ago
Verified dupe
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.