Selecting "Don't show this message..." should prevent pop-up blocked info bar from being displayed

RESOLVED FIXED in Firefox 4.0b8

Status

()

Firefox
General
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: streetwolf, Assigned: fryn)

Tracking

(Depends on: 1 bug, {regression, ux-control})

Trunk
Firefox 4.0b8
regression, ux-control
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101013 Firefox/4.0b8pre
Build Identifier: 20101013184549

Pop-up block info bar always displays even though it's checked not to. www.msnbc.com is a good site to test this. 

Reproducible: Always




Today's nightly build introduced this.  Lot's going on with this nightly.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk

Comment 1

8 years ago
I can confirm this.

Comment 2

8 years ago
I've been seeing this problem for quite some time in the nightlies.

Comment 3

8 years ago
Confirmed.
But, A status bar was removed, and the icon which showed that popup was blocked was also removed, So, I think that some kind of notices are necessary.

Comment 4

8 years ago
this behavior is intentionally by Bug 574688.
And this depend on Bug 594294.
Depends on: 594294
(Reporter)

Comment 5

8 years ago
This problem only started with today's nightly.  The Add-on bar has been in place for at least a week or more. I for one don't want to see the info bar everytime there is a blocked popup.
(Reporter)

Comment 6

8 years ago
Seems I found a workaround for the info bar.  When the info bar pops up click on the options and allow the site to use popups.  Refresh the page and see the popup.  Close out the popup and while still on the main page right click and choose 'View Page Info'.  Go to Permissions and change he option 'Open pop-up windows' to 'block' or 'default'.

Updated

7 years ago
Blocks: 610349
Duplicate of this bug: 610349
Blocking on this regression.
blocking2.0: --- → final+

Updated

7 years ago
No longer blocks: 610349

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 9

7 years ago
The bug on which this depends got marked not blocking, but we still want this regression fixed (it's a blocker), so I'm going to go ahead and fix it anyway for now and deal with its dependency later.
Assignee: nobody → fryn
Status: NEW → ASSIGNED
Keywords: regression, ux-control
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Updated

7 years ago
Depends on: 588317
(Assignee)

Updated

7 years ago
Summary: Pop-up block info bar always displays. → Selecting "Don't show this message..." should prevent pop-up blocked info bar from being displayed
(Assignee)

Comment 10

7 years ago
Created attachment 492521 [details] [diff] [review]
patch

(In reply to bug 594294 comment #4)
Gavin Sharp wrote:
> I think we should remove the dead code in the interim.
> http://hg.mozilla.org/mozilla-central/rev/eec9a82ad740#l6.45

This removes it.

This patch fixes the "Don't show this message..." checkbox, which currently does nothing due to its code being commented out. That functionality was already broken for users that had the checkbox checked before we broke it, since we removed the status bar icon, which was the other indicator.

The lack of a less noisy indicator will be fixed asap in bug 588317, which will move both the bar and the icon that used to exist to the location bar. We will also remove the ability to hide the bar, since the bar will no longer exist.
Attachment #492521 - Flags: review?(gavin.sharp)
(Assignee)

Updated

7 years ago
Attachment #492521 - Flags: ui-review?(faaborg)
Comment on attachment 492521 [details] [diff] [review]
patch

fine for addressing this blocking bug, eventual UI is still planned to be bug 588317
Attachment #492521 - Flags: ui-review?(faaborg) → ui-review+
Comment on attachment 492521 [details] [diff] [review]
patch

As I understand it, the only thing that's broken is toggling the pref from the menu - if you set it to false manually (or had it set to false before we broke this), it should still be preventing the notification from showing, right? Comment 0 was kind of misleading here.

We could probably go further and remove the blockedPopupDontShowMessage broadcaster (and just set the attributes on the menuitem directly), though I don't know offhand how that meshes with bug 588317 - if it isn't going to be used or removed in that bug, make sure a followup is filed?

This makes bug 311866 INVALID by removing the dialog; nice to finally get rid of it.
Attachment #492521 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 13

7 years ago
Pushed.

http://hg.mozilla.org/mozilla-central/rev/bacd5fbd6456
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Target Milestone: --- → Firefox 4.0b8
You need to log in before you can comment on or make changes to this bug.