Overdrawing/not clearing when scrolling sites

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Joe Drew (not getting mail), Assigned: Joe Drew (not getting mail))

Tracking

({dogfood, regression})

unspecified
x86
Mac OS X
dogfood, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 beta8+)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

7 years ago
At least on the linked blog, which uses a fancy Wordpress theme, scrolling causes us to draw old results. This is almost certainly a regression from bug 575521, and was not caught by our testsuite.
(Assignee)

Comment 1

7 years ago
We can't release a major milestone with this bug.
blocking2.0: --- → beta8+
Keywords: dogfood
(Assignee)

Comment 2

7 years ago
Created attachment 490028 [details] [diff] [review]
clear the area of transparent surfaces into which we're going to draw

I will come up with a testcase for this too, but this fixes the bug.
Attachment #490028 - Flags: review?(jmuizelaar)
(Assignee)

Updated

7 years ago
Keywords: regression
Whiteboard: [review needed jeff]
Just to see if other cases are fixed with this, I'm seeing something similar on http://dev.w3.org/html5/websockets/ (fixed background) and in the tab bar when I scroll the overflow. I'm also seeing this in multilines <select>.
(Assignee)

Updated

7 years ago
Duplicate of this bug: 611718
Attachment #490028 - Flags: review?(jmuizelaar) → review+
Summary: Overdrawing/not clearing when scrolling sites with transparency → Overdrawing/not clearing when scrolling sites
I filed bug 611786, is that a dup?

Updated

7 years ago
Duplicate of this bug: 611786
(Assignee)

Updated

7 years ago
Whiteboard: [review needed jeff]
(Assignee)

Comment 7

7 years ago
Created attachment 490227 [details] [diff] [review]
test for bug

I was able to come up with a test that reproduces the problem.
Attachment #490227 - Flags: review?(jmuizelaar)
Attachment #490227 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 8

7 years ago
http://hg.mozilla.org/mozilla-central/rev/74fe0c57e581
http://hg.mozilla.org/mozilla-central/rev/32fad78c84fa
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.