Last Comment Bug 611921 - Closing a panorama tab group should be recoverable, like tabs and windows
: Closing a panorama tab group should be recoverable, like tabs and windows
Status: RESOLVED WONTFIX
: dataloss, ux-error-recovery
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: unspecified
: All All
P4 critical
: Future
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 1196184 (view as bug list)
Depends on: 587676
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-12 18:53 PST by Jonathan Watt [:jwatt]
Modified: 2016-04-12 14:00 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Jonathan Watt [:jwatt] 2010-11-12 18:53:55 PST
I just closed some tab groups, came out of panorama, and then realized I shouldn't have closed two of the groups. There does not seem to be any way to get them back though. This is contrary to the History > Recently Closed Tabs and History > Recently Closed Windows functionality. Panorama should really have the same sort of thing.

As an aside, when I closed the groups they changed to a little area saying Undo Close Group, so I thought going back to undelete wouldn't be a problem. Those areas had gone though. Subsequently I found that they disappear after a few seconds. I think this is really bad. There's a small (x) on them to close them if you really want them gone, and I really dislike this timeout behavior.
Comment 1 User image Kevin Hanes 2010-11-17 15:51:11 PST
Seems like this bug is two ideas.

1. Make undo close group more coherent with the undo close tab and history features. 

and...

2. Get rid of the timeout on our current undo close group in Panorama

I am a big fan of 1; if we can (and we clearly can) keep track of your groups, then Firefox should reflect that in a more unified manner. 

I do not agree with getting rid of our timeout however. If we do that, we are essentially opening a modal dialog every time someone closes a group asking if they are sure. Also, if we implement part 1, then this is entirely unnecessary.
Comment 2 User image Kevin Hanes 2011-01-10 10:07:43 PST
bugspam (moving b9 to b10)
Comment 3 User image Kevin Hanes 2011-01-10 10:10:31 PST
bugspam (removing b9)
Comment 4 User image Kevin Hanes 2011-01-11 15:54:29 PST
punting
Comment 5 User image YF (Yang) 2015-12-17 21:11:20 PST
*** Bug 1196184 has been marked as a duplicate of this bug. ***
Comment 6 User image Justin Dolske [:Dolske] 2016-02-03 16:11:15 PST
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Comment 7 User image Ulrich Windl 2016-02-03 23:56:33 PST
(In reply to Justin Dolske [:Dolske] from comment #6)
> We're removing Panorama because it has extremely low usage (about 0.01% of
> users), and has a large number of bugs and usability issues. (...)

Well I also missed that "tab groups" actually do exist, until I was looking for the keyboard shortcut to find a specific tab. Maybe that's one reason why few people use it (they don't know it exists).
The other thing is that many people are completely unable to work with multiple windows (those who always have one window full-screen, as opposed to those who have windows all over the desktop) plus current incompleteness of the concept.
This doesn't mean people don't use it because the concept is bad or not wanted; it's like the E-cars (i9nteresting, good, but not ready for mainstream) MHO...

Note You need to log in before you can comment on or make changes to this bug.