Some characters are doubled when typed in any text field.

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
VERIFIED FIXED
7 years ago
4 years ago

People

(Reporter: Anna (Waverley), Assigned: mbrubeck)

Tracking

Trunk
ARM
Android

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101117 Firefox/4.0b8pre
Build Identifier: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre) Gecko/20101123 Firefox/4.0b8pre Fennec /4.0b3pre

Whenever you type a digit in any input text field the digit is doubled.

Devices: Samsung Galaxy S Captivated. (Android 2.1 updated)
         Motorola Droid 2. (Android 2.2)

Reproducible: Always

Steps to Reproduce:
1. Visit www.google.com 
2. Type "123" in the search field.

Actual Results:  
The digits displayed are: "1123|32" "|" = position of the cursor. Also if you want to delete the digit "3" (only one), both 3's will be erased.

Expected Results:  
The expected result should be: "123".
(Reporter)

Updated

7 years ago
OS: All → Android
Hardware: All → ARM
(Reporter)

Comment 1

7 years ago
The same behavior is observed on:

Device:   Motorola Droid 2,
Build ID:  Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre)Gecko/20101123 Firefox/4.0b8pre Fennec /4.0b3pre

when trying to enter an URL in the awesome bar. (e.g.: www.msn.com) ONLY using the hardware keyboard.

Actual Result: "wwwwww.mmssnn.ccoomm".

Expected Result: "www.msn.com"
(Assignee)

Updated

7 years ago
tracking-fennec: --- → ?
Summary: Digits are doubled when typed in any text field. → Some characters are doubled when typed in any text field.
(Assignee)

Comment 2

7 years ago
Regression from bug 599811.
Assignee: nobody → mbrubeck
Blocks: 599811
Status: NEW → ASSIGNED
(Assignee)

Comment 3

7 years ago
Created attachment 492657 [details] [diff] [review]
patch

I think this fixes it; haven't finished building and testing yet.
Attachment #492657 - Flags: review?(blassey.bugs)

Updated

7 years ago
Attachment #492657 - Flags: review?(blassey.bugs) → review+
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Duplicate of this bug: 614252
(Reporter)

Comment 6

7 years ago
VERIFIED FIXED on Devices: Samsung galaxy S Captivated and Motorola Droid 2,

Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre)Gecko/20101124
Firefox/4.0b8pre Fennec /4.0b3pre
Status: RESOLVED → VERIFIED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 614230
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.