Web Console gets stuck at 0px height w/ border and keyboard shortcut breaks

RESOLVED FIXED

Status

defect
P2
normal
RESOLVED FIXED
9 years ago
Last year

People

(Reporter: fryn, Unassigned)

Tracking

Trunk
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 601909])

Reporter

Description

9 years ago
This happens on Windows but not OS X for me, possibly due to a difference in key repeat rates.

Steps to reproduce:
1. Open Web Console using ctrl-shift-k.
2. Wait for the Web Console animation to finish.
3. Close Web Console using ctrl-shift-k.
4. Before the Web Console finishes its closing animation, hold down ctrl-shift-k.

Actual results:
Web Console opens up, but its height is 0px, and you can only see its border. Continuing to hold down ctrl-shift-k or releasing and pressing again doesn't do anything, and the Web Console remains in this state. The height can still be adjusted by dragging the border (resizer).

Expected results:
Web Console repeatedly closes and opens normally with the animation and all.
possible fix is to decrease the transition time to open/close? see bug 612300.

can't reproduce on Mac, but I'll try it on my PC and report back.
Depends on: 612300
able to reproduce on windows.

I think what's happening is that during the repeated opening and closing, the previously opened height is being recorded (bug 601909) and it oscillates from the last opened height down to a smaller value as the console opens and closes, eventually ending up at 0px.

Not a hugely critical bug as you can still open it with the resizer, but I could see it being annoying.

Adjusting key repeat rates may have different effects as well.
Reporter

Comment 3

9 years ago
A possible fix would be to record the previously opened height only if the transition has ended.
oh, after some further playing, I see that you can't actually close the console at all in this state. It's "stuck" open. Only way to get rid of it is to close the tab. That makes this a little more critical.
(In reply to comment #3)
> A possible fix would be to record the previously opened height only if the
> transition has ended.

yeah, that would work.
Reporter

Comment 6

9 years ago
(In reply to comment #4)
> oh, after some further playing, I see that you can't actually close the console
> at all in this state. It's "stuck" open. Only way to get rid of it is to close
> the tab. That makes this a little more critical.

Don't think the above fix will resolve this though :\
not sure. Need to debug this a little to see what's actually happening.

Updated

9 years ago
Blocks: devtools4
Reporter

Comment 8

9 years ago
I can now reproduce this on Mac.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101204 Firefox/4.0b8pre
OS: Windows 7 → All
but can you close it completely? I can't get it to stick in a way that it's uncloseable with the keyboard shortcut on mac or windows.

Updated

9 years ago
Priority: -- → P2
Reporter

Comment 10

9 years ago
From my investigation, it seems like this was fixed when the patch for bug 601909 landed.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 601909]
Reporter

Updated

9 years ago
Depends on: 601909
This issue is still reproducible. Please see bug 693201.

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.