Minefield "about" box showing neither "up to date" nor a button for checking for updates

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: dria, Assigned: rstrong)

Tracking

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(1 attachment)

Created attachment 493986 [details]
about box refusing to help me

Stumbled across this when trying to check for updates this morning.  Screengrab attached.
Rob: is this caused by one of the timeout/network failure states?
This may have been caused by the "update ready to apply" popup window being open in the background, which I thought we had an existing bug on file for (but I can't find it).
Damon just told me he hit this today, too :/
Yes, seems to happen when I close my macbook and switch wifi networks (i.e., drive into the office).  Also, I get stuck in Offline mode where it's asking me to uncheck the Work Offline option.  Even unchecked and with a working wifi connection, I'm stuck in offline mode.  I'm assuming that's a different bug, but these two seem to happen at the same time.  When I'm stuck in offline it triggers me to look at the about box and that's when I notice that there's no update/current information.  And, probably a third, related bug, is eventually, when in this state, the about box stops working completely (open it, be confused as why there's no version info, close it, turn on offline and then off again, try to open the about box, blammo, no about box to be found, restart, all OK).

Updated

7 years ago
blocking2.0: --- → betaN+
Might have the same root cause as the bug that is causing offline mode to be stuck. I'm looking into it.

Comment 6

7 years ago
Damon mentioned on IRC if this could be an instance of bug 614286, and I told him no!  (just for the record)
Just talked with Ehsan - I think this might in fact be caused by the same underlying bug described in bug 613998, and that in turn might be the same issue as bug 614286 (though we're not sure). Hopeful that the fix for bug 614286 will address all of these.
Thank you Gavin
Just talked with Damon and at least in his case he can't browse web pages so update checks would definitely fail. Not 100% sure why nothing is displayed in the ui at that point though it could be due to code bailing due to bug 614286. I have verified that the ui is displayed under normal circumstances when in offline mode though it will just display that Minefield is up to date due to the ui not displaying error conditions per the original implementation specification.
Can this still be reproduced?
I think there are two separate issues:
1) no update button/status appearing when there is an "update ready to apply" dialog in the background
2) no update button/status appearing in some error conditions (offline mode triggered by bug 614286 or related issues that are likely now fixed)

We need a bug on 1), if this isn't it. I think 2) was mostly addressed by bug 614286, but there may be some remaining edge cases where it can crop up.
I filed bug 599574 for creating a toolkit widget that apps can use similar to what is in Firefox's about dialog and when I create that I plan on making it possible to have both open at the same time which would solve bug 1 but that won't happen for Firefox 4.

One possibility for bug 1 for Firefox 4 is providing a button in the about dialog that would then focus the update UI. If this is wanted / needed for Firefox 4 then that should be the approach taken and this bug would suffice. Otherwise, it will be taken care of in bug 599574.
(In reply to comment #10)
> Can this still be reproduced?
Once again, can this still be reproduced
Assignee: nobody → robert.bugzilla
I finally remembered to check once the update dialog popped up (sorry it took so long, I just kept forgetting) and...I can't replicate it anymore.  It now shows the current version + the apply update button.
Thanks! I suspect that bug 614286 fixed this but since I can't say that it did so with 100% certainty I am resolving this as wfm.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
I just reproduced this with today's nightly, on Windows. My update failed, so on startup I got the "update failed to apply, we'll try a full update". Opening the about dialog while that window was open in the background resulted in the symptoms from comment 0.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
What Deb reported was not caused by the app update window being opened. Yes, if the app update window is open already the ability to check for updates is disabled in the about window. As I stated in comment #12 I have filed bug 599574 to provide a generic widget that will handle this.

I am re-closing this bug because the cause / steps to reproduce is different than the cause / steps to reproduce for what you are describing and I filed bug 624617 for the about Window not having controls for checking for updates when the app update window is already opened.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.