Closed Bug 616251 Opened 9 years ago Closed 9 years ago

Sync UI: Disable auto-hyphenation in Firefox 4.0b8

Categories

(Firefox :: Sync, defect, major)

defect
Not set
major

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- beta8+

People

(Reporter: jhford, Assigned: philikon)

References

Details

(Whiteboard: [has patch][has review][will land with J-PAKE UI])

Attachments

(1 file)

My computer crashed and when I relaunched minefield, my profile was gone.  I started up and tried to use sync to get my profile back.

When trying to enter my sync key, the wizard keeps changing my input to include hyphens as the second, and every seventh char after the second.  It is also removing any numbers I type in.

What is going on?  Were the requirements for the key changed recently or something?  Is there no (apparent) way to convert my old key into a new key?  Would it be possible to inform a user that there was a change.  Instead of manipulating the key, why not accept the old style key and inform me that I need to change to a new key.

Is my sync data gone forever? Is my browser busted?
Hi John,

Sounds like you're using a very recent build -- at the end of November we landed crypto simplification work that includes changes to sync keys.

On startup, Sync will quietly upgrade your key and bump the storage version on the server. This should all be seamless. You're seeing the seam because you're essentially setting up a new device, but without knowledge of your key.

You can no longer enter an old-style sync key, because you shouldn't need to enter one unless you're setting up a new device: you're either upgraded, or you generate a new key.

The UI you're seeing is 'helping' you to type the correct format of key.

You're likely to be in one of two states:

* Less likely: your data on the server has been upgraded, and your profile disappearing means that your locally saved sync key is gone.

Take a look in password manager ("Mozilla Services Encryption Passphrase" should be right at the top); if you see 26 characters for your passphrase, then just type those in. If you don't, then it's possible to derive your new key... but I don't know if there's even any data on the server.

* More likely: the server has not been upgraded, and still has your old data. Try a nightly build from prior to 2010-11-30; that might sync down your data and rebuild your profile. You can then back up your profile and try a more recent build, which will upgrade everything to the new Sync version.

If you get an error message from an older build saying "you need to upgrade your Sync version", and you're unable to find your sync key, then we'll need to manually derive your sync key from your old passphrase. That's a slightly involved process, so I won't describe it yet.


I think it's important to mention that Sync is not a backup service. It's entirely possible for data on the server to disappear, and a valid error handling approach for Sync is to blow it away and start again. You should keep backups of your profile, particularly if you're frequently updating to new Minefield builds or nightlies. You're living on the edge...
I think we need to remove the cleverness in the short term, and put it back for final.  The transition will be too painful otherwise.  And we may not be able to keep it at all.
Assignee: nobody → philipp
blocking2.0: --- → beta8+
(In reply to comment #2)
> I think we need to remove the cleverness in the short term, and put it back for
> final.  The transition will be too painful otherwise.  And we may not be able
> to keep it at all.

I agree this is somewhat painful. But I wonder whether we should have to back down on what I think is the right thing to do just because a rather uncommon procedure does not work right now. Mix and match between nightlies and other Firefox versions is always a big problem when revving the storage format. It's not like we didn't know this in advance.

It still pains me to break people like that, but I keep thinking about the bigger picture (Firefox 4 and onward). I would personally prefer to let people know of this change and what they need to do rather than carry the legacy in our code forever. I volunteer to blog about it, but a small piece of text in the UI might work too, e.g.:

  If your existing Sync Key is not accepted, please make sure to upgrade
  Firefox Sync on your other computers first and type in the new key that
  will be generated for you. _Show me how._
This is a step backwards in ease of use. I know my sync key. I created it. Now I have to write down some cryptic key and enter it on all of my machines?
(In reply to comment #4)
> This is a step backwards in ease of use. I know my sync key. I created it. Now
> I have to write down some cryptic key and enter it on all of my machines?

By the time all this launches, you'll typically never have to see or type your sync key.

New users will have it generated.

Existing users will have it upgraded for them.

Neither will be involved in those processes.

Setting up a new device will use a system called J-PAKE, which to you and me is essentially magic -- just like pairing a Bluetooth headset with your phone, but exchanging your Sync tokens.

You'll only need to look at and type your sync key for backup purposes, or if J-PAKE isn't possible for some reason.


All told, you're pretty much going from

  username
  password
  passphrase

to just username and password. I call that a win.
(In reply to comment #4)
> This is a step backwards in ease of use. I know my sync key. I created it. Now
> I have to write down some cryptic key and enter it on all of my machines?

For another few days, yes. We're going to introduce bluetooth-like pairing very soon that will make any sort of tedious typing, particularly on mobile, unnecessary.
(In reply to comment #5)
> Setting up a new device will use a system called J-PAKE, which to you and me is
> essentially magic -- just like pairing a Bluetooth headset with your phone, but
> exchanging your Sync tokens.
> 
> to just username and password. I call that a win.

Wow. forgive my ignorance, that sounds fantastic.
Honestly, I don't think the win is big enough, in the case where you're typing this in, to break the million or so existing users who don't yet know that their key has been converted.
Whiteboard: [needs patch]
Redirecting this to rnewman.  We basically need to just disable the rewriting, but I think we'll put this back for final.  But right now I think the gain is outweighed by the pain involved.
Assignee: philipp → rnewman
>I think we'll put this back for final

I think it seems entirely reasonable to put this back after we have jpake in place.
Philipp is busy touching the wizard code, so I'm holding off on making any code changes until J-PAKE drops.
Status: NEW → ASSIGNED
Duplicate of this bug: 617176
OS: Linux → All
Hardware: x86_64 → All
Summary: I can't enter my sync key because my input is being screwed with → Sync UI: Disable auto-hyphenation in Firefox 4.0b8
Blocks: 617173
Depends on J-PAKE UI work. (Metadata.)
Depends on: 602876
use correct jpake bug
Depends on: 602682
No longer depends on: 602876
This doesn't block the merging bug because there's nothing to merge. Integrated Firefox UI lives in mozilla-central.

We need to clone this bug for the add-on UI, but that doesn't get merged to mozilla-central either.
No longer blocks: 617173
Attached patch v1Splinter Review
Rip out the auto-hyphenation and the Sync Key validation as you type for now.

Sorry for stealing this blocker from you, Richard ;) But I had all the stuff it depends on in my patch queue already, and since I wrote the original code I knew where to go :)
Assignee: rnewman → philipp
Attachment #495774 - Flags: review?(mconnor)
Whiteboard: [needs patch] → [has patch][needs review mconnor]
Blocks: 617264
Attachment #495774 - Flags: review?(mconnor) → review+
(In reply to comment #16)

> Sorry for stealing this blocker from you, Richard ;) But I had all the stuff it
> depends on in my patch queue already, and since I wrote the original code I
> knew where to go :)

Feel free to raid my bug list any time :D
Did this not land?
(In reply to comment #18)
> Did this not land?

No, my patch is based on the JPAKE UI because that revamps the setup wizard a bit. I'll land it together with the JPAKE UI changes.
Whiteboard: [has patch][needs review mconnor] → [has patch][has review][will land with J-PAKE UI]
http://hg.mozilla.org/mozilla-central/rev/04a4bf3504aa
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
No longer blocks: 615950
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.