Last Comment Bug 618198 - redraw issues after restarting firefox from fullscreen mode
: redraw issues after restarting firefox from fullscreen mode
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: XP Toolkit/Widgets: XUL (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 1 vote (vote)
: mozilla2.0
Assigned To: Jim Mathies [:jimm]
:
: Neil Deakin
Mentors:
Depends on:
Blocks: 574690
  Show dependency treegraph
 
Reported: 2010-12-09 18:15 PST by brianjamos
Modified: 2011-04-23 20:49 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
broken screen. F11 > close by clicking "X" > restart > F11 > mouse hover (291.54 KB, image/png)
2011-01-07 20:25 PST, Alice0775 White
no flags Details
titlebar (28.54 KB, image/png)
2011-01-12 12:38 PST, Jim Mathies [:jimm]
no flags Details

Description brianjamos 2010-12-09 18:15:54 PST
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

The menu toolbar disappears after closing firefox from within fullscreen mode and then re-opening.



Reproducible: Always

Steps to Reproduce:
1.Enter full screen mode
2.close firefox using the upper right hand red "X"
3.re-open firefox
Actual Results:  
no longer in full-screen mode and menu toolbar appears to be hidden.  In some cases the window re-draw is significantly impaired.  other times full screen mode is still active and when coming out of full screen mode, the "Menu" toolbar is still not visible.

Expected Results:  
start in full screen mode or start with last toolbar configuration before entering fullscreen

Windows XP SP3.
Comment 1 brianjamos 2010-12-09 18:25:40 PST
appears to be more of a re-draw problem (possibly related to graphics drivers) than originally thought.  the menu doesn't disappear (it can't be seen because it is not being properly drawn).

GPU: nvidia Geforce 9400GT 
graphics driver: 6.14.12.6099

would have changed actual results, but can't edit due to permission level - sorry.
Comment 2 Alice0775 White 2010-12-09 19:18:57 PST
Confirmed on 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101209 Firefox/4.0b8pre ID:20101209030340

Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/188670e40942
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101015 Firefox/4.0b8pre ID:20101015070125
Fails:
http://hg.mozilla.org/mozilla-central/rev/5c698ec1841c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101015 Firefox/4.0b8pre ID:20101015074501
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=188670e40942&tochange=5c698ec1841c
Comment 3 Alice0775 White 2010-12-09 19:28:28 PST
After step 3.re-open firefox,
Click restore button of fullscreen window control buttons at the upper right corner,
Desktop , taskbar and whole other windows fail to repaint.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101209
Firefox/4.0b8pre ID:20101209030340
Comment 4 Dietrich Ayala (:dietrich) 2010-12-13 17:59:37 PST
Closing from a non-default state makes this a pretty narrow case, blocking-. Would take a safe patch.
Comment 5 Jim Mathies [:jimm] 2010-12-14 12:05:47 PST
(In reply to comment #3)
> After step 3.re-open firefox,
> Click restore button of fullscreen window control buttons at the upper right
> corner,
> Desktop , taskbar and whole other windows fail to repaint.
> 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101209
> Firefox/4.0b8pre ID:20101209030340

I wonder if this is specific to video hardware/drivers. I'm not able to reproduce the original problem or this one.
Comment 6 Alice0775 White 2011-01-07 20:25:54 PST
Created attachment 502191 [details]
broken screen. F11 > close by clicking "X" > restart > F11 > mouse hover

F11 
Close by clicking "X"
Restart
F11
Mouse hover

Completely broken screen. 
I think the above str is not special case.
Comment 7 Alice0775 White 2011-01-10 14:20:12 PST
Sorry,
Comment #3, Comment #6 are different bug because the regression range is different.
Comment 8 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-01-12 12:17:19 PST
Part of this seems related to the fact that session restore doesn't handle full screen mode (bug 539597) and is similar to the private browsing mode transition with full screen mode (bug 500150). The painting issue is weird though.
Comment 9 Jim Mathies [:jimm] 2011-01-12 12:34:21 PST
oops, sorry, didn't mean to remove that. I don't see how that would cause the problems I'm seeing with glass painting black after coming out of full screen.
Comment 10 Jim Mathies [:jimm] 2011-01-12 12:38:09 PST
Created attachment 503255 [details]
titlebar

Is anyone else seeing this? STR:

1) f11
2) close
3) restart
4) f11 (normal mode)
5) resize the window
Comment 11 Alice0775 White 2011-02-15 16:14:17 PST
Did Bug 629860 fix this?
Comment 12 Jim Mathies [:jimm] 2011-02-15 16:39:44 PST
(In reply to comment #6)
> Created attachment 502191 [details]
> broken screen. F11 > close by clicking "X" > restart > F11 > mouse hover
> 
> F11 
> Close by clicking "X"
> Restart
> F11
> Mouse hover
> 
> Completely broken screen. 
> I think the above str is not special case.

This should be fixed. Not sure about the rest of the problems reported here. I haven't seen the black glass problem in a while.
Comment 13 brianjamos 2011-04-23 20:49:22 PDT
Looks like I'm late to the party. . .this appears to be fixed (running 4.0.1).  Also (in my opinion), I'd say that 629860 was probably a duplicate of this bug.

Thanks to all!

Note You need to log in before you can comment on or make changes to this bug.