Open Bug 618791 Opened 9 years ago Updated Last month

Add a close button to the tab overflow menu

Categories

(Firefox :: Tabbed Browser, enhancement)

enhancement
Not set

Tracking

()

REOPENED
Tracking Status
firefox66 --- affected
firefox67 --- affected
firefox68 --- affected

People

(Reporter: pwd.mozilla, Unassigned, NeedInfo)

References

(Depends on 1 open bug)

Details

(Whiteboard: [design-work-needed])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101212 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101212 Firefox/4.0b8pre

Currently if you click "List all tabs", you can switch to any tab that's listed on that window. However, by dragging a tab, you should be able to rearrange it's position on the tab strip.

Reproducible: Always
Severity: normal → enhancement
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk
Bug 596017 combines the Tabcandy & List all tabs Button Elements, so this RFE should be considered after that Merge.
RFE?
Request For Enhancement
Could be a nice feature, helping the user to be more organized in correlation with Bug 596017 - Combine the Panorama button and the List Tabs button and list all tabs+groups in List Tabs drop-down.
(In reply to comment #4)
> Could be a nice feature, helping the user to be more organized in correlation
> with Bug 596017 - Combine the Panorama button and the List Tabs button and list
> all tabs+groups in List Tabs drop-down.

Yeah, that's not really where I wanted to go with this. This should stay as far away from Panorama as possible. Panorama is nice for the people that want to use it, but ultimately this is about having a Window based (current set of tabs) with the simple ability to close as per Aero Peek overflow and reorder. It's actually a very simply request. I'd like to see the data in regards to Panorama adoption and success before we start tying simple tab management tools into it.

Also, if this is an 'RFE', why isn't it marked new?
Summary: Allow users to reorder tabs from the "List all tabs" drop-down → Allow users to reorder and close tabs from the "List all tabs" drop-down
Depends on: 596017
(In reply to comment #1)
> Bug 596017 combines the Tabcandy & List all tabs Button Elements, so this RFE
> should be considered after that Merge.

Based on the hierarchical picture drawn by XTC regarding this request. I've set the dependency.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 625894
Attached image Mockup of enhancements
Please check attachment for mockup of enhancements:

-Close button directly in list all tabs menu (allow to close tab using only one click)

-Also consider to built-in by default in browser some enhancements from wonderful extension: List all tabs Menu. (like search bar, etc..)

https://addons.mozilla.org/en-us/firefox/addon/list-all-tabs-menu/
(currently not updated to work in Firefox 4.0)
Duplicate of this bug: 771919
All the requested features are nicely implemented in add-on:

https://addons.mozilla.org/en-US/firefox/addon/all-tabs-helper/
I think these types of feature deserves to be integrated.
Why everything should be undertaken by add-ons ?
They don't change the way you browse or add functionalities dedicated to a restricted group of people, they would be useful for a lot a FF users.
But I suppose with the Australis UI release there is no hope for such features ?
Blocks: 939457
Depends on: 953217
No longer depends on: 596017
The core feature request is the close button next to each tab that appears in the "List all tabs" menu. The rest of the features are nice-to-haves.

This should be relatively easy to implement and would be very useful; and a quick-win. Add-ons are an inefficient —wrt CPU/memory usage—means to implement something as simple as this as it is better to have it done in the core code

What is the status of this feature request? Is it being taken seriously?
Mr. Horlander,

Can we have your blessing for this to happen?

I think this could help people with "tab hoarding issues" =) and as such reduce the instances of OOM crashes and such...

FWIW this very bug bite me on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140818030205 CSet: 0aaa2d3d15cc
Flags: needinfo?(shorlander)
Perhaps also reconsider on bug 361609?
Please respond  Mr Horlander!
Perhaps phlsa has some thoughts on this as well.
Flags: needinfo?(philipp)
There's the tab center project going on right now: bug 1020372
In the second phase, tab center could more or less replace that menu and add the functionality you requested.
Flags: needinfo?(shorlander)
Flags: needinfo?(philipp)
This is good news. 

The screen mock ups of Tab Centre look great but I could not see the tab close button. Perhaps it becomes visible when you hover in tab centre on a specific tab?

Also, which version of Firefox is Tab Centre to make its first appearance?
Flags: needinfo?(philipp)
(In reply to stochos from comment #18)
> This is good news. 
> 
> The screen mock ups of Tab Centre look great but I could not see the tab
> close button. Perhaps it becomes visible when you hover in tab centre on a
> specific tab?
> 
> Also, which version of Firefox is Tab Centre to make its first appearance?

Yes, close buttons are only visible on hover (otherwise having so many buttons in a row would be quite jarring).

There's no version number associated with tab center yet, but it is on the short list for implementation.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(philipp)
Resolution: --- → WONTFIX
An update on Tab Centre would be appreciated.

Has it been given a version number for release yet?

IT would be of great help to those users who have many tabs open concurrently.
Flags: needinfo?(pwd.mozilla)
(In reply to stochos from comment #20)
> An update on Tab Centre would be appreciated.
> 
> Has it been given a version number for release yet?
> 
> IT would be of great help to those users who have many tabs open
> concurrently.

I think you meant to needinfo :phlsa? I believe he's running point on the Tab Centre UI work.
Flags: needinfo?(pwd.mozilla)
Thanks Paul. 

Attention: phlsa

An update on Tab Centre would be appreciated.

Has it been given a version number for release yet?

IT would be of great help to those users who have many tabs open concurrently.
Flags: needinfo?(philipp)
(In reply to stochos from comment #22)
> Thanks Paul. 
> 
> Attention: phlsa
> 
> An update on Tab Centre would be appreciated.
> 
> Has it been given a version number for release yet?
> 
> IT would be of great help to those users who have many tabs open
> concurrently.

Tab center is still pretty high on our »we want that« list, but development hasn't started and there's no version number associated with it yet.

I agree that it would be great to have :)
Flags: needinfo?(philipp)
Hi Phil

Kindly advise on the status of Tab centre?

Has a version number been assigned as yet? Development?

There is an addon that does this but alas, I believe it causes ram/cpu overhead.
https://addons.mozilla.org/en-us/firefox/addon/all-tabs-helper/?src=cb-dl-toprated

Perhaps the code for close button from this addon could be ported in the interim?
Flags: needinfo?(philipp)
(In reply to stochos from comment #24)
> Hi Phil
> 
> Kindly advise on the status of Tab centre?
> 
> Has a version number been assigned as yet? Development?
> 
> There is an addon that does this but alas, I believe it causes ram/cpu
> overhead.
> https://addons.mozilla.org/en-us/firefox/addon/all-tabs-helper/?src=cb-dl-
> toprated
> 
> Perhaps the code for close button from this addon could be ported in the
> interim?

There's no release assigned to it at the moment, but there are active discussions around how to prioritize it. Whether or not that means that the core team will be able to work on it in the near future is hard to tell.
Flags: needinfo?(philipp)
Hi Phil
Please advise on the status of the Close Button within List All Tabs drop down menu (visible only on hover).

This RFE has a long history now and deserves to be fast tracked.

This feature will be appreciated by most users who have multiple tabs opened; also no such feature exists other browsers.
Flags: needinfo?(philipp)
Hey there, Tab Center is now available for experimental testing through Test Pilot, so you might want to try that:
https://testpilot.firefox.com/experiments/tab-center
Flags: needinfo?(philipp)
Thanks Phillip.
I tested it; but it is not what we need. It is way too elaborate. 

All we need is a close button that will appear on right of the active tab when the "List all tabs" menu of tabs appears. 

This feature will be used by most power users who generally have many tabs open.
Flags: needinfo?(philipp)
Hi Again
It has sort of been implemented in a Firefox browser fork. 
https://forum.palemoon.org/viewtopic.php?t=12164

In particular see screen shot here.

https://forum.palemoon.org/download/file.php?id=5356&sid=3579b24e29432330b091e26bac28735b&mode=view

I think the implementation that I'm suggesting will be cleaner. 
Thanks
Reopening and reducing this to the issue of having a close button.
We'll need to come up with a spec for that.
Status: RESOLVED → REOPENED
Flags: needinfo?(philipp)
Resolution: WONTFIX → ---
Summary: Allow users to reorder and close tabs from the "List all tabs" drop-down → Add a close button to the tab overflow menu
Whiteboard: [design-work-needed]

I did a quick prototype of this. If there's still interest I'm happy to finish implementing it. Here's a video of the current approach in action https://www.dropbox.com/s/fbv1xen8j7nuixr/alltabs-close.mov?dl=0

I made the close button always visible since otherwise it's not clear what the interaction with the other "secondary buttons" (like the sound playing button) should be.

Also at the moment the all tabs button (down arrow that opens the menu) only appears after a threshold of tabs have been created, and disappears when the tab count gets below that threshold. This leads to weird behaviour when closing tabs from the menu: if you close enough tabs then the menu and the button disappear. Poof.

This is why I stopped reporting bugs on Firefox. I still get emails from bugs / new feature requests I reported EIGHT YEARS AGO and the developers are still trying to figure out whether to implement the change / who to assign the code creation to.

Finally!!1 Does the video count as an anti-rickrolling? :D

In the meantime, Tab Center Redux works in a pinch (Ctrl+Shift+O on Windows).

Duplicate of this bug: 1538721

(In reply to Alessandro Decina from comment #31)

I did a quick prototype of this. If there's still interest I'm happy to finish implementing it. Here's a video of the current approach in action https://www.dropbox.com/s/fbv1xen8j7nuixr/alltabs-close.mov?dl=0

I made the close button always visible since otherwise it's not clear what the interaction with the other "secondary buttons" (like the sound playing button) should be.

Also at the moment the all tabs button (down arrow that opens the menu) only appears after a threshold of tabs have been created, and disappears when the tab count gets below that threshold. This leads to weird behaviour when closing tabs from the menu: if you close enough tabs then the menu and the button disappear. Poof.

I'd love when it would look like Opera, were the close button is only visible upon hovering.

Would you ever release this on the official add ons site?

(In reply to Alessandro Decina from comment #31)

I did a quick prototype of this. If there's still interest I'm happy to finish implementing it. Here's a video of the current approach in action https://www.dropbox.com/s/fbv1xen8j7nuixr/alltabs-close.mov?dl=0

I made the close button always visible since otherwise it's not clear what the interaction with the other "secondary buttons" (like the sound playing button) should be.

Also at the moment the all tabs button (down arrow that opens the menu) only appears after a threshold of tabs have been created, and disappears when the tab count gets below that threshold. This leads to weird behaviour when closing tabs from the menu: if you close enough tabs then the menu and the button disappear. Poof.

¡Hola Alessandro!

I for one would love to see your implementation finished and attached as a patch here.

I believe this would be very helpful for all the tab hoarders out there =)

¡Gracias!
Alex

Flags: needinfo?(alessandro.d)
Duplicate of this bug: 1550578
You need to log in before you can comment on or make changes to this bug.