Previews within a group are not restored properly on startup

VERIFIED FIXED in Firefox 4.0b10

Status

Firefox Graveyard
Panorama
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: The 8472, Assigned: ttaubert)

Tracking

Trunk
Firefox 4.0b10
Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101214 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101214 Firefox/4.0b8pre

I'm experiencing 3 issues with tabcandy at startup
a) stacked groups which don't get touched  in some way are not displayed as in rotated form, instead all previews are ontop of each other
b) stacked groups that have been touched once display all tabs in circular fashion instead of just the first few (imo this actually is better... but it's inconsistent behavior)
c) preview thumbnails are not restored without rendering the pages

I suspect this is due to the large number of tabs (300+ atm) that i'm using.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
Created attachment 497812 [details]
broken tabcandy view after startup

This screenshot illustrates all 3 issues. Most tabs don't have thumbnails even those that did before restarting firefox. And untouched or touched-once stacks have a broken layout.
(Reporter)

Comment 2

7 years ago
Issue A) and B) are covered by bug 619161

iangilman pointed out for issue C) that the slow rendering of previews and the fact that this doesn't happen in the background means i have to leave the panorama view open for several minutes until all previews are rendered, but even if i do that and then restart firefox the previews are not restored from cache.
Blocks: 598154
Depends on: 619161
The latest patch for bug 615954 may help fix this bug.
Depends on: 615954
Assignee: nobody → tim.taubert
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 4

7 years ago
C) has been fixed as far as i can tell
B) is covered by bug 622835 

this leaves A)
Depends on: 622835

Comment 5

7 years ago
bugspam (moving b9 to b10)
Blocks: 608028

Comment 6

7 years ago
bugspam (removing b9)
No longer blocks: 598154
No longer depends on: 615954
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
OS: Windows 7 → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
Version: unspecified → Trunk
verified with minefield build of 20110217

A? WFM as well.

Updated

7 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.