Closed Bug 620507 Opened 9 years ago Closed 9 years ago

mozilla-central/mozilla-2.0 l10n release mozconfigs are using the wrong update channel

Categories

(Release Engineering :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(blocking2.0 -)

RESOLVED FIXED
Tracking Status
blocking2.0 --- -

People

(Reporter: jbecerra, Assigned: bhearsum)

References

Details

Attachments

(2 files)

While testing l10n spot checks I noticed that the none of the localized Windows builds show the feedback button when you launch them. So if you are a first time 4beta Windows user with a localized beta 8 build, it looks like you won't be able to submit feedback.

This is a regression from beta 7, and it is a blocker.

Steps:
1. Install one of the localized Windows candidate builds for beta 8
2. Launch with a clean profile

Expected: Feedback button

Actual: No Feedback button shown, but if you go to about:addons the extension is listed and enabled.

Could this be an l10n repackaging issue?
blocking2.0: --- → ?
Is this a DUP of bug#620053, which was fixed this morning?
Blocks: 615555
This is not a dupe of bug 620053, because that one happened when updating. This is for plain, first time installation.

More info: the feedback menu option under the Tools menu isn't there.
The error console shows this:

Errore: entità non definita
File sorgente: chrome://testpilot/content/feedback-browser.xul
Riga: 21, Colonna: 3
Codice sorgente:
  <toolbarbutton type="menu" id="feedback-menu-button"
The customization panel does not show the feedback button option either.
blocking2.0: ? → beta8+
There were similar problems with the repacks (same error). Does the feedback extension need to be rebuilt/repacked with the fixed build system step/merge locales script?
The feedback locale simply doesn't exist in the installer, I don't really know how the repacking works to be able to guess why.
I don't know enough about the build system to answer that question about Feedback.
I'm rebuilding the 'it' locale for 4.0b8 using the old repack code to either verify or rule out it as the cause.
From irc, juanb confirmed that the feedback button *does* work correctly for linux, mac builds.
Re: The test pilot error log file attached in comment 5 --

I just read through it, and it shows everything *but* the overlay is working fine -- all the JS code and networking stuff etc. for Feedback is still happening correctly, it's just not displaying anything to the UI because the overlay failed.
About the Feedback submenu in the Tools menu not being there -- it's defined later in the xul overlay than the toolbarbutton. So if the overlay process is failing on the toolbarbutton as indicated in comment 3, then that probably also explains the absence of the submenu as well.
Summary: feedback button doesn't show on Windows 4b8 candidate builds → feedback button doesn't show on localized Windows 4b8 candidate builds
Attachment #498859 - Attachment mime type: application/octet-stream → text/plain
Another issue with the new repack code. Moving to RelEng.
Component: General → Release Engineering
Product: Firefox → mozilla.org
QA Contact: general → release
Version: Trunk → other
Need an owner and b8 by xmas or coal in your stockings!

/be
Assignee: nobody → bhearsum
Christian, can you make a call here?

/be & damons (at a bar)
We aren't blocking on this. Merry Christmas! Beta 8 for all! Well, maybe not for users wanting to download win32 localized builds from Mozilla.com...jury's still out for them w/o additional info :-)
blocking2.0: beta8+ → -
(In reply to comment #16)
> We aren't blocking on this. Merry Christmas! Beta 8 for all! Well, maybe not
> for users wanting to download win32 localized builds from Mozilla.com...jury's
> still out for them w/o additional info :-)

Bug # or it didn't happen.

/grinch
Can this bug be closed?

/be
Nope. The issue is still outstanding. We haven't got to the root cause, only narrowed it down to the build system. It has been decided the issue isn't severe enough to prevent beta 8 though.
Digging a bit in the source for possible reasons, does that mean that the MOZ_UPDATE_CHANNEL was not "beta" during the windows repacks, but on the other platforms it was?

I checked the german unsigned candidate build 1 zip, firefox/defaults/pref/channel-prefs.js sets the update channel to beta. Probably not touched during the repacks at all, too.
Those are indeed the right files, and that indeed seems like the issue :-(. I'll verify it.
Confirmed. Fixing the update channel in the l10n-mozconfig to be "beta" fixes the feedback extension in beta 8 repacks. The good news is that despite it being wrong in the mozconfig, the repacks with the broken Feedback extension are still using the "beta" channel when checking for updates.
Updating summary.
Summary: feedback button doesn't show on localized Windows 4b8 candidate builds → mozilla-central/mozilla-2.0 l10n release mozconfigs are using the wrong update channel
I grepped across all of the release mozconfigs for additional wrongness and didn't find any in any of mozilla-1.9.1, mozilla-1.9.2, mozilla-central, or mozilla-2.0. There's a 64-bit Linux release mozconfig in 1.9.2 using "beta" but that's not something we ship.
Attachment #499010 - Flags: review?(rail)
Attachment #499010 - Flags: review?(rail) → review+
Comment on attachment 499010 [details] [diff] [review]
fix update channels in l10n mozconfigs

changeset:   3674:6d33580c6a24
Attachment #499010 - Flags: checked-in+
This will be fixed going forward.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 620720
My feedback still isn't working, should I rollback to b7?
This will work again in update 9. I suggest that you stick with b8, overall it's the better version of the two.
Feedback button works perfectly well in my copy of Beta 8. It's one of two "known issues" that were not a problem. You probably should update to only be problems for SOME users.

I am using an existing profile, however. Perhaps that could be a workaround--create the new profile in beta 7.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.