IMAP online search fails silently

RESOLVED FIXED

Status

defect
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: mnyromyr, Assigned: neil)

Tracking

Trunk
Other
Other
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

9 years ago
Both SeaMonkey and Thunderbird trunk.

If I do an advanced search (online) for an IMAP account I'm not yet logged in to, the search silently fails. No dialog comes up, asking for my credentials.
blocking-thunderbird5.0: --- → ?
Are you talking about problem of bug 546925?
Reporter

Comment 2

9 years ago
Hm, maybe, not sure.
The problem here is that any online search would need to trigger a login prompt, which doesn't appear. This might be caused by 546925's not searching online at all...
(In reply to comment #2)
> The problem here is that any online search would need to trigger a login prompt, which doesn't appear.

Current online search after Gloda is next, if I understand correctly.
- Quick search never uses online search after Gloda.
- Edit/Find/Search Messages(name of Tb) never does do online search,
  even if 'Run search on server' is requested(bug 546925).
- However, online search is executed if Saved Search folder(Virtual Folder),
  as far as search target folders are IMAP folders only.

No IMAP folder access is invoked by Tb even when "online search" is requested by Saved Search Folder(Virtual Folder)?
If so, search target folder is mixture of local mail folder, IMAP folder of offline-use=on, and IMAP folder of offline-use=off?

You do not request "Save Password" for any IMAP account?
Reporter

Comment 4

9 years ago
(In reply to comment #3)
> Current online search after Gloda is next, if I understand correctly.
> - Quick search never uses online search after Gloda.

SM doesn't use Gloda, so that should not matter.
(If it does, it's a bug!)

> - Edit/Find/Search Messages(name of Tb) never does do online search,
>   even if 'Run search on server' is requested(bug 546925).
> - However, online search is executed if Saved Search folder(Virtual Folder),
>   as far as search target folders are IMAP folders only.

Not really. For this to work, the IMAP access would have to prompt me for my password, which it does not.

> If so, search target folder is mixture of local mail folder, IMAP folder of
> offline-use=on, and IMAP folder of offline-use=off?
> 
> You do not request "Save Password" for any IMAP account?

New profile, IMAP-offline=off for all IMAP, checked all folders that this is true and that there is no data, no saved passwords.

Comment 5

8 years ago
I don't think we're actually trying to run the search online, despite the state of the check box.

Comment 6

8 years ago
I think the msgWindow that's getting passed to the search url doesn't have a doc shell that supports nsIAuthPrompt, so we fail to get the password. See nsMsgIncomingServer::GetPasswordWithUI().

Thunderbird also has the issue that we never try to run the search online because of this line:

http://mxr.mozilla.org/comm-central/source/mail/base/modules/searchSpec.js#439
Assignee

Comment 7

8 years ago
(In reply to comment #6)
> I think the msgWindow that's getting passed to the search url doesn't have a
> doc shell that supports nsIAuthPrompt, so we fail to get the password. See
> nsMsgIncomingServer::GetPasswordWithUI().
That's easy enough to fix, just set .allowAuth to true on it.
Assignee

Comment 8

8 years ago
Compare bug 267485.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #514758 - Flags: review?(mnyromyr)
Assignee

Comment 9

8 years ago
(In reply to comment #8)
> Compare bug 267485.
Sorry, should be bug 267486.
Component: Search → MailNews: General
Product: MailNews Core → SeaMonkey
QA Contact: search → mail
Reporter

Comment 10

8 years ago
Comment on attachment 514758 [details] [diff] [review]
Proposed patch

Yay!
Attachment #514758 - Flags: review?(mnyromyr) → review+
Assignee

Comment 11

8 years ago
Pushed changeset 675814419cd8 to comm-central.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Sorry for noise, I need to reset a flag :-(
Component: MailNews: General → General
Product: SeaMonkey → Thunderbird
blocking-thunderbird5.0: ? → ---
Component: General → MailNews: General
Product: Thunderbird → SeaMonkey
You need to log in before you can comment on or make changes to this bug.