Closed Bug 620695 Opened 12 years ago Closed 12 years ago

Terms entered in search field from http://bugzilla.mozilla.org are not considered

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(fennec2.0b4+)

VERIFIED FIXED
Tracking Status
fennec 2.0b4+ ---

People

(Reporter: anamaria.moldovan, Assigned: blassey)

References

()

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b9pre) Gecko/20101221 Firefox/4.0b9pre Fennec /4.0b4pre

Terms entered in search field from http://bugzilla.mozilla.org are not considered.

Device: Motorola Droid 2 (Android 2.2)

Reproducible: Always

Steps to Reproduce:
1. Go to Bugzilla 
2. Tap on the search field
3. Enter a search term (eg: "twitter") and press "Quick search" button.
    

Actual Results:  
A message box saying: "Please enter one or more search terms first".

Expected Results:  
A page with the search results.
OS: Other → Android
Hardware: Other → ARM
Is this because you did not press the "Search" button on the virtual keyboard? I have noticed that the text entered via the keyboard is not sent to the textbox as you type.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 607504
Status: RESOLVED → VERIFIED
Duplicate of this bug: 621914
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 607504
Attached patch patch (obsolete) — Splinter Review
This patch commits the composition when the text box is un-focused.
Assignee: nobody → blassey.bugs
Status: REOPENED → NEW
Attachment #500924 - Flags: review?(mwu)
tracking-fennec: --- → 2.0b4+
Duplicate of this bug: 621633
Comment on attachment 500924 [details] [diff] [review]
patch

>diff --git a/embedding/android/GeckoAppShell.java b/embedding/android/GeckoAppShell.java
>--- a/embedding/android/GeckoAppShell.java
>+++ b/embedding/android/GeckoAppShell.java
>@@ -255,6 +255,7 @@ class GeckoAppShell
>             break;
> 
>         case NOTIFY_IME_FOCUSCHANGE:
>+            GeckoApp.surfaceView.inputConnection.finishComposingText();
>             GeckoApp.surfaceView.mIMEFocus = state != 0;
>             IMEStateUpdater.resetIME();
>             break;

I think it's better to call finishComposingText under NOTIFY_IME_RESETINPUTSTATE instead of NOTIFY_IME_FOCUSCHANGE
Attachment #500924 - Flags: review?(mwu) → review?(jimnchen+bmo)
Attached patch patchSplinter Review
(In reply to comment #7)
> Comment on attachment 500924 [details] [diff] [review]
> patch
> 
> >diff --git a/embedding/android/GeckoAppShell.java b/embedding/android/GeckoAppShell.java
> >--- a/embedding/android/GeckoAppShell.java
> >+++ b/embedding/android/GeckoAppShell.java
> >@@ -255,6 +255,7 @@ class GeckoAppShell
> >             break;
> > 
> >         case NOTIFY_IME_FOCUSCHANGE:
> >+            GeckoApp.surfaceView.inputConnection.finishComposingText();
> >             GeckoApp.surfaceView.mIMEFocus = state != 0;
> >             IMEStateUpdater.resetIME();
> >             break;
> 
> I think it's better to call finishComposingText under
> NOTIFY_IME_RESETINPUTSTATE instead of NOTIFY_IME_FOCUSCHANGE

that works
Attachment #500924 - Attachment is obsolete: true
Attachment #501360 - Flags: review?(jimnchen+bmo)
Attachment #500924 - Flags: review?(jimnchen+bmo)
Comment on attachment 501360 [details] [diff] [review]
patch

Thanks!
Attachment #501360 - Flags: review?(jimnchen+bmo) → review+
pushed http://hg.mozilla.org/mozilla-central/rev/db4d73bcabf0
Status: NEW → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b13pre) Gecko/20110317 Firefox/4.0b13pre Fennec/4.0b6pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.