Form helper: deletes characters, doesn't allow backspace in user id field

RESOLVED DUPLICATE of bug 620695

Status

Fennec Graveyard
General
RESOLVED DUPLICATE of bug 620695
7 years ago
4 years ago

People

(Reporter: tarend, Unassigned)

Tracking

Trunk
ARM
Android

Details

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
Created attachment 500209 [details]
User ID entered

found on 20101229 nightly on Droid II and N1 (see bug 621642)

(1) go to live.com (also seen on ebay.com and other sites)
(2) tap into user id field, enter an ID with a . or _, e.g. user@email.com (com remains underlined)
(3) tap into password field, enter password

Result: in some cases, the content of the user id field gets truncated to user@email
Expected: user id remains unchanged

(4) tap back into user id field to correct the entry

Result: DEL button (VKB and physical keyboard) doesn't work
Expected: DEL button should do backspace on the field entry
Workaround: type any letter, which appears at the beginning or in the middle of the entry, then DEL works again
(Reporter)

Comment 1

7 years ago
Created attachment 500210 [details]
Tap into password field - user id entry drops ".com"
(Reporter)

Comment 2

7 years ago
Error console shows no errors but several CSS Warnings (error in parsing value for line-height, unknown property 'text index', etc.)
Comment on attachment 500209 [details]
User ID entered

Thomas, I can't really see what's going on here, can you get a better screen shop please? (http://blog.lassey.us/2010/09/13/android-screen-shots-without-rooting-your-phone/)
s/shop/shot
(Reporter)

Comment 5

7 years ago
Sorry about the blurry web cam captures. Let me attach higher res pictures showing how everything after the . or _ in the user id field gets dropped when you tap into the password field. Also seen here: no arrows in the gray form helper bar. And: when you tap back into the user id field (to correct the truncated entry) DEL doesn't work, as described above.
No errors in console.
(Reporter)

Comment 6

7 years ago
Created attachment 500270 [details]
User ID entered (hi-res pic)
(Reporter)

Comment 7

7 years ago
Created attachment 500271 [details]
Tap into password field truncates user id entry (hi-res pic)

Updated

7 years ago
tracking-fennec: --- → ?
seems like a dupe of bug 620695
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 620695
(Assignee)

Updated

4 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.